Jump to content
Cyclone Boom

STEX Issues - Community Report Thread

64 posts in this topic Last Reply

Recommended Posts

I'll add in another URL straggler from 2004:

 

In the description, there is a link for discussion, questions, and comments:

http://www.simtropolis.com/idealbb/view.asp?mode=viewtopic&topicID=48119

However, that link uses a pretty old URL, leading to a page not found.  Pasting the topic ID of the broken URL into a current URL brings a working forum thread from 2012:

http://community.simtropolis.com/forums/topic/48119- /           

I'm not actually sure if that is the thread originally intended to be linked, for while the brief discussion does refer to toroca's file, it reads as after-the-fact rather than contemporaneous to the file.  That forum thread is also full of broken links lost in some site changing and processing and which now just try to reload the thread.

toroca's Opera House Fix is commonly mentioned as an important fix in many popular lists of recommended SimCity 4 mods, so its STEX description might be a candidate for hands-on fixing.

________

This next is perhaps outside the scope of the STEX-specific issues of this thread, but toroca's included readme.html also contains outdated and broken URLs to Simtropolis forum threads.  They are not necessarily critical links, and other broken links in the readme point to sites outside the control of Simtropolis, but it may be useful to be aware of these in the discussion of automatic redirects or creating pinned guides on how to find forum threads with obsolete URLs.

 

Share this post


Link to post
Share on other sites
9 minutes ago, Odainsaker said:

Pasting the topic ID of the broken URL into a current URL brings a working forum thread from 2012:

http://community.simtropolis.com/forums/topic/48119- /           

Seems to me updating the description to have the linky point there is way better than having a broken link. I'm sure one of our STEX Moderators will be along soon and fix this up. (And I'd guess a simple note in the file description about the readme.html having old, broken links would be sufficient to alert peeps to that part.) I'll defer to the experts on how they want to handle this. *;)

Share this post


Link to post
Share on other sites
  • Original Poster
  • 1 hour ago, Odainsaker said:

    However, that link uses a pretty old URL, leading to a page not found.

    Seeing as it points to the 'www' location, we might be able to do a rewrite to direct this old URL to the correct format. Just as has been done recently for older STEX file links. Or better still as a permanent solution, updating these instances via a database command. (That's something we're looking into.)

     

    1 hour ago, Odainsaker said:

    I'm not actually sure if that is the thread originally intended to be linked, for while the brief discussion does refer to toroca's file, it reads as after-the-fact rather than contemporaneous to the file.

    Yes, although there is reference to the Opera House Fix, it does seem unlikely given the file was uploaded 8 years before the thread was created.

    It's possible those old links are so outdated (back when ST used the IdealBB forum software), that the ID numbers no longer correspond to the IPS equivalent today. Along with readme files, this means it'd require a best guess and a manual update as Cori said.

     

    1 hour ago, Odainsaker said:

    That forum thread is also full of broken links lost in some site changing and processing and which now just try to reload the thread.

    It seems those URLs are empty as follows:

    <a href="" rel="external nofollow noopener" target="_blank">Opera House Fix</a>

    There is no target in the href, so it just directs to the currently viewed page being the thread.


    Again with this data missing and without a pattern, it rules out an auto-redirect or batch process. Therefore the only viable way forward is for us to manually fix them on demand, providing it's possible to determine the correct target location.

    Share this post


    Link to post
    Share on other sites

    Unfortunately, when I was creating my STEX link updater, I did have a look into converting topic links, however it seems the IDs for topics have changed over the years, so older topic links can't be converted into the new format.

    I'm also unable to find the actual support topic the link is supposed to direct to, looking at @toroca's topics there doesn't appear to be one that matches.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections