Jump to content
Sign in to follow this  
shaun600

Display Issues with Windows 7

9 posts in this topic Last Reply

Recommended Posts

Hey guys

 

Apologies if this has already been asked countless times before, but it's annoying the hell out of me. I recently updated my laptop from Vista to Windows 7 and it's completely wrecked the display settings. After mucking around with the shortcut target I've managed to make it widescreen however the whole display has become squashed in.. SC4 worked perfectly fine with Vista, but 7 has been a frustrating mess.

 

Can this be fixed?, and how?... I took a screenshot, though it doesn't really show the problem well.

 

System - Windows 7 Home Premium

Processor - Intel Core Duo 2.10GHz

Display -ATI Mobility Radeon HD 4500 Series

Resolution - 1366 x 768

 

Version - Sim City 4 Deluxe (Origin)

 

xq0v.jpg
 
 
Cheers,
 
P.S First time poster, long time lurker!

Share this post


Link to post
Share on other sites

Hi there,

 

Do you mean how the menu appears pushed over to the left side? If so, this is quite normal when running off a higher resolution - where it appears more pronounced.

You could lower it (in the shortcut parameter) to make the menu appear wider. But this will sacrifice image quality. See here for a list of supported resolutions.

 

Here's mine for comparison, running at 1600x900:

 

AoUrK7H.jpg

Share this post


Link to post
Share on other sites

Here is one of mine at 1920 x 1080.  I am also using a mod that changes the appearance of the GUI.
 
QWzEF78.jpg

Because of the very high resolution, I keep a magnifying glass handy to the screen.  If you click on the image above, your system will try to display it as originally shot.

Share this post


Link to post
Share on other sites
  • Original Poster
  • Thanks guys for your replies.

     

    Hi there,

     

    Do you mean how the menu appears pushed over to the left side? If so, this is quite normal when running off a higher resolution - where it appears more pronounced.

    You could lower it (in the shortcut parameter) to make the menu appear wider. But this will sacrifice image quality. See here for a list of supported resolutions.

     

    Here's mine for comparison, running at 1600x900:

     

    I can live with the smaller menu. Though the actual game display has become more narrow despite using all different resolution settings, including the standard SC4 settings. Plus the only resolution I've found to make it widescreen is my actual screen resolution 1366 x 768 (16:9), everything else goes to box size. However the picture becomes grainy and again narrow. 

     

    I've tried playing around with the Compatibility mode changing it to XP and Vista with no luck. All I want to do is play the game in widescreen and not have the game display narrowed nor grainy. It was perfectly fine in Vista, but not Windows 7 :/

     

    Is there a patch for Windows 7 or anything?

    Share this post


    Link to post
    Share on other sites

    The game resolution options by default only give you option 4x3 standard (outdated) resolution. But it doesn't mean SC4 doesn't support widescreen. Just add -CustomResolution:enabled -rwwwwxhhhxdd (replace the w, h, and d with the resolution you want). But make sure you add it after the closing ".

    Share this post


    Link to post
    Share on other sites

    Here is one of mine at 1920 x 1080.  I am also using a mod that changes the appearance of the GUI.

     

    QWzEF78.jpg

    Because of the very high resolution, I keep a magnifying glass handy to the screen.  If you click on the image above, your system will try to display it as originally shot.

    Sorry for the off-topic question, but I don't remember where to find the mod you talked about....Could you send me the link please ?

     

    EDIT: I found it !


      Edited by B.C builder  

    Share this post


    Link to post
    Share on other sites

    The game resolution options by default only give you option 4x3 standard (outdated) resolution. But it doesn't mean SC4 doesn't support widescreen. Just add -CustomResolution:enabled -rwwwwxhhhxdd (replace the w, h, and d with the resolution you want). But make sure you add it after the closing ".

     

    I think this is the solution that you're looking for TC.

     

    I assume you'd like to use your monitor's native resolution, so just figure out what that is if you don't already know, and pop the above into your launch options. For instance, I'm running my SC4 at 1440x900 with 32 bit colour, with the following command in my launch options: -CustomResolution:enabled -r1440x900x32

    Share this post


    Link to post
    Share on other sites

    This doesn't look any different from what I play with. Vista has always been a crappy software. Did you switch computers or did you simply upgrade?

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections