Jump to content
11241036

MMP Issue: Game skips one step

5 posts in this topic Last Reply

Highlighted Posts

I'm suffering from a weird issue related to placing MMP's: Whenever I'm trying to place a flora item by clicking once, the game always skips one item in the MMP cycle. In other words: If there's a cycle of 6 MMP's, I can only place item 2, 4, and 6 on a city tile. This does only count when I'm clicking once, when dragging, the game only places the first item.

I should note that I'm suffering from this issue since I've bought a new PC, along with an edition of Windows 10 and a digital copy of SimCity Deluxe from Amazon. I can't tell if this issue is related to my new machine, Windows 10, or the digital copy from Amazon.

Share this post


Link to post
Share on other sites

I have the Amazon version of SC4 and do not have a problem like the one you described.  Based on your description, could it be some setting with the mouse software that treats a single click as a double click.  That's the first thing that comes to mind.

Share this post


Link to post
Share on other sites
  • Original Poster
  • @SimCoug I've checked all settings related to my mouse and could not find any setting like this. Also, this issue only occurs while playing SC4 and furthermore, only and exclusively while placing MMP's.

    Share this post


    Link to post
    Share on other sites

    Another user was recently also having problems with MMPs, although not identical, very similar problems:

    At the time I could only conclude that something was probably wrong with the user's setup, given that I'd never heard of the problem elsewhere. Frankly, that's still a possibility, although I know you do know what you are doing technically, I wouldn't want to rule it out.

    Of course 2 cases of similar weirdness may be a compatibility issue somewhere, even thought it's hard to understand why that just affects the "Flora Cluster type" functionality. Given that we're looking at two versions of Windows, both versions many people play with without problems, I think we can probably rule out the O/S. Could it be related to graphics drivers?, seems a long shot, since this isn't affecting graphics/rendering, but actual code function.

    So it would appear some hardware/software in your machine may be causing an incompatibility with some code/library etc that is preventing the intended behaviour. Without more data regarding the problem, all I can suggest is try the usual suspects.

    • Make sure the game is patched fully (I know, it's a digital version, but check the version number to be sure).
    • Remove your plugins suite and test, maybe with a single, test MMP, ideally with Maxis props only.
    • Try updating your drivers for things like sound/video cards and other devices used by Direct X.
    • Switch the rendering mode to software, it's worth a shot.
    • Disable all security/antivirus tools completely. Best to disconnect from the internet whilst testing.
    • After that, I'd try disabling all background apps on your PC.
      Under Win7 this would be using the MSCONFIG application to disable every program, service and startup application you could, whilst still allowing SC4 to run. Not sure if you get MSCONFIG on Win10, but there should be an equivalent one hopes. That would be your baseline test, if the problem remains, no point continuing. But if somehow it went away, then you'd need to manually enable apps one at a time until you found the culprit.

    The problem here is that the behaviour is very odd and it really doesn't make sense:

    On 16/06/2017 at 4:44 PM, rsc204 said:

    how is it that the game can still read the sequence to switch between the first few items, but then fails for items beyond three? (or in this case can read every second exemplar). We know the code is still switching between IDs, i.e. the expected behaviour. So if that's working why does it stop at a certain point? If the properties inside the MMPs are unmodified, then the links should still be there. If somehow the game couldn't read IDs properly, then your issue would not be limited to MMPs, it would frankly cause huge problems, since everything relies on IDs.

    That was one of my conclusions with the last problem I linked to. Not the same as yours, but related to incorrect function of MMP exemplars. Odder with your problem is that the first item never appears. Without that exemplar being read, it would be impossible for the MMP to function in the first place to show the second item. Similarly, the linked IDs are the order of the exemplars being read, which must be happening for it to skip showing a given flora item. The code must be reading the exemplars of those items it doesn't show, or it wouldn't link (jump) to the next one's ID. So it is reading all the data, but simply skipping every other objects display?

    16 hours ago, SimCoug said:

    Based on your description, could it be some setting with the mouse software that treats a single click as a double click.

    You know that resonates totally with the problem you are seeing. We could look at the more complex problems, but I really think SimCoug is on the money, it's simply the most probable explanation here. Perhaps the driver doesn't like archaic versions of DirectX? Perhaps your mouse has super-sensitive buttons?

    (Or like one I got recently which double clicks when pressed once, OK that was a cheap nasty second hand mouse I got free with a laptop, but still)...

    It just seems that two clicks = every other item shows, that's simply too neat to ignore as the most likely cause.

    If that's not it though, things get very tough frankly to diagnose, let alone fix. Such problems are rarely going to be hardware/driver based issues. Of course code is all written in different languages and yes something could break compatibility with the libraries function that enabled that code. But to do so for such a small and specific part of the whole is very odd indeed. You may find it nigh on impossible to track the real cause with any certainty. Especially since we don't know enough about how the game works at a code level to offer targetted advice. What I'm setting myself up to say here is, if you can't get it working easily, you most likely never will. As such, I'd look to try running the game in a VM or some other work-around if you get to that point.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • @rsc204 Thank you for your advice. I've tried all or your suggestions, but none of them worked.

    • My game is fully patched (1.1.641).
    • The problem still persists on an empty Plugins folder.
    • All device drivers are up to date.
    • Switching to Software Rendering Mode didn't help, either, nor disabling antivirus tools, or disabling all background apps.
    • Regarding my mouse: I'm using the same mouse that I've been using on my old machine. I have DirectX 12. I've also checked all mouse settings and couldn't find any setting treating a single click as double-click (besides, that would affect the function of my mouse just anywhere else, and anywhere else, my mouse works fine).

    Edit: Fortunately, there's a good temporary workaround: I'll just remove the Flora Clustering ability from selected MMP's, thereby making several single MMP items out of one MMP cycle, if I want more control about which MMP I'll get in particular.


      Edited by 11241036  

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Similar Content

      • By Simmer2
        SM2 Dry Stone Walls  (Muro Secco)
        Are a type of wall made with stones found locally and assembled without mortar thus the name Dry Wall (Muro Secco)
        They are mostly found in European countries. Unfortunately they are the remnants of a lost art. No one makes them anymore.
        These walls were used to "fence in" properties and also to provide shelter for livestock.
        I tried to provide almost all possible combination in order to make just about any shape you may need.
        Orthogonal, diagonal, round corner, sharp corner, diagonal to orthogonal, broken walls, overhanging diags and orthos, open gates, closed gates, even gates on diagonals and more!
        There are also a few stone structures to complement the set and one special transition piece which will allow you to follow heights differences of 7.5 meters. (slope friendly). Please use the road lifter tool in the NAM menu to set height to 7.5 meters when using the transition piece for best results.
        Included are 4 lots (Orthogonal only) that will make it possible to create EDGE to EDGE scenes.
        And last but not least, I have included 2 MMP files based on the model and texture of the wall, for those hard to reach areas. They are slope friendly and you can even place them under water if you wish.
        I created a custom icon set with clear and easy to recognize symbols, You will find all 42 lots in the park menu.
        No cost to plop, maintain and bulldoze. Neutral lots. The lots have no base textures. Just plop them and dress them with your favorite MMP.
        No Dependencies.
        Simmer2
      • By Huston
        Hey, I just thought I'd give this a shot and see if anyone could possibly point me out to a tutorial for creating MMP/Mayor Mode Ploppables? There's virtually nothing on the internet (that's obvious) that I can find regarding the conversion of props for use as MMP or how to even do that? I've been wondering how to do this since I first started BATing sci-fi props and would totally appreciate any help anyone could provide on this
      • By VIP Team
        This pack contains seasonal plopables plant, and various decorative elements for your landscape. The seasonal props has the S logo.
        Note: for fitting with other seasonal items, props need to be planted the 1st September ot the 1st Marsh. We do not recommand you to use seasonal trees on growable LOTs.
        The Pack are included:

         DEPENDENCIES
        You need to have in your plugins:
        VIP CarPackMMP vol1
        Seasonal Flora Patch for All Terrain Mods
        INSTALLATION
        Auto Installation: Double-click the installer file to start the installation. The program will guide you through the process. You can change the default installation path, but we strongly suggest to keep the standard folder in order to make future updates and additions easier.
        MAC Users: File Juicer should enable you to use this installer package. If it's ZIP archive it is necessary to make the same manipulation that during installation manual (see above).
         
        CREDIT AND FEEDBACK
        Models by Manchou and Vnaoned. Modding by Badsim.
        If you have questions or problems you can leave us a message SC4devotion thread

      • By paeng
        A Painter's Patch
        This will help the landscape painters among us - once installed you will be able to brush any flora MMPs right up to the shore and into the water of lakes, ponds, streams and rivers using ploppable water coming from SimPeg... You can camouflage any fixed shoreline or just create your own shores completely, no more plain straights and empty curves... ;-)
        Aside from tweaking the shore lines you can 'paint' MMPs inside the water without using any extenders or other workarounds.
        This patch will work for:
        PEG Ponds
        PEG Streams
        Note: This is not intended for use with the older 205 version of the streams, which have different IDs.
        PEG PPonds (Tahoe, including PEG Culverts and PEG Fords)
        PPond Canal Kit (inc. Docks, Locks and Bridges)
        SPAM Irrigation Canals (SPIC)
         
        DEPENDENCIES
        ~ none ~
        Though the patches only make sense if you use any of the listed packages ;o)
         
        DEVELOPER NOTES
        After unpacking you'll find a folder 'zzz_Free_Waters' - it doesn't really need to be the very last thing to load, but make sure it loads after all ponds, streams and pponds...
        For a bonus the folder contains new larger water tiles as well - for the Ponds an additional 4x4 piece, for the Tahoe additional 2x2 and 4x4 pieces. They are in the 'Parks' menu along with the other water tiles.
        Note: The installed patch will NOT take effect on already plopped landscapes. You need to either re-plop existing ponds and streams or just save it all for your new developments ;o)
        And a word of caution - take it easy, brush by brush... else, before you know it, there is no more water to be seen!
         
        SUPPORT
        For questions and support, please see here:
        Happy painting ;o)
      • By Takingyouthere
        There's some big infrastructure projects that I'm just about ready to present, but before that here's an extensive look at the Trueno river as it winds its way through Gravenhurst, a suburban area of the Middle East borough of Pretoria.
        Gravenhurst highlighted in red:

        Overview:






        The opposite angle:




        The idea with having white rocks on one side and not on the other is that the rock wall was constructed higher there for added protection since that's where the city is so not all the rocks get covered in algae or whatnot. Meanwhile the other side is more natural and lightly populated so the rock wall was not constructed as high, if at at. I also think changing the appearance makes it makes it look more interesting.


        South end of the river:

        Now for some, or rather a lot of close ups
        The west bank is somewhat flood prone as seen by how marshy the area is, but thankfully as mentioned the population is quite spares on that side:








        North of Manitoba Island is the mouth of Taylor creek. This creek is is one of the many streams which outflow into the Trueno river. As with many(but not all) creeks in Pretoria it was built as the area was urbanized and turned into an underground river. Which is quite typical of what happens IRL in most major cities in NA.
        The mouth Taylor creek where it emerges before joining the Trueno river:


        Water flow is normally very low except during and after a rainfall. Unsurprisingly much like a nearby abandon rail tunnel in Lindin City, underground creeks like these are very popular with local urban explorers.
        A typical view from inside the underground waterway:

        As for the more populated east side of the river, it's well protected from flooding by the rockwall - more accurately called a riprap or revetment. The popular West Coast Trail is the gravel pathway seen running along the west bank of the river:


        The trail continues down Jessica St. halfway through the town instead of directly along the waterfront. The property line of homes on Jessica st. goes right up to the riverbank here. The city had no interest in starting a prolonged and messy fight with the smug rich people living here in order to continue the path through their backyards. Home values are approx. 30% higher then similar homes on the other side of the street. All just for a having a property fronting the waterfront. The trail once again meets the riverbank at the end of Jessica St. where it then goes underneath the Rustaway bridge which carries GWR's Midland Sub(currently used):


        The Midland sub. was the second railway to cross the Trueno river overall but the first to do so within Pretoria's current city limits. This rail corridor was GWR's primary north-south rail line through the region for almost 100 years - from the time it was constructed in 1858 until the completion of Vandenburg tunnel under Cisco Bay in 1956.
        Bridge info:
        Name - The Rustaway bridge
        Type - Howe Truss
        Built in - 1919-1920 (replaced a bridge built in 1858)
        Design Life - unk
        Railway - Midland Subdivision(GWR)
        Total Length - 855ft (261m)
        Longest Span - 262ft (80m)
        Clearance - 102ft (31m)
        Average daily traffic - 0 (disused)
        Cost - unk
        unnamed trestle on the other side of Manitoba island
        Type - Wooden Trestle
        Built in - 1858
        Design Life - unk
        Railway - Midland Subdivision(GWR)
        Total Length - 427ft (130m)
        Longest Span - n/a
        Clearance - 106ft (32.5m)
        Average daily traffic - 0 (disused)
        Cost - unk



        For the record here's a few shots of how the riverbed about a year ago before I started to have fun with mmp's:



        Quite the transition yes?
        And to close out this entry, a 360 degree view of Manitoba Island:

        RE: Your Comments!
        would of replied sooner but was a little delayed by Easter.
        MilitantRadical
        Thanks, lots more like that to come!
        Mymyjp
        Hey mymy, thanks for the comment. Btw is New Manshin on hiatus?(because of C:S) No updates in a while...
        SylvioJ
        Thank you!
        amazona
        I was wondering if I made the pano's too big, glad to hear that's not the case.
        Ultimate727
        And the interchanges will only get bigger from here on out.
        Kim Sunwoo
        Awesome! They were my two favorite as well, that's why I had to put them first afterall.
    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Season's Greetings!

    xmas popup.jpg

    Thank You for the Continued Support!

    Simtropolis relies mainly on member donations to continue operating. Without your support, we just would not be able to be entering our 15th year online!  You've really help make this a great community.

    But we still need your support to stay online. If you're able to, please consider a donation to help us stay up and running, so that we can help keep bringing SimCity players together to share our creations.

    Make a Donation, Get a Gift!

    Expand your city with the best from the Simtropolis Echange.
    Make a donation and get one or all three discs today!

    stexcollection-header.png

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections