Jump to content
Sign in to follow this  
KradenX

SC4 Deluxe CTD/Large Cities Only

17 posts in this topic Last Reply

Recommended Posts

Hi. First post here. Sorry its a cry for help. I've had SC4 since 2005 and have played it on multiple OS's with a wide range of hardware. Its always had a random ctd here and there but now its very often, and annoying. 

 

I am running the most recent CAM and NAM mods with a few textures and quite a few bats, but I've checked them over and have not been able to discover any conflicts. I am running Windows 8 64-bit.

 

Don't even try to blame it on the new OS, its still an NT kernel and normally runs it fine... until I get a large city of 400k+ sims. Then bam. Shut off. I'm running it in a custom 1920x1080 resolution and have set the

 

game to only run off one core. Deluxe steam version by the way... don't use cds anymore unless I have to

 

Hardware:

Intel i5 quad 2.8GHz

8GB DDR3

120GB Solid State (Samsung)

ATI/AMD HD6970

 

I've got the minidumps if anyone knows how to really read them. Wont be back on til tomorrow... any help is greatly appreciated.

Share this post


Link to post
Share on other sites

No idea.  Does this happen on all cities or only the big ones?

 

Sounds like it might be a plugin conflict.  Are you aware that the CAM and NAM controllers conflict?  If you have them both, remove the CAM one.

 

Which version of NAM do you have?

Share this post


Link to post
Share on other sites

I've had a very very similar problem for years now, and the new NAM 31, which I'm really enjoying, seems to aggravate it more, maybe, I could be wrong. It is becoming quite frustrating at times, but I've posted my minidump and the man, Nonny Moose himself, declared it the normal dump. I have noticed if I go more than 15 minutes without saving, it's a guaranteed hang up or CTD. The only way I'm able to combat it is to save every 5-10 minutes and it's about 70-80% working so far, and that's only after reading the CTD threads backwards and forwards and finally realizing how important Nonny Moose's, essential and sage advice...

Salute CRTL+s often... Like every 5 minutes, especially if you've completed something. I've definitely learned as soon as I say to myself, Perfect, just how I want, the very next thing I do is press CRTL + s

You'll also notice sometimes the simulation will start to kinda hang up a little, get choppy, kinda too late but you really need to save, as Nonny Moose taught me, the system needs to dump or it will eat up your RAM, I've had hangs where the program was using over a million and a half bytes, and I usually can attribute it to not saving often enough, best guess and all... : ) Luck... I'm trying to solve this too, as well as Bruce over at SC4D

 

Edit: Whoops forgot to add, one of the reasons I posted was because I only play large tiles, run the same custom resolution but I don't, I repeat, I do not mess with my cores, I let it run normally... I run Full NAM 31, CAM, SPAM, have CAM & IHT fix dat packed, 1 traffic controller, and my latest plugins is about 4GB, but it's seriously been slimmed for new NAM 31, but it's already growing again, as usual : ) hehe

I get pretty regular CTD's, but I can tell when I get cities going about 150,000 on the tile, it starts to get pretty unstable, and I have to be very very gentle with the simulation, let it catch up to itself, and be very patient...

Share this post


Link to post
Share on other sites

Same issues here, also on Win8 x64, large tiles but 1920x1280, I have to save very regularly or CTD (even have quick save mapped to a mouse button) whenever I do anything and exiting to region from my main city now is 95% of the time CTD.

I have mods but not too many mainly use Nam31, RTMTV3, then rest are mainly bats with radius doubler and lots, rail to subway.

The CTD's are very random.

Have a strong feeling NAM31 is a likly cause of a few.

Tried the rail over ave as soon as I placed it down instant CTD next time I bet it wouldn't do that.

Share this post


Link to post
Share on other sites

I got rid of those crashes by altering my command line prompt increasing system memory and upgrading the video card/memory. When I did I temporarily renamed my plugin folder and uninstalled SC4. I then removed everything I could find in file folders and registry that related to SC4. Then De-fragged my hard drive where SC4 is installed before re-installing the game. The only CTD's I've had since then (over a year) has been when I forget and wave a railroad around over a station or whatever it is that causes that. It happens so fast I usually don't know what I did until it is done. 

 

Remember some laptops will not run SC4 no matter how much memory etc is installed. SC4 prefers desktop PC's. Also consider what else are you running while SC4 is running? Are they trying to use the same resources?

 

My system is nothing special by today's standards.

Windows Vista Home Premium 64 Bit

Intel Core 2Quad CPU

Q9400@2.66GHz (4 CPUs), ~2.7GHz

4094MB RAM

DX 11

 

Anyway, hope something I did will help someone else as I do know the frustration and it made me quit SC4 for a couple of years at one point.

Share this post


Link to post
Share on other sites
  • Original Poster
  • No idea.  Does this happen on all cities or only the big ones?

     

    Sounds like it might be a plugin conflict.  Are you aware that the CAM and NAM controllers conflict?  If you have them both, remove the CAM one.

     

    Which version of NAM do you have?

     

    Currently at work, so not positive but...

     

    I am using the most recent one, v31 I think? I am using the NAM controller, I didn't install the CAM one. The really frustrating problem is sometimes it crashes when I save (I too have quick save assigned to a mouse button), even if I have only been playing for 15 or 20 minutes. I'm starting to believe that it has to be one of the plugins as well because I could get up to 700k sims with no crashes AT ALL on the same system before plugins. The next chance I get I'm going to reinstall the game and then redo all of my plugins step by step.

     

    Someone mentioned defragging... Solid state drives do not require defragging, but that would be a good move normally. This game begins to take up a lot of resources with these mods...

     

    Maybe overclocking the core I'm using would help? I'd assume that 2.8 GHz would be enough even with just one core if there is RAM to back it up...

     

    I have windows 7 on a standard 750GB harddrive with SC4 deluxe also installed, same core and res parameters, but it CTDs at random now with or without plugins.

     

    The solid state makes the game run so much more smoothly but I don't know... these crashes every 10-20 minutes, especially when I hit auto save and it crashes during the save process, are very annoying. I'm not very good at SC4 but I enjoy it...

     

    Ugh. I know the coding is old and somewhat...inefficient...so ctds I expect...but this?

     

    I'm assuming Nonny Moose that you are the Mr. (or Ms.) Fix-it around here so I emplore you for help.

     

    Or anyone else. I don't know what the general consensus around here is of the newest SC but it does not appear to be my cup o' tea...

    Share this post


    Link to post
    Share on other sites

    Please open your Exception Reports folder, find the most recent *.txt file.  Open it in note pad and post the first 20 lines only.  We need some facts about your system, and this is one of the quick ways to check.

     

    And by the way, this is my command line:

     

    "C:/Program Files/Maxis/SimCity 4 Deluxe/Apps/SimCity 4.exe"  -intro:off -CustomResolution:enabled -r1920x1080x32 -d:software  -f -CPUcount:1

     

    which says run this program without the silly movie, for my 1920 x 1080 screen at maximum colour depth, use software rendering, full screen, and use only one CPU core.  The forward slashes ( / ) are due to my file system  NTFS wants backslashes ( \ ).

     

    There is a problem with the latest Intel processors which may cause trouble.  It will be fixed with NAM V31.1.  If you are on V31 consider reverting to V30.

    Share this post


    Link to post
    Share on other sites

    Here is my 20 first lines of the latest report.

     

    Exception time: 03/22/2013, at 01:06:12.

    Exception code: 0xC0000005 (-1073741819) ACCESS_VIOLATION.
    Current thread ID: 2012 (0x000007dc).
    Version information:
    Application/module path: D:\SimCity 4 Deluxe\Apps\SimCity 4.exe
    Application/module version name: SimCity 4
    Application/module version: 1.1.638.0
    System version: Windows NT 6.2
    System memory: 4096 Megabytes total, 4096 Megabytes free.
     
    Exception module:  D:\SimCity 4 Deluxe\Apps\SimCity 4.exe.
    Exception address: 0x0065ec40. Section:Offset: 0x01:0x00257c40.
     
    Registers
       EAX: 0018e068
       EBX: 0018e06c
       ECX: 00000000
       EDX: 000000c1
       ESI: 00000000
       EDI: 1585799c
     
    And my WEI:

     

     

    Processor Intel® Core i7 CPU 950 @ 3.07GHz

    Model X58A-UD3R
    System memory 12.0 GB RAM
    System type 64-bit operating system
    Number of processor cores 4 Storage
    Display adapter type NVIDIA GeForce GTX 590   Total available graphics memory 4095 MB (latest driver)
    Primary monitor resolution 1920x1200

     

    Share this post


    Link to post
    Share on other sites

    OK.  Windows 8; game loaded from disk.  Deluxe with update EP1.  You definitely need the following options set on your command line (target) in the shortcut that starts the game after the final quote of the game path:

     

    <space>-cpucount:1<space>-customresolution:enabled<space>-r1920x1200x32

     

    Where <space> is exactly one space.

     

    If you refer to my last post you can see some optional additions.

     

    Now, it is possible you are having plugin problems so try this:

     

    Rename your Plugins folder to Plugins.old and start the game.

    Open one of the cities that crashes the game, ignoring brown boxes and other plugin errors.

     

    If the game starts and runs, you have indeed something going on in your plugins suite.  If you have NAM V31 and any RHW networks, I suggest you revert to NAM V30 and RHW 5.0 until NAM V31.1 is available.  There is also trouble with the vastly extended NAM traffic controllers having to do with the latest Intel processors (I suspect a microcode problem in the processor), which is another reason to revert.

     

    You might also check to see if you have some conflicts in your plugins.  You might find that Rivit's Data Node program will help.  This can be found on SC4Devotion's LEX.  If you have not registered there, you will need to register both for the site and the LEX. (free).

    Share this post


    Link to post
    Share on other sites

    Already do the command line stuff.

     

    Dependancies seem to mainly be nam.

     

    As for nam downgrade I use some 31 stuff so ill have to wait it out.

     

    Ill try a fresh plugin folder at some stage probably for nam 31.1 and only put in what I have used etc or redo certain things to be more unified with whats already with nam rtmt etc.

     

    Also my cities don't crash the game as when I load them its random crashes while building etc.

    Also sorry to hijack ops thread but a common thread for us is probably a good thing if we are all having similar issues so we can help each other out in a single area.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Here is mine which, not surprisingly, is very similar.

    ----------------------------------------------------------------------------------------------------

    Exception time: 03/20/2013, at 22:53:20.
    Exception code: 0xC0000005 (-1073741819) ACCESS_VIOLATION.
    Current thread ID: 3540 (0x00000dd4).
    Version information:
    Application/module path: C:\Program Files (x86)\Steam\steamapps\common\SimCity 4 Deluxe\Apps\SimCity 4.exe
    Application/module version name: SimCity 4
    Application/module version: 1.1.641.0
    System version: Windows NT 6.2
    System memory: 4096 Megabytes total, 4096 Megabytes free.

    Exception module:  C:\Program Files (x86)\Steam\steamapps\common\SimCity 4 Deluxe\Apps\SimCity 4.exe.
    Exception address: 0x005b9feb. Section:Offset: 0x01:0x001b2feb.

    Registers
       EAX: 00000000
       EBX: 00020000
       ECX: 00000000
       EDX: 0000004a
       ESI: 00000009
       EDI: 81680004
       CS:EIP: 0023:005b9feb
       SS:ESP: 002b:0018f5b8  EBP:0018f7b8
       DS:002b  ES:002b  FS:0053  GS:002b
       Flags: 00010206

    -----------------------------

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • I've done a lot of testing, and my basic assumption is that with very large numbers of automata the new NAM controller runs up the processor to 100%. WHY it does this I'm not sure, but when it does top out, it crashes. And, as noted previously, his appears to only happen on multi-core Intels, specifically the i5 and i7s.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Running the simulation at the slowest speed and (oddly) saving only while its running seems to limit the crashes.

    Share this post


    Link to post
    Share on other sites

    The internal save (CTRL+s) does seem to do some garbage collection and reset things to reduce crashes.  I do one every time I change the infrastructure of the the city and at other times when I feel it has run long enough without one.

     

    After I've been doing things with puzzle pieces, I do one as well.  Sometimes in the middle of a sequence if it is complex.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Applying the slow simulation speed practice on my large cities has removed almost all crashing...its somewhat depressing though because I don't have very much time to play the game. In any case, I guess it doesn't matter what hardware you have-if you're running old code to the max sometimes it will break.

     

    Thanks for all of your support. I'm going to mark this as solved, even though it's not quite a full solution.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections