Jump to content
Sign in to follow this  
TBszmty

No Radio folder and can't change screen resolution :/

5 posts in this topic Last Reply

Recommended Posts

Since the problems with SimCity 2013 keep on going, I decided to reinstall my good ol' SimCity 4. It took me a couple of minutes to find the discs and to finish installation. I opened the game and changed the screen resolution, then I quit the game, expecting the game resolution to be ok after opening the game again. Meanwhile I downloaded NAM and the other mods I had before, and I also got the idea of downloading some SimCity 3000 mp3 so I could add them to the game too. However, when I opened the files to place the mods and the music I noticed that I only had the Plugin and Regions folders. I was able to install NAM and place the mods, but where do I put the music?

I decided to start the game again to see if this was the only issue, and when I opened it I discovered that the resolution didn't changed at all, even though I changed it from the default 800x600 to my screen resolution.

It's not much of a big deal. The game runs fast and smooth as it should, but it's somewhat of an eyesore to play with a wrong resolution, and I wanted to add some custom tracks to make the game experience even more pleasant. I don't know if it's related but I'm using a Windows 8 to play the game. I've got other games installed in this PC that (supposedly) aren't supported, yet I don't have the same issues.

 

Please tell me if I can do something to fix it.

EDIT: I'm using SimCity 4 Deluxe Edition.

Share this post


Link to post
Share on other sites

To use custom music, first go to:

 

"C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Radio\Stations"

 

Here there are two folders, you may use one or both of them, depending on what modes you'd like it to play:

 

  • "Mayor" -- Music will be played in Mayor Mode (i.e. whilst in your city).
  • "Region" -- Music will be played in region view or in God Mode, before starting a city.

 

Copy your custom music inside the "Music" folder (alongside the standard tracks). You must check the "Custom Tunes" option in the game's Audio Options for them to play.

 


 

To use a custom resolution, add the following commands to the target field of your SC4 shortcut (add a space after the target):

 

-intro:off -CustomResolution:enabled -rWIDTHxHEIGHTx32 -f -CPUcount:1

Replace WIDTH and HEIGHT with the resolution of your monitor.

 

Also, -intro:off will skip the game's intro, and -f -CPUcount:1 will force the game to run on a single processor core. This helps to make the game run more stable on modern CPUs.

 

For example, my shortcut looks like this:

 

"C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -intro:off -CustomResolution:enabled -r1600x900x32 -f -CPUcount:1

 


 

As a side note, if you haven't already, I recommend you also install the latest updates for the game. These can be found on this page at SC4 Devotion.

 

Please say if you need any further help with this.

Oh, and welcome back to SimCity 4! :)

Share this post


Link to post
Share on other sites
  • Original Poster
  • To use custom music, first go to:

     

    "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Radio\Stations"

     

    Here there are two folders, you may use one or both of them, depending on what modes you'd like it to play:

     

    • "Mayor" -- Music will be played in Mayor Mode (i.e. whilst in your city).
    •  
    • "Region" -- Music will be played in region view or in God Mode, before starting a city.
    •  

     

    Copy your custom music inside the "Music" folder (alongside the standard tracks). You must check the "Custom Tunes" option in the game's Audio Options for them to play.

     


     

    To use a custom resolution, add the following commands to the target field of your SC4 shortcut (add a space after the target):

     

    -intro:off -CustomResolution:enabled -rWIDTHxHEIGHTx32 -f -CPUcount:1

    Replace WIDTH and HEIGHT with the resolution of your monitor.

     

    Also, -intro:off will skip the game's intro, and -f -CPUcount:1 will force the game to run on a single processor core. This helps to make the game run more stable on modern CPUs.

     

    For example, my shortcut looks like this:

     

    "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -intro:off -CustomResolution:enabled -r1600x900x32 -f -CPUcount:1

     


     

    As a side note, if you haven't already, I recommend you also install the latest updates for the game. These can be found on this page at SC4 Devotion.

     

    Please say if you need any further help with this.

    Oh, and welcome back to SimCity 4! :)

    Thank you for telling me how to fix the screen resolution. I did it and it worked very well. Oh, and thank you for welcoming back :D

    However, I still don't know why I don't have that folder. I know how it works, but I don't know why I can't see it :(

    This is a screenshot of what I'm telling you:

    post-370181-0-07609800-1363391198_thumb.

    I had a similar problem with The Sims 2: it lacked a Downloads folder. But that's supposed to be a very common problem that can be easily fixed by creating a folder and naming it "Downloads". Can I do that with SC4?

     

    EDIT: Tragedies never end T_T

    I downloaded the patch you gave me in the link, but since I did that, I noticed that my residential areas looked somewhat empty. Judge by yourself:

    post-370181-0-71589400-1363394877_thumb.

    What should I do in those cases?

    Share this post


    Link to post
    Share on other sites

    Custom music does not work from your "Documents" SimCity 4 folder (as in your screenshot).

    Locate your game's installation path, which is usually in Program Files, and open:

     

    Maxis > SimCity 4 Deluxe > Radio > Stations > Mayor or Region (Then follow the explanation on my previous post).

     


     

    As for the in game screenshot, it does seem like your graphics settings have been reset. This usually happens after applying the game updates.

    To fix this, go to the game's Graphic Options and make sure the "City Detail" is set to high:

     

    Y2Wkqa4.png

     


     

    Also, once you've located where the game is installed, open the "Apps" folder and hover your mouse over the file named SimCity 4.exe . From this, it will state the game's version. If it's 1.1.638.0, the previous update was successful (anything less means it didn't work correctly). But to be fully updated, you'll need to install the BAT nightlights update, available here (direct link from SC4 Devotion). This allows the night lighting to work on custom made buildings.

     

    After installing this, your game should then be fully updated to 1.1.640.0 .

     

    Note: The City Detail option may need to be set back to high. ;)

     

     

     

     

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Custom music does not work from your "Documents" SimCity 4 folder (as in your screenshot).

    Locate your game's installation path, which is usually in Program Files, and open:

     

    Maxis > SimCity 4 Deluxe > Radio > Stations > Mayor or Region (Then follow the explanation on my previous post).

     


     

    As for the in game screenshot, it does seem like your graphics settings have been reset. This usually happens after applying the game updates.

    To fix this, go to the game's Graphic Options and make sure the "City Detail" is set to high:

     

    Y2Wkqa4.png

     


     

    Also, once you've located where the game is installed, open the "Apps" folder and hover your mouse over the file named SimCity 4.exe . From this, it will state the game's version. If it's 1.1.638.0, the previous update was successful (anything less means it didn't work correctly). But to be fully updated, you'll need to install the BAT nightlights update, available here (direct link from SC4 Devotion). This allows the night lighting to work on custom made buildings.

     

    After installing this, your game should then be fully updated to 1.1.640.0 .

     

    Note: The City Detail option may need to be set back to high. ;)

    Thank you very, very much. Now everything is in order and I'm ready to simulate some cities the way I like.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections