Jump to content
Sign in to follow this  
nick13

Ea symbol crashing my game

10 posts in this topic Last Reply

Recommended Posts

 when ever i load simcity 4 deluxe it starts loading then when the Ea simple shows up it freezes for a few seconds then crashes to the desktop. i have tried uninstalling and reinstalling the game and deleting everything that has to do with the game but it just won't work.42.gif if some one can help or think of some think i haven't it will be very happy. 

Share this post


Link to post
Share on other sites

For openers, we need to know what machine you are running, and what version of the game you have installed.  We can't guess why things like this happen unless you describe the circumstances.

You have Deluxe, but did you apply the updates (EP1, BATupdate) after you installed it?  If you locate the .exe file and right click on it, you will see that the version number is 1,1,638.1 for EP1 or 1,1,640,1).

Next, we need to see what machine you have, so please post the following:

CPU type, number of cores

GPU make and model and any extra settings

RAM size in gigabytes

VRAM (swap file) size in gigabytes

Operating system, version and update status

If you want to get rid of the EA movie, open your shortcut's properties and add the following after a single space

-intro:off

Share this post


Link to post
Share on other sites
  • Original Poster
  • ok so i had the EP1 update installed but for some reason the bat update did not work.The CPU type something like intel® Core2 Quad CPU Q6600 @2.40GHz. GPU is AtI Radeon 2600 XT. my operating system is windows vista on a dell. RAM isPentium 4 Prescott DT, 3,0 GHz, 1 MEGB i don't know if this is correct my dad told me this and he thinks he some kind of computer expert but he isn't so tell me if it is and thank you for your time and help

    Share this post


    Link to post
    Share on other sites

    Well, we are getting there.  How big is your swap file?  You can find out by doing a right click on "My Computer" and following the Advanced tabs until you find it.  There are probably two numbers for the minimum and maximum size.

    For the life of me, I can't understand how you would have 3GB of RAM.  Generally speaking RAM comes in even numbers, and it is better if it does.

    When was the last time you checked your machine for viruses?  What anti-virus are you running?  There have been issues with some of them killing the game at start up.  This could also explain why you can't install the BATupdate.

    BTW, all that stuff you posted is of the class too much information.  If you were able to answer my query in the tabular form in which I asked it, things would be better.

    There is a program called system information that will get you all the stuff you need or you could open the run box and just type in dxdiag+RETURN.  The first page of this program will tell you a lot.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • @ SC4BOY i'm using the new simcity box set with the societies and the snap city. @ A Nonny Moose i don't have any viruses and i'm running the "Norton security suite" and where would i find the swap file info in the system info program. thanks for the help happy holidays!

    Share this post


    Link to post
    Share on other sites

    I had this problem before, and it could be related. If your crashing before they say "ea games" you might want to check that you have the drivers for your sound card/motherboard installed correctly. No sound card drivers causes simcity to crash whenever a sound comes up.

    Share this post


    Link to post
    Share on other sites

    Originally posted by: nick13

    @ SC4BOY i'm using the new simcity box set with the societies and the snap city. @ A Nonny Moose i don't have any viruses and i'm running the "Norton security suite" and where would i find the swap file info in the system info program. thanks for the help happy holidays!quote>

    Your swap file is in your My Computer panel.  Right click on My Computer, then follow the Advanced Tabs.  You should find it on about the third one.  There is all kinds of interesting stuff hidden away in that configurator, and it is worth a look.

    The previous point about sound is correct.  SC4 won't run without a proper sound set up.  It doesn't run without a graphics accelerator either.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • OMG it was the speekers the whole time i did not have them plugged in and i plugged it in and now my sc4 works! thanks for all the help a nonny moose and CTMandR. 

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections