Jump to content

Archived

This topic is now archived and is closed to further replies.

pjot

Transit enabling and transparent base

15 posts in this topic Last Reply

Recommended Posts

  • Original Poster
  • It seems as a tile can't both have a transparent base texture and be transit enabled at the same time. Is this the case?

    I've made a 2x2 lot and placed some highway props on it. I saved it in the lot editor and went into SC4tool to transit enable (TE) it. I tried it in game and everything worked perfectly so I took the next step: Transparency. In ilives reader I removed the 0x00000002 properties that belonged to the base textures to make the tiles transparent. When I tried the lot in game again they were transparent but not TE:d anymore.

    I also tried the other way around. I created the lot, deleted the base textures and when I tried to TE it in SC4tool, but I couldn't. I'm not sure if this is a limitation of the game, SC4tool or if I've screwed up somewere along the way.

    It seems as the 0x0000007 (TE) property is more related/depentant to it's 0x00000002 (texture) property than I thought. Maybe that's a known fact, that the TE property won't work without a texture property for the same tile?

    Another thing I've noticed when I was making another lot was that I couldn't TE one lot for both ground and elevated highway. I tried to TE the lot in SC4tool and everything seemed perfect, but in game I couldn't place ground nor elevated highways anywere. I've TE:d many lots for both rail and road, rail and street, road and street and they've all worked in game. So why not highways?

    Anybody who knows this who can help me clear my mind a bit?


    And YES I've searched the forums! 2.gif

    Share this post


    Link to post
    Share on other sites

    Try this:

    In iLive go to the lot's exemplar, select a LotConfigProperty line, right-click, select Reindex Lotconfig, and save. This may fix the lot.
     
    You should do so every time you add/remove LotConfigProperty lines in iLive.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Yes, I did that. Just forgot to mention it since it's more or less a habit when using the reader 1.gif but thanks anyway!

    Share this post


    Link to post
    Share on other sites

    Tiles can be transparent using the technique you're using, just don't forget to reindex lotconfig as cogeo mentioned. Sounds like you got this part down okay.
    Now for the transit enabled tiles:
    1. If you tranist enable a tile, you don't want it to be transparent, I tried not having a base texture or overlay in my jetty walls (link in signature) figuring that when I dragged the road across the tile (in-game) the game would draw the road texture. No such luck. A few quick tests and you can verify this for yourself. I needed the base texture to get the sidewalks and the overlay to get the road.
    2. Multiple transit types on a single tile. Hmmm. I never tried this one although I would expect rail EW and road NS to work ... and there's even overlays for this. But 2 transit types in the same direction on the same tile may not work. I don't think the game can handle it. Not using just a type 7 property like usual anyway. If it is possible, I suspect that pathing files would be needed (which are way over my head). So ... for this issue ... I'd suggest PM'ing one of tha NAM folks for help. They seem to have the handle on this issue.
    Sorry I couldn't be more help. Good luck.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • JayStimson: That's the problem when transit enabling for highways. They arn't textures but props 2.gif Sure I could have a grass or concrete texture below the highway but since the games original highways doesn't I don't what that either.

    On the second question I guess I was a bit fuzzy 3.gif I'm not trying to transit enable the same tile for two networks but a 2x1 on one end of the lot for elevated highway and one 2x1 in the other end for ground highway. I know that I need some rul and sc4path files for this to be working asif maxis had done it but I'd be satisfied even if the automatas drove like drills into the ground or if they didn't show up at all just as long as the pathfinding engine could guide the sims through the lot.

    PS. I've seen your walls and they look great! 36.gif

    Share this post


    Link to post
    Share on other sites

    there must be a way to TE and make a lot transparent at the same time as this was done with a toll booth over a highway. Has anyone been able to remove the base textures of more than 4 tiles? because i always get an error for more than 4 (yes i do reindex the lot), as i cant find the right texture to delete so LE crashes.

    Share this post


    Link to post
    Share on other sites
    pjot:
    Firstly, thanks for the encouraging comment on the walls I'm making.
    Secondly, I'm not quite following the orientation of your 2x1 TE tiles on your lot but I don't see why it wouldn't work from what you've stated. Could you post a pic from in the LE with an explanation on which tiles your trying to do what with and in which direction the TE goes. I'll try and make one myself and post it back for you or if you want to zip it and attach it to your post I'll DL it and take a look at it.
    EDIT: I did some experimenting with a 4x1 lot that's TE'd for ground highway and elevated highway. Couldn't get it to work. I tried making it 5x1 so there'd be at least 1 tile between the 2 highways. Still no luck. Dang ! I'll try a bit more testing tomorrow and see what I can figure out.

    toxicpiano:
    There shouldn't be any problem with lots more than 4 tiles. I've done it before and it works fine (except for the water bug issue ardecila mentioned). I'm not quite sure I followed that last part of your post correctly but if I did, it does help if you delete the right textures (lol). When I'm making tiles transparent I use a base texture that's not used on any tiles other than the ones I want transparent. This way I always know when I'm in Reader which properties i want to delete. I re-index and save and it always works. Did I not understand what you were trying to convey ?
    EDIT: Not sure what you're doing wrong toxic. I made a copy of the SoL LM and removed the base textures and overlays and here's what I got:
    <ahttp://www.simtropolis.com/idealbb/files//JS_Test_Transparent_Tiles1.jpg align=baseline>

    <ahttp://www.simtropolis.com/idealbb/files//JS_Test_Transparent_Tiles2.jpg align=baseline>
    If you want to zip and attach the lot you're having trouble with I'll take a look at it for you.

    Share this post


    Link to post
    Share on other sites

    I actually messed around with transparent/TE base-textures before abandoning it on my first BAT (the road tunnels).
    HERE is the link to the topic I started awhile back and Swamper77 was able to give me advice on it.

    I had a transparent base AND it was transit enabled for PED, CAR, BUS, FRIEGHT. At one point it was also transit-switch capable for all but Frieght.

    I however abandoned this in my final version I uploaded to the STEX. The problem, like JayStimson mentioned, was that when running roads or one-ways through the transparent-base the new roads wouldnt show through.

    When I got this to work I had actually already TE'd the lot in SC4TOOL then just followed PEG's Tutorial last.

    P!: A picture of your current LOT would be helpful to better explain what your doing and why your having the problem.

    -trigger

    -trigger

    -----------------------

    trigsidx18it.gif

    Share this post


    Link to post
    Share on other sites

    It is possible to create transparent puzzle pieces with transit-routes. Currently I am creating a canal ferry system which is working with any kind of ploppable water. You place the puzzle piece over a LOT and don't see it. It just adds routes to the LOT. So if you're silly, you can build ferry routes through parks, houses and so on.

    Share this post


    Link to post
    Share on other sites

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections