Jump to content

Urban Sturgeon

Member
  • Content Count

    6
  • Joined

  • Last Visited

    Never
  1. Mod suggestions?

    I've checked out the recommendations. Thanks. I forgot to mention that I've also used the NAM (that's a definite must have.) The hole digging lot is very useful. The slope mod looks neat, but apparently either the DL is broken or I'm doing something wrong because it's not showing up in game. I've looked at the farming lots before and, honestly, have been turned off by the tremendous number of dependencies that aren't linked with the original file. Is there any sort of consolodated ag mod like the PEG MTP? It makes it much easier to deal with dependencies if everything is available under one common theme. Thanks for the suggestions so far.
  2. Mod suggestions?

    Hi, Every year or so I get the urge to fire up SC4. And every year or so I start going through the mod databases here and on other sites and eventually get discouraged because there's a tremendous amount of content and it's difficult to find exactly what I'm looking for. I've just reinstalled and installed my favorite terrains and terrain mods as well as finally DLed the entire MTP (I think. Between the dependencies and sheer number of files, I'm not sure. I haven't actually installed it yet,) but I still can't find the things that I hope exist. So I'm hoping someone can point me in the right direction. Things I'm looking for: -Some sort of agriculture mod. The default Maxis farms are pretty useless in terms of employment and income. Is there any mod that fixes this? -Some type of airport mod. Ideally something that makes the whole air travel system a bit more realistic and flexible. -"Must haves." Every game I play generally has some sort of "must have" mod list. I've yet to find one for SC4. Does one exist? Any help with that? The agriculture thing has always been my big issue. I like to build little towns, but the Maxis farms are pretty much useless and always have been. Thanks.
  3. SC4: Constant BSODs

    Disabling all hardware sound acceleration worked--I can now play. So that's the solution for anyone else with a Montego that's getting crashes. Now that I can actually play, can anyone point me towards any "must have" mods? I've been completely away from SC4 since about 3 months after it came out. I have no idea what the state of the community is. Thanks.
  4. SC4: Constant BSODs

    Initial results of running with hardware acceleration for sound are surprisingly positive. I just did all of the things that have made it crash in the past and it kept running. If this is a solution, I'll be pleased. I'll post a further update tomorrow. I hope that wasn't just a coincidental fluke. In case it isn't, I'll just mention something that I forgot to mention in my original post: The game ONLY BSODs in mayor mode. I could literally landscape a region all day without it crashing. In fact, that was the first thing that I did after installing it--I spent six hours making a region with no problem, but as soon as I started a city and tried zoning, the system BSODed.
  5. SC4: Constant BSODs

    Originally posted by: BIWDC You might be running out of ram or need a replacement see what you can upgrade,that's my guess on the Bad_pool Message. I couldn't say about the IRQ one as i am getting this rarely when i use my capture software & i haven't firgured out the problem yet.quote> I shouldn't be running out of memory--I have 1024MB. SC4 also ran fine on my old rig with only 512MB and a GF 4400. The memory itself is physically fine. I've run memtest86 on it prior and I regularly do more memory intensive tasks than SC4 with no problems (processing 300-700MB images in Photoshop, for example.) Originally posted by: SWAT-MEDIC I looked around on the internet and it looks like you might have a spyware or something like that hijacking system resources when your trying to do system-intensive tasks.quote>The system is clean. I scan regularly. Thanks for the suggestions, though. Please keep them coming. I'd really like to play since it looks like a lot has changed in the past 5 years. *edit: I'm going to disable hardware acceleration for sound completely and try again. I'll report the results.
  6. SC4: Constant BSODs

    I was referred to this place as a last resort. Honestly, I've pretty much given up on running SC4 at this point, but I figured it's worth a shot. Background: I bought SC4 when it came out 5 years ago. It ran fine. I played it for a few months, put it aside, and eventually lost the discs. In the interim I built a new system. I got the urge to play it again, so I picked up the Deluxe edition cheaply recently. I installed it expecting to play. Every time I start a city, however, the system BSODs as soon as anything starts to happen (zoning, road building, looking at the screen funny, etc.) The most common is a BAD_POOL_HEADER error, but IRQL_NOT_LESS_OR_EQUALs related to portcls.sys have occurred. To me, this suggests an issue with the sound drivers. I have tried all drivers available for my card. I updated video drivers. I reapplied SP3. I've tried SC4 with the sound disabled, in compatibility mode, and with the process affinity set to one processor. I've also tried the game freshly installed and with the latest patch. Hell, I've tried lowering sound acceleration in dxdiag like you used to have to do to play certain games with stability back in the 90s. Basically I tried everything that I could think of and then some (including thermal monitoring--not it. Everything is in order and the system runs everything else fine.) Pertinent specs: OS: XP SP3 Mobo: Supermicro X5DAE (E7505 chipset) CPUs: 2x 3.0GHz Xeon RAM: 1024MB HDD: 40GB 10K SCSI (system,) 500GB 7200 RPM SATA (everything else) Video: GeForce 7800 (latest drivers) Sound: Turtle Beach Montego DDL (latest drivers) Paging: 2500MB on the SCSI About all that I can add is that this isn't a problem with the system--it's rock solid stable and runs programs that are quite a bit more taxing than SC4 with no issues whatsoever. In fact, I would go as far as saying that, aside from the 20+ SC4 related crashes in the past 48 hours, the system has crashed less than half a dozen times in the last two years. The portcls.sys error makes me think that this is related to the Montego, but I'm definitely not getting rid of a rock solid soundcard that runs everything but SC4 just because SC4 crashes. I've pretty much given up, but I was told that you guys know SC4 best, so maybe this is a known quirk and there is a workaround. Thanks for any info.
×