Jump to content
Sign in to follow this  
batterytrain

Terrain/landscapper/mapper generator

12 posts in this topic Last Reply

Recommended Posts

Hello!

 

I am new here and a relative newbie when it comes to mods and third party modifications; I have already made a thread on the landscape creator but I have not been able to find a version of it for the mac despite searching for it on the Simtropolis exchange. That thread however got no views in the process and I still cannot find a landscape mapper and generator program that is on a mac platform. 

 

How exactly do you add or change the existing green tilesets and terrain? I saw on the city journals that the terrain (snowy mountains, snow, greener pastures, stony mountains etc) can be different, how exactly do you get these effects? Pardon my ignorance and noobery :)

Share this post


Link to post
Share on other sites

Welcome to the conversation.

 

All the post-market tools are for Windoze.  I feel your pain because I run Linux.

 

To run a windoze program on Mac you need the Windoze Executive (wine).  [Not wineskin.]

 

You can actually run pretty much any windoze application using this operating system layer.  It consists of a JIT compiler for windoze calls.  With it, you can run the SC4 program itself, and all the additional software including the NAM 31.2 installer.  You can use either the release (1.6) or if you are adventuresome the beta (1.7.1 when I looked earlier today).  The betas usually have little tweaks, and they progress slowly.

Share this post


Link to post
Share on other sites
  • Original Poster
  • Welcome to the conversation.

     

    All the post-market tools are for Windoze.  I feel your pain because I run Linux.

     

    To run a windoze program on Mac you need the Windoze Executive (wine).  [Not wineskin.]

     

    You can actually run pretty much any windoze application using this operating system layer.  It consists of a JIT compiler for windoze calls.  With it, you can run the SC4 program itself, and all the additional software including the NAM 31.2 installer.  You can use either the release (1.6) or if you are adventuresome the beta (1.7.1 when I looked earlier today).  The betas usually have little tweaks, and they progress slowly.

     

    I downloaded crossover for mac from that website and I managed to install landscape mapper program, however I attempt to run the software using the crossover program and the program itself doesn't start at all. The icon starts running but then it disappears and the program doesn't start at all. Is there any solution to this problem?

    Share this post


    Link to post
    Share on other sites

    Your package probably needs to have the Python run-time package added to it.  If you keep flailing around in different packages, you might want to think why your run OS/X at all.  If you need some Apple-specific apps, OK, but you could simply load up Linux beside it and run with wine or dual boot Windoze 7.  It is not at all painful to boot up a new O/S at need.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Your package probably needs to have the Python run-time package added to it.  If you keep flailing around in different packages, you might want to think why your run OS/X at all.  If you need some Apple-specific apps, OK, but you could simply load up Linux beside it and run with wine or dual boot Windoze 7.  It is not at all painful to boot up a new O/S at need.

     

    I downloaded Wine instead of crossover now but I am unfamiliar with the how the Mac system runs as a whole, I am running SC4 on a macbook so I am not using any sort of PC system. I downloaded Wine and the icon appears to show that Wine is running but nothing appears on the screen, I am also unfamiliar with how this program works at all.

    Share this post


    Link to post
    Share on other sites

    To run a windows executable under Linux, right click on the program and this is what happens.  (NAM 31.2 Installer).
     
    nTH3hVq.jpg

    It should be the same on OS/X. The wine prefix will open and run the program. You must have the proper libraries loaded to use the windows controls in the installer. If you don't have them and funny things happen, use winetricks to pick up the advanced text controls.

     

    Anyone not using Windoze is presumed to have some computer smarts.  I hope this is the case.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • To run a windows executable under Linux, right click on the program and this is what happens.  (NAM 31.2 Installer).

     

    nTH3hVq.jpg

    It should be the same on OS/X. The wine prefix will open and run the program. You must have the proper libraries loaded to use the windows controls in the installer. If you don't have them and funny things happen, use winetricks to pick up the advanced text controls.

     

    Anyone not using Windoze is presumed to have some computer smarts.  I hope this is the case.

     

    I have tried doing that exactly!!

     

    But there is an error with the actual program itself, where I try to open wine and install the application but it stops installing halfway and then there is an error and the logfile shows up for the wine application. 

    Share this post


    Link to post
    Share on other sites

    if you are trying to install SC4 from CD under wine, the trick is to change the disks using your O/S to:

     

    1. Dismount the first disk.

    2. Mount the next disk (which is the play disk)

     

    The wine system can't see manually dismounted/mounted disks at the time the app. is running.  All *nix system need the O/S mount routines to change a CD.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • if you are trying to install SC4 from CD under wine, the trick is to change the disks using your O/S to:

     

    1. Dismount the first disk.

    2. Mount the next disk (which is the play disk)

     

    The wine system can't see manually dismounted/mounted disks at the time the app. is running.  All *nix system need the O/S mount routines to change a CD.

     

    I'm not trying to install SC4, I am trying to install an ".exe", executable file on the mac and I have tried using winebottler to install this downloaded SC4 program from the internet using winebottler but an error shows up and it says that there is an error with the prefix and then a log appears whereby the installation stops halfway.

    Share this post


    Link to post
    Share on other sites

    Can you do that again but redirect the output of the wine console to a file so you can review it and/or post it here?  Here is a Linux script that does that:

     

    #!/bin/bash
    wine winecfg &>~/wineconf.log
     

    The redirect may not be the same for your console.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • ###BOTTLING### default.sh

    ###BOTTLING### Gathering debug Info...

    Versions

    OS...........................: darwin10.0

    Wine.........................:

    WineBottler..................:  CFBundleVersion = 1;

    Environment

    PWD..........................: '/Applications/Wine.app/Contents/Resources/bin'

    PATH.........................: /usr/gnu/bin:/usr/local/bin:/bin:/usr/bin:.

    USER.........................: User

    HOME.........................: /User

    BUNDLERESOURCEPATH...........: /Volumes/WineBottler Combo/WineBottler.app/Contents/Frameworks/WBottler.framework/Resources

    WINEPATH.....................: /Applications/Wine.app/Contents/Resources/bin

    LD_LIBRARY_PATH..............: /Applications/Wine.app/Contents/Resources/lib:/usr/X11R6/lib

    DYLD_FALLBACK_LIBRARY_PATH...: /Applications/Wine.app/Contents/Resources/lib:/usr/lib:/usr/X11R6/lib

    FONTCONFIG_FILE..............: /Applications/Wine.app/Contents/Resources/etc/fonts/fonts.conf

    DIPSPLAY.....................: /tmp/launch-3I1B4k/org.x:0

    SILENT.......................:

    http_proxy...................:

    https_proxy..................:

    ftp_proxy....................:

    socks5_proxy.................:

    Bottle

    TEMPLATE.....................:

    BOTTLE.......................: /Users//Documents/Terraformer.app

    INSTALLER_URL................: /Users//Documents/SimCity 4/SC4Terraformer.exe

    INSTALLER_IS_ZIPPED..........: 0

    INSTALLER_NAME...............: SC4Terraformer.exe

    INSTALLER_ARGUMENTS..........:

    WINETRICKS_ITEMS.............:

    DLL_OVERRIDES................:

    EXECUTABLE_PATH..............: winefile

    EXECUTABLE_ARGUMENTS.........:

    EXECUTABLE_VERSION...........: 1.0

    BUNDLE_IDENTIFIER............: com.yourcompany.yourapp

    SILENT.......................:

    Hardware:

        Hardware Overview:

          Model Name: MacBook

          Model Identifier: MacBook7,1

          Processor Name: Intel Core 2 Duo

          Processor Speed: 2.4 GHz

          Number Of Processors: 1

          Total Number Of Cores: 2

          L2 Cache: 3 MB

          Memory: 2 GB

          Bus Speed: 1.07 GHz

          Boot ROM Version: MB71.0039.B09

          SMC Version (system): 1.60f5

          Serial Number (system):

          Hardware UUID:

          Sudden Motion Sensor:

              State: Enabled

    ###BOTTLING### Create .app...

    ###BOTTLING### Enabling CoreAudio, Colors, Antialiasing  and flat menus...

    ### LOG ### Command '/Applications/Wine.app/Contents/Resources/bin/wine regedit /tmp/reg.reg' returned status 139.

    Task returned with status 1.

     

    This is the error log script.

     

    Now when I try using Crossover to install the application, I have to use "other Application" for installation of the program because the application is not listed in the one Crossover shows. When I attempt to install the program using Crossover using the above, the actual program (Terrformer etc) starts while the installation with "other applications" is halfway but then the progress bar just stops and I can use the program to see it but I can't do anything else besides that.

    Share this post


    Link to post
    Share on other sites

    I hope some MAC user can help with this.  winebottler is not needed with Linux/wine.  I run mapper not terraformer, but both are by the same author.  I simply installed mapper from its installer into wine by executing the installer under wine.  Extract the installer and simply run it in a console:

     

    wine SetupSC4Mapper2013v3.exe

     

    Runs fine for me and even inserts the program in my wine menu.  Maybe you should be using Mapper instead of Terraformer.

     

    Your environment must have the correct Python run-time available.

     

    uMUALOM.jpg

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections