Jump to content
jeffryfisher

Datpack says "examplar has no sig attribute"

5 posts in this topic Last Reply

Highlighted Posts

After editing some SPAM farm fields (exemplars) to give me more anti-air pollution power, I tried to pack SPAM. Datpack errored out with the message "Examplar has no sig attribute". It doesn't specify which exemplar.

I only made changes within one of SPAM's dat files. I only touched the pollution radii and strengths. I'm using iLives reader 1.54.

What's a sig attribute, and how could it have been lost? Is iLives 1.54 buggy?

Share this post


Link to post
Share on other sites

I would have taken the error to mean 'Exemplar has no significant attribute' (i.e. it may be empty).  I would go back and check that particular dat file to start.  Something may have corrupted the file.  Reader 1.54 is apparently very particular about Re-indexing and Rebuilding the Directory file after making changes, and before saving.

 

Share this post


Link to post
Share on other sites

Did you try to run SC4DataNode tool? The DataNode tool gives you a log file with errors and usually very detailed informations about the TGI, that causes the problem.

Kind regards!

Share this post


Link to post
Share on other sites
  • Original Poster
  • 1 hour ago, markussaage said:

    Did you try to run SC4DataNode tool?

    Yes, but it didn't say much. Maybe the exemplar is empty. There were some lines that were "unreadable".

    However, I'm not even sure I was looking in the right place. Datpack's error is cryptic, not even giving the problem exemplar's name or number. I'm just trying to get more info so I can make more sense of it.

    I had been hoping I could edit the pollution numbers within a dat file (not changing any length in any way) without reindexing etc, but no dice apparently. I've discarded my botched edit and will start over. I'll see if I can make an override-patch instead of making my own version of PEG's whole file.

    If there's ever any more work done on iLives Reader, I humbly request that it automatically do whatever reindexing is needed whenever saving a file (since it seems to be a mandatory step anyway).

    Share this post


    Link to post
    Share on other sites

    if DataNode complains about "unreadable" its found a tag saying "what follows is an exemplar" but when it tries to decode it can't make sense of it - usually a sign of file corruption. 

    It issues a message to that effect on the log, and will dump the exemplar? to the \SC4Datanode\DebugData folder so that you can try to load it into Reader to see what it thinks.

    As for editing the pollution numbers directly - should not be a hassle - changing these values does not change the file length.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Similar Content

      • By nukehumvee
        I have downloaded all the dependencies and I still get a brown box and a 43170746 missing plugin pack warning.
         

      • By jeffryfisher
        I have a fresh install of Wounagain's 2008 datpacker in Win7. In Win7, my user dir is under "My Documents", but the dat packer insists on looking in "Documents", which does not even exist in Win7. I've tried editing config.ini, but no joy. How do I coerce the datpacker to look in the right place?
      • By chirpy22
        Hello everyone,
        Recently it seems I have a mod conflict and decreased FPS. Upon checking the log, there is a single line looping hundreds of times.
        Look rotation viewing vector is zero (Filename: Line: 92) Line 92 is the following.
        (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) Adding package 'Garden Rivers2' [C:\Program Files (x86)\Steam\steamapps\common\Cities_Skylines\Files\Maps\Garden Rivers2.crp] [Packer - Internal] I have disabled all vanilla maps in the game menu, including Garden Rivers. Why would this be causing a massive error in my game?
         
        Thanks for any assistance.
      • By AlRESA
        I get this error message after installing  and run the game.
        Hope someone helps.
        Thanks in advance 

      • By VitroOliveira
        I have downloaded a file call leis plus Mensalao that give 750000 for month and now only give  100... why this not function... mayby becouse use the Cam addon mode...
        leis+mensalao.rar
    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Thank You for the Continued Support!

    Simtropolis relies mainly on member donations to continue operating. Without your support, we just would not be able to be entering our 15th year online!  You've really help make this a great community.

    But we still need your support to stay online. If you're able to, please consider a donation to help us stay up and running, so that we can help keep bringing SimCity players together to share our creations.

    Make a Donation, Get a Gift!

    Expand your city with the best from the Simtropolis Echange.
    Make a donation and get one or all three discs today!

    stexcollection-header.png

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections