Jump to content

10 posts in this topic Last Reply

Highlighted Posts

You deleted some plugins from your folder, or you installed and plopped a lot without installing all its dependencies.

When you do those things and then save and re-open your city, the game warns you about it, mainly because it can cause file corruption in the long term.

Check the recently plopped lots for brown boxes or blackened textures, close the game without saving and install the dependencies you missed.

Share this post


Link to post
Share on other sites
  • Original Poster
  • Thank you for try help , but sincerely I cannot find the things or plugins I need,... Are some way to find how find this plugins...

     

     

    Share this post


    Link to post
    Share on other sites

    I uploaded some lists into the omnibus to help people find their missing plugins, first of all

    Quote

    To convert Plugin Pack ID shown on the Load Warning Box in SC4 enter the number into a Decimal Calculator and then convert this number into a hexadecimal number, then search the relevant CATALOG ID file for the HEX number no guarantee the number will be in the CATALOGs as I have stopped updating it, but there is a good chance it will be listed.

    This is the first CATALOG ID file

    there are 16 files all together.

    -catty

    Share this post


    Link to post
    Share on other sites

    Hi @VitroOliveira, welcome to Simtropolis! *:)


    Those numbers shown in the "Warning" dialog are from an identifier known as a Plugin Pack ID.

    As far as I'm aware, all lots are assigned one of these in the exemplar properties. Then once placing a custom lot in the game and saving, a record is made to these IDs in the saved city file. Upon loading a tile it then checks to make sure the lots inside the current city are loaded from your Plugins folder. Basically the warning message is a reminder that the referenced model files it expects are missing, and they must be added back to make the lots functional again.

    Converting the three IDs shown in your screenshot to hexadecimal form (from decimal), they are as follows:

    • 0x29F68062
    • 0xF084B5FE
    • 0xA6AAE59E


    Maybe these can be found in the useful lists Catty mentioned above?

    Otherwise on their own, these IDs don't tell us much. However, one potential method I've discovered is to open a saved city file in iLive's Reader to determine what item of content they refer to. The individual exemplars include other details such as the Name and Type, which gives a much better chance of tracking them down.

    If you'd like feel free to upload the affected saved city here in reply (as an attachment), or send it me via PM. Then hopefully the missing plugins can be identified before looking into possible missing dependencies on the lots themselves.

     

    On the subject of Dependencies...

    Just to clarify, the plugin pack warning will show when custom lots are built in a city, but are no longer in your Plugins. But in addition to the lots themselves, they may also require extra files including other models, props or textures. Usually on the STEX and other exchanges, authors will list these in the description or readme documentation. Without these installed in your Plugins folder, you may notice brown boxes or other missing details when they're built in the game.


    Some more info from a recent post I made in reply to the "Mod error" thread:

    On 16/04/2018 at 2:04 AM, Cyclone Boom said:

    The cause of brown boxes is due to model files missing for use on custom lots. Without them installed, the game shows a box instead. Also it appears you're short of a texture from the lot itself, which explains why the blue grid is showing through.

    Both props and textures are collectively known as dependencies. In other words, these are files needed for any lot to work properly when built inside the game. So as a next step here, I suggest checking the description or included readme documentation of the files. These will hopefully specify the extra content required to be placed in your Plugins folder, in addition to the lot files themselves. Most dependencies are bundled in the form of MEGA packs containing a collection of multiple props or textures.

    Just be sure to run the installers on these (or extract if a zipped archive), and the contents which are usually *.dat files will be copied to your Plugins folder. Then unless there are specific requirements necessary to adjust the loading order, they can always be moved to a subfolder structure of your choice. As long as placed somewhere inside Plugins.

     

    Share this post


    Link to post
    Share on other sites
    7 hours ago, Cyclone Boom said:

    ....Converting the three IDs shown in your screenshot to hexadecimal form (from decimal), they are as follows:

    • 0x29F68062
    • 0xF084B5FE
    • 0xA6AAE59E

    While these numbers aren't in the lists, it sometimes helps to see if there is a close match, and in this case there is to one of the numbers

    0xF084B5FD = SG_4x4_WaterControlBoard

    given how close it is I'm guessing that one of your missing plugins has to belong to SimGoober

    Sorry I can't help.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Hello again, I have resolved almost all plugin problems with the Brown boxes, but some plugins remain and I cannot see becouse... maybe some help...

    plugimProblemsa.jpg

    Share this post


    Link to post
    Share on other sites
    On 09/05/2018 at 9:44 PM, VitroOliveira said:

    Hello again, I have resolved almost all plugin problems with the Brown boxes, but some plugins remain and I cannot see becouse... maybe some help...

    Looks like you've made great progress with identifying the dependencies.

    For those still missing, once again I'm more than happy to investigate the two missing plugins causing the error. Should you wish, you're most welcome to upload your city tile in reply as an attachment (or send me a PM). By default, cities will be located in folders at: \Documents\SimCity 4\Regions\<Region Name>

    Like I did here to help another member experiencing the exact same problem, all being well the files can be tracked down. *;)

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Similar Content

      • By VitroOliveira
        Hello, I have to wait 11 minuts to load SC4, 7 to load Regions Map and 4 to load the Map i choose, incredible... maybe are some way to descend this times for load, or I have to eliminate some plugins... but how I can do it safety...
      • By VitroOliveira
        I make for first time a High Speed Rail and not show good... can anyone help...
      • By fritzfarlig
        where can I find my DL history on STEX ?
      • By ScreaminAbdabs
        Hi,
        1st post here and I am stuck. I am trying to download a number of mods for City Skylines including BloodyPenguin's Advanced buildings editor.
        When I subscribe to the mod Steam says its downloading, and when I look in the content manager the game says its there but when I open the Asset editor there are no additional options or menus.
        When I look in Cities_Skylines\FilesMods I just have the base ones, like Hardmode and when I look in Local\Colossal Order\Cityckylines\Addons\Mods its empty.
        Anyone any idea what's going on? Verifying the game cache does nothing it says all is OK and unsubscribing/subscribing also does nothing.
        I can download assets from the workshop, such as joaks excellent 4 track train station and these work fine.
        Do I have to enable something in game in order to use mods like the Advanced Buildings editor? I cannot find anything on the net saying this.
        Hope someone can help.
      • By Duco
        To whom it concerns,
        This post is meant as a a big ‘ Thank You!’ .
        Although I’m not a community man, I visit simtropolis a lot. Since a few months I have a new computer and I just copied the files from my old tot the new one.
        But now I have more possibilities and because the game crashes some times with my new settings, I decided to install everything from zero.
        C.P.’s terrainmod Meadowshire is installed, the seasonal trees from Girafe, a watermod from Peg, the NAM, Spam and several addons, so I am on my way.
        But when I am doing this, I  realize that this game woudn’t be anywhere, without all this cool things.
        So, Thank You! Just wanna say thank you to all the people who made/ make this game so much fun.
        Thanks!!
    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Thank You for the Continued Support!

    Simtropolis relies mainly on member donations to continue operating. Without your support, we just would not be able to be entering our 15th year online!  You've really help make this a great community.

    But we still need your support to stay online. If you're able to, please consider a donation to help us stay up and running, so that we can help keep bringing SimCity players together to share our creations.

    Make a Donation, Get a Gift!

    Expand your city with the best from the Simtropolis Echange.
    Make a donation and get one or all three discs today!

    stexcollection-header.png

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections