Jump to content
citycowboy

Crash when digging in sandy desert

10 posts in this topic Last Reply

Recommended Posts

Hi. I started a new city with the sandy desert terrain mod installed. It worked until I dug down to the water. That's when it crashed. So I removed my water mod. It crashed again when I dug down. So I removed the sandy desert terrain mod. It did not crash when I dug down on vanilla. I've used the Olympic terrain mod in the past. It works just fine. I removed all of the associated olympic terrain mod files, and so there shouldn't be a conflict with the sandy terrain mod now. The sandy terrain mod does work and does paint the landscape tan, but it has something to do with the water. I am running on hardware default settings. 

Share this post


Link to post
Share on other sites

My first instinct is that you also have a rock/cliff mod that is overlapping with a rock/cliff exemplar in the sandy desert mod. If you would post linkys to each of the terrain related mods (rock/cliff, beach, terrain, & water) I'd be willing to look into this.

I ran into something similar when I was writing my shoppes threads. It confuzzled me at first cause everything would look good, but then I'd run a road up a hill and when the slope changed the terrain, I'd get the crash. I'm guessing a similar thing could be happening with a beach mod interfering with the terrain one. Or the digging you are doing is creating a slope it now needs to make a cliff.

Share this post


Link to post
Share on other sites
  • Original Poster
  • i took the rock mod out when i took the water mod out. the only other thing would be the beach extender mod, or i dont know if the NAM has a built in slope mod. Ill try it again in a bit. 

    Share this post


    Link to post
    Share on other sites
    5 minutes ago, citycowboy said:

    i dont know if the NAM has a built in slope mod.

    I can say with 99.9% certainty I've seen @rsc204 state that NAM does not have a built-in slope mod. And to clarify, it wouldn't be the slope mod itself causing any trouble. For me it was when the altered sloped caused the game to shift from one set of textures (based on the new angle of the terrain) that it crashed. So in my case the slope mod was the catalyst not the actual cause of the crash.

    Share this post


    Link to post
    Share on other sites

    It does indeed sound like you've a conflicting terrain mod still in your plugins folder. The fact that removing one of them...

    12 hours ago, citycowboy said:

    So I removed the sandy desert terrain mod. It did not crash when I dug down on vanilla.

    ... fixed the issue pretty much confirms this. What you need to do if you want to use the Sandy Desert terrain is find the other one and remove it, that should solve the problem. Do a search (in Windows) on your plugins folder for *CPT*, that should easily highlight any of CP's terrain files for you, which would be the main suspect if you previously used a CP terrain.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • I searched CPT and removed some additional files I hadn't seen. It works to dig now. However, when I try to make a mountain, it crashes. I can make hills. I removed the SHK HDRock mod. It still does it. It has something to do with cliffs. I have no idea what else would do that, since all it is is the terrain mod. I don't have a rock mod in there, and I can't think of what it would be. 

    Share this post


    Link to post
    Share on other sites

    The inherent problem with these issues is that we can not know the contents of your plugins folder. However we know removing the terrain mod fixes the issue, so we can be pretty sure there is another file that alters similar terrain properties that's conflicting with it.

    DataNode is a useful tool for finding such overrides/conflicts if you know how to use it. Otherwise the only suggestion we can offer is using the Binary Search method to track down the problem file. In essence this involves removing half your plugins and seeing if the problem is fixed, keep going until the issue goes away and the last files you moved must contain the problem file. From there it's a simply matter of trial and error to trace the exact file.

    Share this post


    Link to post
    Share on other sites

    Also look in the logs after each crash. The logs are mostly useless, but they sometimes point at what the game was trying to do when the crash occurred. That doesn't mean that's the bug, just that it's a clue to what the bug touched in a way that broke it.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Similar Content

      • By JohnAkaMrP
        Hi All,
        I had been running the game with just the 8 MB of memory that I had when I bought my current computer in 2013, but I started getting loading times that were too long to tolerate.  I upgraded the current machine myself to 16 MB maybe two or three months back and have been celebrating not breaking my machine ever since by downloading too many great assets. 
        Anyway, of late, if I've tabbed out of CS to another application (like Firefox with one or more Youtube pages open), I've have Windows tell me that I'm running low on memory, then seemingly give me the option to close the CS application.  In reality, by the time this happens, the CS application is already too unstable to allow me to even save my progress, so my two options are to allow Windows to close the CS or deny it permission and then have to use the Task Manager to force the shut down.  My load times are quite acceptable, so by that one (albeit simple) measure, the computer seems to be able to handle the assets and mods.  However, I'd like to be able to move back and forth between Firefox and CS so that I can get inspiration from someone's Youtube series and/or Google Maps.
        Does the behavior described above sound like anything other than subscribing to too many assets and mods?  Any advice other than scrapping assets and mods?
        Thanks in advance for any help!
        John
      • By Corrival_Rhyme
        So when I go to use NAM's ground tram station, specifically working with its tracks, not placing the station (no problems there), it freaking crashes the game when I basically place either types of tracks, the draggable or the single one.
      • By gb901
         Hello! So yesterday I downloaded some stuff to my game. And after that when I opened the game, it'd just crash to the desktop whenever I opened a city. I've tried to remove the files that I downloaded but still the same error... :/ I tried again today in a blank city tile, and it could load but I couldn't do anything. When I moved in the game, the map wouldn't move. I could only see that the map (like the map-map, on the game menu) was moving. What can this be?
         
      • By shwabonka
        Edit: Thanks for all your help! I just had to switch off the sound since AFAIK I didn't have any speakers for the game to output to.
        Game crashes either on the EA splash screen, or if I use the SC4 Launcher and skip the intro, after exactly six seconds. Anyone had the same problem and/or know a fix?
        More detail: all the Exception Reports state "ACCESS_VIOLATION" in the Exception Code and that ".pdb files appear to be absent" in the call stack/debug information. The game seems to recreate the SimCity 4 folder in My Documents on occasion, but yet, in-game, seems to be finding Regions from the SimCity 4 folder in the Steam directory. 
        It crashes exactly the same way in all events - a very short time into the EA splash screen or after exactly the same span of time (around 6 seconds) if I skip the intro using a Launcher.
        Tried running in various compatibility modes, with a Launcher, without, on one core, on software renderer, on different resolutions. All no luck. 

        Here's a copy/paste of the latest Exception Report:
         
         
      • By ReshiramLover
        Years ago, I downloaded SimCity 4 Startup Manager by (according to the help contents) Jean-Luc Picard.
        It was a handy tool to create custom config BMPs and now years later it won't run. It crashes upon launch. No error message, it looks as if it doesn't open, but if the Windows Task Manager is open when I try to run it, the program opens as a process for a split second and then it closes "crash"
        Does anybody know how I can get it running again? It worked in 2011.
    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Season's Greetings!

    xmas popup.jpg

    Thank You for the Continued Support!

    Simtropolis relies mainly on member donations to continue operating. Without your support, we just would not be able to be entering our 15th year online!  You've really help make this a great community.

    But we still need your support to stay online. If you're able to, please consider a donation to help us stay up and running, so that we can help keep bringing SimCity players together to share our creations.

    Make a Donation, Get a Gift!

    Expand your city with the best from the Simtropolis Echange.
    Make a donation and get one or all three discs today!

    stexcollection-header.png

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections