Jump to content
swtea

I just can't figure this out. Weird shadow on asset?

33 posts in this topic Last Reply

Recommended Posts

So I have a model I am working on but this one corner of it gets a REALLY dark shadow. It is uvmapped the same as the other faces, the normals are facing right, it's not inset in the wall.. I just don't get it? It's driving me nuts. The shadow goes away if I put a light on it..

In blender I tried recreating the face and unwrapping it again to no avail. I don't know what else to try? It's definitely a shadowing issue because it goes away if I move the sun just right, or put a light on the area at night.

 

s1.jpg

s3.png

s2.png

Share this post


Link to post
Share on other sites
  • Original Poster
  • I've figured it out for anyone else that may search this problem:

    I rotated the UV map for that face. I don't know why it worked, but I rotated it 180 and tried it again in-game and the shadow was gone. 

    Share this post


    Link to post
    Share on other sites
    10 minutes ago, swtea said:

    I've figured it out for anyone else that may search this problem:

    I rotated the UV map for that face. I don't know why it worked, but I rotated it 180 and tried it again in-game and the shadow was gone. 

    Maybe you created a broken normal map? The neutral normal map colour is #8080FF.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Just now, boformer said:

    Maybe you created a broken normal map? The neutral normal map colour is #8080FF.

    I have nooo idea, lol. I'm so new to this! It's just strange because it looked fine on the rest of the areas that used that part of the texture/normal map.

    Share this post


    Link to post
    Share on other sites

    Well, flipped normals are quite common, but they should be translucent ingame, instead of darkened. You sure it's not a double face? Try deleting it and see if there's no face behind it.

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Just now, Darf said:

    Well, flipped normals are quite common, but they should be translucent ingame, instead of darkened. You sure it's not a double face? Try deleting it and see if there's no face behind it.

    Yes I'm sure. I even completely deleted that segment and remade it and remapped it a few times... certainly only one face there. I did fix it finally by rotating the UV map 180 on that face.

    Share this post


    Link to post
    Share on other sites

    if it is blender you are using it is a flipped face - wrong sided

     

    Flip Direction

    Reference

    Mode: Edit Mode
    Menu: Mesh ‣ Normals ‣ Flip or Specials ‣ Flip Normals
    Hotkey: W, Flip Normals

    Well, it will just reverse the normals direction of all selected faces. Note that this allows you to precisely control the direction (not the orientation, which is always perpendicular to the face) of your normals, as only selected ones are flipped.

    Recalculate Normals

    Reference

    Mode: Edit Mode
    Menu: Mesh ‣ Normals ‣ Recalculate Outside and Mesh ‣ Normals ‣ RecalculateInside
    Hotkey: Ctrl-N and Ctrl-Shift-N

    These commands will recalculate the normals of selected faces so that they point outside (respectively inside) the volume that the face belongs to. This volume do not need to be closed. In fact, this means that the face of interest must be adjacent with at least one non-coplanar other face. For example, with a Grid primitive, recalculating normals doesn’t have a meaningful result.

     

    Directions

    To find out which direction ther normals are pointing at you can enable "normal" in the mesh display tab. 

    72jnJ.png

    42txX.png

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • 3 hours ago, OwiHH said:

    if it is blender you are using it is a flipped face - wrong sided

     

    Flip Direction

    Reference

    Mode: Edit Mode
    Menu: Mesh ‣ Normals ‣ Flip or Specials ‣ Flip Normals
    Hotkey: W, Flip Normals

    Well, it will just reverse the normals direction of all selected faces. Note that this allows you to precisely control the direction (not the orientation, which is always perpendicular to the face) of your normals, as only selected ones are flipped.

    Recalculate Normals

    Reference

    Mode: Edit Mode
    Menu: Mesh ‣ Normals ‣ Recalculate Outside and Mesh ‣ Normals ‣ RecalculateInside
    Hotkey: Ctrl-N and Ctrl-Shift-N

    These commands will recalculate the normals of selected faces so that they point outside (respectively inside) the volume that the face belongs to. This volume do not need to be closed. In fact, this means that the face of interest must be adjacent with at least one non-coplanar other face. For example, with a Grid primitive, recalculating normals doesn’t have a meaningful result.

     

    Directions

    To find out which direction ther normals are pointing at you can enable "normal" in the mesh display tab. 

    72jnJ.png

    42txX.png

    Hi, I am actually positive it wasn't the normals as I understand how they work and probably checked them 20 times/recreated the face several. In CS, also, a flipped normal was always transparent - in this case, the face was visible but heavily shadowed. I could see it perfectly if the sun was JUST right or I put a nightlight against the wall, so the face was there and showing normally. In the end, I flipped the UV map around for that face and the shadowing was fixed

    Share this post


    Link to post
    Share on other sites

    Hi, sorry to bump another old thread, but I'm having this exact problem and I don't feel that it is answered here. I've spent hours googling and experimenting and I can't find a concise solution.

     

    I've figured out that the "weird shadows" problem is due to oddly pointed normals of the VERTICES. It has nothing to do with "backwards FACE normals" and cannot be fixed in Blender with "ctrl-N" or "flip normals." Your face normals will look perfectly fine, but you will clearly see the problem in 3D View->Solid display mode, and that is exactly how it will look in Cities:Skylines (terrible!).

    problem-verts1.jpg

     

    If I turn on the normals for Verts (dark blue lines), you can see that the normals at the edge of the wing point out. I think this is causing the messed up shadows!

     

    problem-verts2.jpg

     

    Since the face normals are averages of the 3 vert normals, I understand how this can cause the problem. In theory, these verts should be split, so that the the normal for the top part of the wing points up, and the normal for the bottom part of the wing points down. I was able to fix this particular problem by adding a global "Edge Split" modifier to the model. But this is just one place that the problem occurs, and this solution didn't work for all of the problems.

     

    problem-verts3.jpg

     

    The problem occurs around the windows of the fuselage, and I can't find a way to fix it for the life of me. All of the VERT normals and FACE normals point out and look like I think they should, but the messed up shading is clear as day. I've flipped and reversed the UV maps to no avail (I don't think it has anything to do with UV mapping, since you can clearly see it in the solid view before any mapping is done). I've tried about every command in the Mesh->Verts and Mesh->Face menu and I can't find anything that will fix this problem. Do you guys have ideas?

     

    Much thx in advance

    -Ami

    Share this post


    Link to post
    Share on other sites

    I haven't got a perfect way to fix this, but I've had fair success with redoing the face. Select the affected faces, hit x and select "Faces only" and then redo the face. Ofc it then needs to be unwrapped again for the texture, which is annoying. But it's the only thing I've found so far to fix it.

    Share this post


    Link to post
    Share on other sites

    Yeah, it seems like "start over" is the best approach here, lol. I've deleted that entire side of the fuselage and I'm rebuilding it from scratch. It's really frustrating to not be able to recognize and solve the problem directly.

    Share this post


    Link to post
    Share on other sites

    I don't see why the UV needs to be touched at all.

    You probably won't be able to do it automatically.

    I think you could simply reset the smoothing and redo it for the problematic area.

    Share this post


    Link to post
    Share on other sites

    I've tried that with no luck at all. I've only had it happen with models I exported from the game or something else I didn't create from scratch myself, so I'm not sure what causes it. I've tried all the smoothing options I could find, but all it did was change the weird shading, not get rid of it. The only thing I've managed to get it to "reset" is to delete the face and make a new one.

    Share this post


    Link to post
    Share on other sites

    It's comforting to know that it's not just me that has wrestled with this issue. Maybe we need to post about it on some blender forums. My friends that use blender also have no idea what is going on.

    Share this post


    Link to post
    Share on other sites

    This bug or lack or knowledge or whatever-the-hell-it-is needs a good and easy solution. It keeps wrecking my workflow.  I'm trying to update this prop by improving the LOD and adding some functioning lights:

     

    20170220155328_1.thumb.jpg.b65f2ab97ed8b488feb84f0f5931285f.jpg

    It should be a simple process, but these weirdo shadows are just killing me. This model has almost 4k tris and rebuilding all of the messed up faces is not an option.

     

    When you export an .OBJ from the game and import it into blender, you seem to get lots of these problems.

     

    Share this post


    Link to post
    Share on other sites

    Yeah I was shocked at the 4k tris too. I'm just trying to update this guy's old model cause I think it would be very useful and lots of people want it with functioning lights.

    http://steamcommunity.com/sharedfiles/filedetails/?id=504250767&tscn=1487547911

     

    The funny thing about this problem is that if you google "blender weird shadows" you get tons of hits, with people having this exact problem, but I've yet to find a simple solution that is not "rebuild all of the faces."

    Share this post


    Link to post
    Share on other sites

    I've tried to fix some models that he made too, but the endless bugs convinced me to not do it. It's a shame because he made some really nice buildings. 

    Share this post


    Link to post
    Share on other sites
    27 minutes ago, AmiPolizeiFunk said:

    Yeah I was shocked at the 4k tris too. I'm just trying to update this guy's old model cause I think it would be very useful and lots of people want it with functioning lights.

    http://steamcommunity.com/sharedfiles/filedetails/?id=504250767&tscn=1487547911

     

    The funny thing about this problem is that if you google "blender weird shadows" you get tons of hits, with people having this exact problem, but I've yet to find a simple solution that is not "rebuild all of the faces."

    Dunno, what's it called in Blender, but welding in 3dsMax basicly means that  any isolated point gets deleted and vertex points within x nr of millimeters will be joined. Result is also that often normals get reset.

    Share this post


    Link to post
    Share on other sites

    I'm getting really frustrated. I rebuilt the entire tower practically from scratch (it's now around 1k tris), and I get this:

    20170220190940_1.thumb.jpg.c6b06e4d7cc92037442a37c81ba8c633.jpg

    All I'm using is an ultra-simple diffuse map and and almost all entirely black spec map. I have no clue what I'm doing wrong.

    Untitled-1.thumb.jpg.cee55b3167c41e11b610c0a9dafb35e6.jpg

    Here are my source files:

    https://www.coh2.org/file/13459/rail-lighting-tower.rar

     

    If anybody has a moment to take a look, I'd greatly appreciate it. I'm at my wits ends. 

    Share this post


    Link to post
    Share on other sites

    I took a quick look. I don't know why but I found using ModTools that the final asset uses random textures that you didn't import. The main model has a diffuse and a normal map, en the LOD ends up with a diffuse, specular and normal map. I couldn't dump the main mesh textures but here are the LOD's.

    I have to go to work now, I hope someone else can help. I imported as well and got the same result and couldn't find anything in the places I'd expect them to be. This is next level weirdness...

    Long story short: the Asset Editor completely ignores the imported textures and magically creates new ones which are twice as big and have completely different colors

    Share this post


    Link to post
    Share on other sites

    Yeah, when I exported the model originally with modtools, it had those extra maps. I figured they weren't necessary so I deleted them. Are you saying that links to those other texture maps are embedded in the .obj file somehow? I didn't think this was possible. I think I might be more confused now.

    Share this post


    Link to post
    Share on other sites

    Ok there's no way that any links to any textures are in the .obj file (I just looked at it). 

    I even changed the filename to import, and it's still messed up (although, it looks different).

    HOW DOES IT KNOW?!

    Share this post


    Link to post
    Share on other sites

    Than why are the textures in your file like 8x8 pixels? A bigger texturemap would probably solve the textureglitches. Still 1000 tris is a huge amount, you can easily save 800 of that by using some alpha maps.

    Share this post


    Link to post
    Share on other sites

    Check if all your textures are correct sizes - powers of 2 such as 256 512 1024 etc

    I've seen textures break when a texture has an incorrect size, maybe it's just one of the textures, or maybe one of the lod textures is a different size than the others.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now


    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections