Jump to content
Sign in to follow this  
CapTon

SimCity 4 Bug (Help Needed)

10 posts in this topic Last Reply

Recommended Posts

Hello, SimCity 4 players. I encountered this bug while trying to record a test video for my Let's Play of SimCity 4. All residential zones are connected to roads, yet it says they're not. Can anyone tell me what's going on?

 

http://www.youtube.com/watch?v=LBxa4VcwJhk&feature=youtu.be

 

Thanks! :)

Share this post


Link to post
Share on other sites

Thanks for the video.

 

From what I can tell, all areas have a sufficient access, and are connected to the main avenue. Maybe try speeding up the simulation until houses build. Sometimes the no road zots can show when zoning, and disappear when they become occupied.

 

By the way, it looks like the menus are flickering when you pan around. Is this a separate problem, or just from the video's recording?

Share this post


Link to post
Share on other sites
  • Original Poster
  • Thanks for the video.

     

    From what I can tell, all areas have a sufficient access, and are connected to the main avenue. Maybe try speeding up the simulation until houses build. Sometimes the no road zots can show when zoning, and disappear when they become occupied.

     

    By the way, it looks like the menus are flickering when you pan around. Is this a separate problem, or just from the video's recording?

     

    Thanks, but I've already tried that. I sped up about a year and they're still like that :) and no problem.

     

    It's just the video's recording. I hadn't fiddled around with the settings yet.

    Share this post


    Link to post
    Share on other sites

    Quite strange, the houses at the edge of your residential area do not display the no connection zot. Maybe try improving the road connection (going to the farm), ie make it an Avenue x Road crossing, instead of a road at the one side and a street at the other (not sure if this connection type actually works). So drag a two-tile-long road section across the avenue intersection. But the farm and the power plabt do not offer that many jobs anyways, so you will need more jobs.

     

    Another gameplay advice, do not zone R along the avenue, they will suffer from the noise and the pollution. Instead zone C, they benefit from the high traffic (=customers).

    Share this post


    Link to post
    Share on other sites

    You might want to look into installing the Extra Cheats DLL mod so you can use the "Draw Path" feature. This will let you see if the paths are actually connected correctly.

     

    If you're not familiar with the Extra Cheats DLL, don't be worried, it's not actually any kind of cheat in itself, only unless you use it for one. But one of the best features of the mod is the Draw Paths command. When you're finished, just use the Hide Paths command to go back to normal view. 

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Quite strange, the houses at the edge of your residential area do not display the no connection zot. Maybe try improving the road connection (going to the farm), ie make it an Avenue x Road crossing, instead of a road at the one side and a street at the other (not sure if this connection type actually works). So drag a two-tile-long road section across the avenue intersection. But the farm and the power plabt do not offer that many jobs anyways, so you will need more jobs.

     

    Another gameplay advice, do not zone R along the avenue, they will suffer from the noise and the pollution. Instead zone C, they benefit from the high traffic (=customers).

     

    Thanks :)

     

     

    You might want to look into installing the Extra Cheats DLL mod so you can use the "Draw Path" feature. This will let you see if the paths are actually connected correctly.

     

    If you're not familiar with the Extra Cheats DLL, don't be worried, it's not actually any kind of cheat in itself, only unless you use it for one. But one of the best features of the mod is the Draw Paths command. When you're finished, just use the Hide Paths command to go back to normal view. 

     

    Might check that out. 

    Share this post


    Link to post
    Share on other sites

    Cogeo has made an interesting point. It seems your networks are connected like this:

     

    B7a3BQG.jpg

     

    The arrows represent the direction of traffic. If you extend the road along the yellow dotted line, this may ensure the connection is adequate for the zones. Also try this with the streets. Otherwise traffic will have no option but to take a 'U' turn and go around. It'll probably take a while for the simulation to recognise this change.

     

    Also try building a parallel road above the first one, and zone some industry near the power station (for more jobs).

    Share this post


    Link to post
    Share on other sites

    Avenue x Street crossings do work normally, if they span up to the opposite direction of the avenue, ie connect to both segments. Just I'm not sure about this special connection type (avenue x road+street).

    Share this post


    Link to post
    Share on other sites

    Not strange at all.  The no-road zot is sometimes also used to indicate that there is no path from the lot to a job.  Do you have enough jobs for that housing space?  Is it properly connected?  Normally, these zots will disappear on the second pass of the pathfinder once the viability of the lot is determined and a path to work has been found.

     

    If a city is very heavily loaded (1,000,000 or more objects), it may take a while for this to occur because the processor is loaded to 100%.  If you want them to go away (only the current ones) use the command tastyzots to remove them.

     

    BTW, how much load is your video processor putting on the system?

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Didn't expect this many replies :) but I sped up the time another year and connected the street onto both sides of the avenue, and everything works again. Thanks for all the help, guys! Stay tuned because I'm doing a Let's Play for the game and I'm currently looking for a software or something where I can create a specific intro for my SimCity 4 Let's Play.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections