Jump to content
Sign in to follow this  
Dockter

SC4 - Capped FPS that changes with game speed selected

23 posts in this topic Last Reply

Recommended Posts

Hello, I recently installed SC4 onto my new PC after getting frustrated with SC5.

 

I've noticed that the FPS in-game seems to be capped.  If I run at >>> speed, my max fps while Im staning still is 15fps.  If I move around, my FPS jumps to 200-300fps, but the game simulation seems to stop progressing (calendar wise).  Once I stop again, and the fps starts to drop back to the locked 15fps, the counter then progresses very fast.

 

If I change my mode to >>, then my FPS is locked at 20.  If I use mode >, then my FPS is locked at 30.

 

Has anyone else seen this?

 

Is this an intended consquence, I'd rather not play a game at 15fps.

 

For what its worth, Ive already edited the Graphics Rules.sgr and Video Cards.sgr.  Those recommended changes had zero affect on this issue.

 

Many Thanks.

Share this post


Link to post
Share on other sites

The simulation does pause whenever you move around.  And once you get larger cities, the game might slow down and get choppy, no matter how powerful your computer is.  Especially when you play on faster speeds.  These are just the limitations of an older game that can't utilize the full benefits of modern technology.

 

You can turn down the settings (especially Shadows; set those to low and I bet you'll see a big difference), and try to play mostly on the slowest speed.

Share this post


Link to post
Share on other sites

This is a single threaded legacy game.  Don't expect miracles from it.  Since it uses only one core everything has to run in its turn.  The simulation will eventually put your core at 100% and things will really slow down.  I fail to see why it matters if the frame rate is more than 16 fps, because this is the human persistence of vision threshold.  What additional detail are you expecting to see in this old, old game?

Share this post


Link to post
Share on other sites
  • Original Poster
  • This is a single threaded legacy game.  Don't expect miracles from it.  Since it uses only one core everything has to run in its turn.  The simulation will eventually put your core at 100% and things will really slow down.  I fail to see why it matters if the frame rate is more than 16 fps, because this is the human persistence of vision threshold.  What additional detail are you expecting to see in this old, old game?

    Actually just above 30fps is what the human eye can see.

     

    Regardless, Im just curious why they cap the FPS.

    Share this post


    Link to post
    Share on other sites

    Same problem here... When i move the mouse over the map my fps up to 60, if i stop moving the mouse the game drops the frame rate to the current game speed selected

    Pause + > = 30 fps

    >> = 20fps

    >>> = 15fps

     

    I remember that i had played the game constantly locked at 60fps. I've tryed to reinstall and delete all the mods... nothing works

    Share this post


    Link to post
    Share on other sites

    And nothing will work.  This is a massive simulation, and you get to the point where it just can't keep up the frame rate.  Relax, put it in Turtle mode, and enjoy the animation.  Running this game at a high rate gives priority to the simulation.

    Share this post


    Link to post
    Share on other sites

    I think i found a fix...

    If the simulation can keep the 30fps on the "Turtle" speed, why not increase the Turtle speed?

     

    Here is what i do - 1º Download ILives Reader

                                  2º After install, open the program and set the location of the game, etc...

                                  3º Open SimCity_1.DAT and go to - Navigator on tools bar

                                  4º Open Simulator, then Main Simulator and search for Simulator Speeds. Open it.

                                  5º Select: Display as INT(integer value), here you have the 3 speeds of the gameplay.

                                  The lower the value the higher the speed of the game. Set on the 1º value 50, Save and exit the program.

     

    Start the game and see the diference :D

    Share this post


    Link to post
    Share on other sites

    Seems like a force to turtle mode, so it must control the accelerator control.  If fps is more important to you than being able to force a burst to get something done, then that's your choice.  You realize that if you ever reinstall the game this will be lost?

    Share this post


    Link to post
    Share on other sites

    I recommend SC4 Launcher: 

     

    it lets your computer run on more than one core, and as icing on the cake allows custom resolutions. I haven't had any crashes so far, and the simulation is really smooth. only downside is that you can't now grab a cup of tea while waiting for the game to save.

    Share this post


    Link to post
    Share on other sites

    Seems like a force to turtle mode, so it must control the accelerator control.  If fps is more important to you than being able to force a burst to get something done, then that's your choice.  You realize that if you ever reinstall the game this will be lost?

     

    Yes, it's like a force, but at 15fps the game is very slow, and if moving around the map and stop, having constantly drops of framerate from 60 to 15 fps it's boring. The speed of the game between turtle and rhino is good enough, but playing at 30fps without any drops is priceless. I might have exagerated when i said to put the game speed at 50, right now i have 800 (something between 500 and 1500 is good). The problem here is maintain a "good" frame rate to play the game smoothly and have a good game experience. ( and yes, if you reinstall the game you obviously restore the original files)

    I recommend SC4 Launcher: 

     

    it lets your computer run on more than one core, and as icing on the cake allows custom resolutions. I haven't had any crashes so far, and the simulation is really smooth. only downside is that you can't now grab a cup of tea while waiting for the game to save.

     

    SC4 Launcher doesn't worked for me

     

     

    Please understand that this isn't about high game speeds and a possible cheat but a solution to those that want to enjoy the game without freezes and use the "cheetah" speed without any fps drop.

     

    Share this post


    Link to post
    Share on other sites

    The game's design is the problem; it's inefficient.  Try turning the settings down, especially Shadows.  (This will still only help to a limited extent)

     

    And remember that Cheetah Speed, whether this was an intended design or not, should not be used except when you just want to sit back and watch zones fill in.  You just can't really build while on Cheetah speed.

    Share this post


    Link to post
    Share on other sites

    Maybe I am just too old and slow for today's snappy graphics hounds, but I don't have trouble with these fps issues.  Could it be a problem with your hardware?  Or are you all just being "fashionable"?  It is a 10 year old game and all the tweaking in the world won't solve its problems.

    Share this post


    Link to post
    Share on other sites

    The game's design is the problem; it's inefficient.  Try turning the settings down, especially Shadows.  (This will still only help to a limited extent)

     

    And remember that Cheetah Speed, whether this was an intended design or not, should not be used except when you just want to sit back and watch zones fill in.  You just can't really build while on Cheetah speed.

     

    I've tryed the lowest settings on the game (even resolution), the game framerate drops always to the same

    Pause + > = 30 fps

    >> = 20fps

    >>> = 15fps

     

    I've tryed everything...

     

     

    Maybe I am just too old and slow for today's snappy graphics hounds, but I don't have trouble with these fps issues. Could it be a problem with your hardware? Or are you all just being "fashionable"? It is a 10 year old game and all the tweaking in the world won't solve its problems.

     

     

    It's not a question off snappy graphics, but smoothness, playing without tearing. You're right, a 10 year old game won't run properly on recent computers. Tecnologies are different, the game is not prepared ro run on windows 7, multicore processors and recent graphic cards. My computer is a recent custom build.

     

    Playing the game at 30 fps is good enough for me.

    Share this post


    Link to post
    Share on other sites

    It doesn't look that choppy to me when I play...but I've never specifically checked the FPS.  Although I can say for sure that it's not as choppy as Minecraft at 15 FPS.

     

    Perhaps it's a problem with your graphics card or its settings.

    Share this post


    Link to post
    Share on other sites

    It doesn't look that choppy to me when I play...but I've never specifically checked the FPS.  Although I can say for sure that it's not as choppy as Minecraft at 15 FPS.

     

    Perhaps it's a problem with your graphics card or its settings.

     

    I'd bet its compatibility issues with architecture, i'm using windows 7 x64 with a core i5 3570k

     

    Did you try running software rendering?

     

    Yes, i've tryed everything :S

    Share this post


    Link to post
    Share on other sites

    I run SC4 on Win 7 x64 with an i3 without problems.  But I'm only using integrated graphics.

     

    Check the settings of your video card itself; make sure that all of the 3D options are set to "use applications settings" or something like that.

    Share this post


    Link to post
    Share on other sites

    my simcity 4 deluxe video setting always revert to default everytime start the game, i try add this to the shortcut target  -CustomResolution:enabled -r1366x728x32. But still when start the game it run with 800x600 and video setting revert to default. My laptop use amd radeon 6470m. Any help???

    Share this post


    Link to post
    Share on other sites

    You  do start the game from the short cut, yes?  If the commands are not properly laid out they won't work.

     

    The requirements are simple.  Each hyphen (-) must be preceded by a single space.  This also applies to the first one immediately after the closing quote on the complete path name.  Example (mine):

     

     "C:/Program Files/Maxis/SimCity 4 Deluxe/Apps/SimCity 4.exe"  -intro:off -CustomResolution:enabled -r1920x1080x32 -d:software -f -CPUcount:1

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections