Jump to content
Sign in to follow this  
Nothh888

Crash on Startup

6 posts in this topic Last Reply

Recommended Posts

Hello,

I recently bought Sim City 4 on steam and I'm trying to run it on windows 7. The game is crashing on the EA Games logo as the game starts up. I've tried all the fixes I could find online such as setting the game to run with one CPU with steam and with the task manager, running the game in compatibility mode for windows XP and running the game as an administrator.

I'm wondering what else I could try to get my game to start succesfully and I'll post my system specs if anyone thinks that it will be relevent.

Share this post


Link to post
Share on other sites
  • Original Poster
  • if cpucount:1 doesn't fix it then i'm not sure and not sure how much help i can be since i have win8

    Yeah, setting the game to only use one cpu hasn't fixed the problem yet.

    Share this post


    Link to post
    Share on other sites

    Crash on launch usually indicates environment trouble. You should try reading the introductory pinned threads. This is a technical forum, and we can't guess (even though some have tried). Please give us the following information:

    1. Is your multimedia system working correctly? Run dxdiag to check. If your graphics or sound set up is incorrect or disconnected the game will not start. The usual cause of this is unplugged speakers.

    2. What is your machine's configuration? Details please, not model numbers.

    3. What is the version number of your game? Find it from the SimCity 4.exe file by hovering your mouse over it.

    4. If you have one, post the first 20 lines only of one of your exception reports (use the .txt file).

    Without this data, there is no way to intelligently pinpoint your problem. Anything up to now has been an educated guess.

    Share this post


    Link to post
    Share on other sites

    Does the ea logo show up and freeze while in the motion? If so I had the same problem and it turned out to be a speaker problem. When the ea logo comes up the game says "ea games, challenge everything" if your speakers or something to do with your volume settings is off it will cause the game to crash because the game can't say "ea games, challenge everything". Try plugging in some headphones and if it runs that is your problem. I don't quite remember what I did to fix. Try changing the volume setting.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections