Jump to content
Sign in to follow this  
Cornbread_v2

Help Running on New Hardware

8 posts in this topic Last Reply

Recommended Posts

Hey guys I recently purchased a new laptop and have been preparing for the new sim city game by playing some Sim CIty 4 again. However, it runs terrible on my new laptop. I have searched through dozens of forums and posts and have finally just given up on fixing it myself. The game is PLAYABLE in software but I am not one to really accept PLAYABLE. I want to be able to play sim city like I used to, maxed out. When attempting to play in hardware rendering the game runs extremely slow and even crashes. I have the resolution set to custom and the CPU set to use only one core. I was also running this machine on Windows 7 with the exact problems so it is not caused by my upgrade to Windows 8.

LAPTOP SPECS

Sony Vaio S Series (svs151190x)

Windows 8 Pro

Intel® Core i7-3612QM CPU @ 2.10 GHz

8 GB RAM

Hybrid Graphics?

Nvidia GeForce GT 640M LE

Intel® HD Grapics 4000

I am not very knowledgeable on how the hybrid graphics affects this situation. If any more specs are required I would be happy to supply them. Thanks for the help guys.

Share this post


Link to post
Share on other sites

Check in your machine documentation and find out how to turn off the Intel graphics. Then, in the hardware control panel for the nvidia card be sure that all the 3D controls are set to 'program selected' or equivalent.

Unless I've forgotten something about the I7 chip set it has four cores and may even have hyperthreading. You will need to use the

-CPUcount:1

option to throttle down the Windows 8 dispatcher. You should then be able to run in hardware rendering, but W8 is so new that you have joined the pioneers for this game. -- You know, the guys who get arrows in their chest. --

Share this post


Link to post
Share on other sites

Open the nVidia Control Panel, set up a new application profile for SimCity 4 (or modify the existing one) and set the default graphics card to the nVidia one (If I remember correctly it calls it "High performance nVidia Graphics").

You'll still be left with a Metric Ton of bugs though (I have a GT 630M in my laptop) and I haven't found a concrete fix. The game should run much faster though. Also, turn the Shadows down as low as they can do, they use functionality that isn't properly implemented on any modern card.

Share this post


Link to post
Share on other sites
  • Original Poster
  • WOW thank you so much. Setting the nvidia settings for sim city 4 to that really helped. It is playable on hardware now. Still not maxing out but much better than before. Now how do I throttle the Windows 8 dispatcher? Honestly I have no idea what you mean by this.

    Share this post


    Link to post
    Share on other sites

    In the call for the program (shortcut or whatever) there is a command line that looks something like this:

    "C:\Program Files (x86)\Maxis\SimCity 4\Apps\SimCity 4.exe"

    If you got your program from Steam or Origin it will be somewhat different, but it is the same meat with different gravy.

    To use the CPU restriction you just add it to the end of the command line after one space:

    "C:\Program Files (x86)\Maxis\SimCity 4\Apps\SimCity 4.exe" -CPUcount:1

    If someone using Steam or Origin versions could chime in here with the completely correct instructions it would help. I am on Linux and my command structure is actually a script: [Don't look if you are not much of a computer geek.]

    #!/bin/bash

    date

    env WINEPREFIX="/home/john/.wine" \

    wine "C:/Program Files/Maxis/SimCity 4 Deluxe/Apps/SimCity 4.exe" \

    -intro:off -CustomResolution:enabled -r1920x1080x32 -d:software\

    -f -CPUcount:1 -audio:off &>~/sc4.log

    date

    Share this post


    Link to post
    Share on other sites
  • Original Poster
  • Oh I had that done already. I didn't know that was the same as restricting it to a single core. Thanks for the help guys. I can actually enjoy my game now.

    Share this post


    Link to post
    Share on other sites

    I don't have Windows 8 and thus I don't know anything about it, so if my forthcoming suggestion isn't possible, just ignore this post: Is there a way to set the game to play in Windows XP (SP2) compatibility mode? Try that.

    Share this post


    Link to post
    Share on other sites

    I don't have Windows 8 and thus I don't know anything about it, so if my forthcoming suggestion isn't possible, just ignore this post: Is there a way to set the game to play in Windows XP (SP2) compatibility mode? Try that.

    Someone posted that the WoW functions from W7 are not in W8. Since I don't run windows at all, you can take this for what it is worth.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  

    Register a New Account

    Sign In  

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×

    Help Keep Simtropolis Online, Open & Free!

    stexcollection-header.png

    Would you be able to help us catch up after a bit of a shortfall?

    We had a small shortfall last month. Your donation today would help us catch up for this month.

    Make a Donation, Get a Gift!

    We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

    By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

    Each donation helps keep Simtropolis online, open and free!

    Thank you for reading and enjoy the site!

    More About STEX Collections