Jump to content
Zelgadis

Post station fix requests here

50 posts in this topic Last Reply

Highlighted Posts

On 7/5/2018 at 9:01 PM, Synergy67 said:

Is someone willing to provide fixes for the following items I am using, but have the Mac transit numbers bug?

I missed this since it's an older topic I wasn't following. (I've now done so.) Yes, I can give this a whirl tomorrow and see what I can come up with.

Share this post


Link to post
Share on other sites

@Synergy67

Here's the (attempted) fixes for Shmails 1x1 Parking set. It contains 3 Garages listed in the order they show in the menus:

  1. Park Place Garage (which needed the tweak)
  2. Park-A-Lot Garage (which needed the tweak)
  3. Park Here Garage (which appears to be Mac friendly already)

For easy testing I've created a small city where the Sims only choice to get to the factory jobs is to use the Park and Go style garages: City - Shmails Parking.sc4. You can place this in your Regions\Downloads folder then import it into a medium size city tile in a sandbox region.

imghp0058.jpg

 

Here's the first one (Park Place Garage) in the game where I fixed the two variables for the Mac. There is a Park Place Garage 1x1_12ff7b91.sav file in the Park Place Garage folder which should be deleted and for the Mac fix you should also delete Park Place Garage 1x1_12ff7b91.SC4Lot then drop in: Park Place Garage 1x1_12ff7b91-Mac.SC4Lot

imghp0053.jpg

 

The second one (Park-A-Lot) was showing the incorrect name on the query so I fixed that and also changed the two variables so it should have the correct capacity for the Mac. There is a Parkalot1x1a_d6c3ab89.sav file in the Park-A-Lot Garage folder that should be deleted and for the Mac fix you'll also delete Parkalot1x1a_d6c3ab89.SC4Lot then drop in: Parkalot1x1a_d6c3ab89-Mac.SC4Lot

imghp0060.jpg

 

The third one (Park Here) looks like it's already good to go for the Mac.

imghp0057.jpg

 

So, give these files a try and see if you get similar numbers for the Actual Usage.

*:)

Share this post


Link to post
Share on other sites

@Synergy67

For the Upgradeable Seaports Revamped it appears only one file needs to be tweaked which I've done. For this one you'll delete the Seaport_FreightRailStation.SC4Lot file and drop in: Seaport_FreightRailStation-Mac.SC4Lot

Since it turns out there are five hidden dependencies only listed in the Upgradeable Seaports.doc file and two of them have dead linkys, I'm not going to test this myself (which would only be a test of the capacity on Windoze for comparison anyhow).

You're on your own to see if it works. *:P Let me know tho. *;)


Edit: I believe I've found the five deps including the two broken linkys:

   BSCBATProps RP2005 Vol02

   Underworlds Industrial Prop Pack

   PEG_CDK--IND_205_SU

   BSC Mega Props JES Vol01

   BSC Mega Props gascooker Vol01

 

Share this post


Link to post
Share on other sites

Hi Corina, thanks so very much! You and Cyclone Boom are taking such good care of my SimCity needs. I have dropped the garages into a city for testing and will verify the capacity when I go back to check. I forgot to look before I saved and left the last time. I noticed that Park Place and Park-A-Lot Garage have both lost their custom name and are now just called "custom ploppable." Out of respect for Shmails' clever work, it would probably be best to put those whimsical names back on the fixes for perpetuity.

Thanks also for the seaport rail station fix. I was using it for a while in game with the seaport (I use that seaport as my seaport anywhere I need one presently.) I forgot I hadn't hunted down the rest of the dependencies for it, only had two of five. It looked pretty good even at only 2/5 of its props, ha! Thanks for the quick links to pick up the rest. I'll test this out when I get the chance and confirm here it's working for me. 

I have cities now up from 50K-90K in size on four large tiles in the Pacific Rim Park map Cyclone imported for me. I've been busy tinkering and having fun. I do have pics and some comments and queries from my experiences, so I'll drop those on my other main thread sometime soon. Meanwhile, I was just reading a lot more about capacity, occupancy, demand, and querying, and it all almost makes sense. 

 

 

Share this post


Link to post
Share on other sites

@Cyclone Boom Imagine my disappointment when I discovered that flora blasting a city did not indeed pummel it back into the ground. I can see you're a bit mischievous. I'll be sure to keep a closer eye on you. ;)

Hey, I see we crossed paths at least once back in 2013 (on page 3 comments at the link below), which I just noticed researching a way to fix the darn, inexplicable brown boxes I'm still getting with this lot, despite having the dependencies as before. it doesn't look like anyone figured out what's wrong with it. I posted a picture of what I am getting on the STEX thread below.
 

Share this post


Link to post
Share on other sites
3 hours ago, Synergy67 said:

Hi Corina, thanks so very much!

You're welcome!

 

3 hours ago, Synergy67 said:

I noticed that Park Place and Park-A-Lot Garage have both lost their custom name and are now just called "custom ploppable." Out of respect for Shmails' clever work, it would probably be best to put those whimsical names back on the fixes for perpetuity.

I'm in total agreement the names should remain intact. Problem is, I can't see where or why they'd go missing. In addition to the popup query in my pics above, here's what I see:

imghp0069.jpg

imghp0070.jpg

imghp0071.jpg

imghp0072.jpg

imghp0073.jpg

imghp0074.jpg

Share this post


Link to post
Share on other sites

I bet it has to do with the "Mac" in the name no longer matching the .sav file with each garage. I'll change the fixed lot names to the original names to match, and I wager that will take care of it. They are working correctly for capacity now, indeed, thanks again.

Share this post


Link to post
Share on other sites
17 minutes ago, Synergy67 said:

I bet it has to do with the "Mac" in the name no longer matching the .sav file with each garage.

My (limited) understanding of the .sav file is it is a duplicate made by the Lot Editor prior to whatever the last changes were by the author. I'm pretty sure I've read multiple times in plugin organization threads one should simply delete any .sav files. In my above screenshots I've deleted them and I'm using the new files with the "Mac" as part of the file name. Let me know if you figure out what's going on cause I'm uncertain what the cause could be. If we figure out what I can do differently, I'll do that to fix them up.

 

3 hours ago, Synergy67 said:

... the seaport rail station fix. ... It looked pretty good even at only 2/5 of its props, ha!

Turns out I got interested in this cause I really like the idea of sending freight via trucks to trains to the seaport. Here it is in a test city using only the .SC4Lot file and none of the 5 deps installed:

imghp0064.jpg


Then for comparison here it is turned and zoomed with all deps missing:

imghp0067.jpg


And here with all deps installed:

imghp0068.jpg


I agree it looks pretty decent even missing the extra props. (And the cargo boxes are the same, just they fade in an out.)

Share this post


Link to post
Share on other sites

That leaves one wondering just how many props he actually used from those five prop sets, considering there is little observable difference. In fact, the only difference I see here is in ground textures. However, there are three versions of this seaport as it upgrades. I expect the beefier versions use more of the props. I'll mess more with the parking garage files and see what it takes to make the names return properly.

Share this post


Link to post
Share on other sites

Oh, there is a way to line up that freight station parallel on the left back side of the seaport that comes in the set (which hugs the coast on its long side, 90 degrees different from most seaports), which allows the freight to go straight to the docks, rather than through trucks again. Oh, and i see we're just looking at the freight station. I was talking about the seaport itself looking okay with 2/5 of the props. I didn't use the freight station long once I realized it couldn't actually help with the freight.

Share this post


Link to post
Share on other sites
6 minutes ago, Synergy67 said:

Oh, and i see we're just looking at the freight station. I was talking about the seaport itself looking okay with 2/5 of the props.

Yeah, I did switch gears on ya. *:P

But, I was just interested in the freight station atm. I considered all the Seaports from the pack, but once I checked the install size (34,384,077 bytes) for the 5 deps I felt that was more space and load time than I'm willing to allocate for a total of 4 new lots. I did then check with DataNode to see what is missing for just the freight station:

Seaport-Freight Missing Deps.jpg

Then with them all loaded I can see which whats those are and if I'm feeling froggy I could then extract only the ones it needs to reduce the overhead of having 5 huge packs installed.

Share this post


Link to post
Share on other sites

All that just for the freight station? I assume most of the props used from it are Maxis/built-in then, since I could only see one texture difference?

It's true, that freight station could be used by itself or at a distance from a port. It's an inverse of a normal freight station essentially, not normally useful, except for getting freight onto a port, which makes it very attractive.

Share this post


Link to post
Share on other sites
6 minutes ago, Synergy67 said:

All that just for the freight station? I assume most of the props used from it are Maxis/built-in then, since I could only see one texture difference?

That list is just the missing ones without the extra dependencies installed. The freight station lot has a total of 94 Lot Objects, so yes, most are Maxis things.

Share this post


Link to post
Share on other sites

@Cyclone Boom noticed that the lot files include an XML entry which does have the text "custom ploppable" in it. I've done some research and it appears that file is used by the Lot Editor, but is not required by the game. I wonder if the Mac picks up on that if present. So, for a you-gotta-try-it-for-me test, I've removed the XML portion for those two lots. They still work perfectly fine in Windoze. Let me know if this makes any difference for you. (Take out the corresponding lot files for the test.)

Park Place Garage 1x1_12ff7b91-Mac-NoXML.SC4Lot

Parkalot1x1a_d6c3ab89-Mac-NoXML.SC4Lot

Share this post


Link to post
Share on other sites

@CorinaMarie I removed the parking garage .sav files -and- named the LOTs back to their original names, and they both register normally with the original titles and stats, so I'm all good with those now, thanks, yay! 

I have three words which I think might describe you: meticulous, methodical, and patient. Am I right? Cheers.

Share this post


Link to post
Share on other sites

Would you still like me to test the de-XML-ed files for you on my Mac? I'm sure they work fine too. I think the problem I experienced was with the sav files for some reason?

Share this post


Link to post
Share on other sites
Just now, Synergy67 said:

Would you still like me to test the de-XML-ed files for you on my Mac? I'm sure they work fine too. I think the problem I experienced was with the sav files for some reason?

The game will read any file that's in your Plugins regardless of extension. If it sees it as a valid format it'll use it. I really suspect that just removing the .sav files is what fixed it. The renaming the "Mac" ones to the original file names was prolly coincidental. At least that's what my programming mind says.

So, we can kill two birds with one stone if you will. Test the no XML ones without the .sav files in there and leave their names as they are. (Be sure to pull out the working .SC4Lot files too.) That'll be useful to know if the lack of the XML hurts the Mac. (I'm guessing no and that'd mean in any others I tweak for Mac peeps I can know it's safe to pull that part out and reduce the file size a wee bit.)

Share this post


Link to post
Share on other sites
3 hours ago, CorinaMarie said:

I really suspect that just removing the .sav files is what fixed it.

I can confirm this testing here on Windows. For both Park-A-Lot and Park Place, the redundant .sav files are bundled with the package. Loading up the game whilst also including the regular .SC4Lot files, I noticed how the correct names and menu descriptions were displayed. However by removing the proper lots and just keeping the .sav files inside and loaded from my Plugins, it then showed up the "Custom Ploppable" text in the menus and likewise when querying them.

Like so:

Custom Ploppable Shmails Parking Menu.png

(I merged 2 images so both appear selected.)

 

@Synergy67

Perhaps there's a difference with the plugin loading order on Mac compared to Windows systems? That may explain if there wasn't an override, since quite conveniently on Windows the .SC4Lot file extension comes alphabetically after .sav (meaning the former will load afterwards with an identical file name).

With both files present, I was able to force the .sav to override by prefixing a "zzz_" at the start.


Comparing them I've found the exemplar properties have a similar structure, though there are a few notable differences. There were no LTEXT files inside which specify a name and description, and also I see how there are other entries missing or altered inside the .sav file including costs and pollution. For the two exemplars (building properties and lot configuration data), the combined difference in the total size is 80 bytes less. While that may sound trivial, it only takes the odd value out of alignment to cause unpredictable results. This leads me to believe it could potentially be a previous version of the file, and therefore the properties are incorrect or incomplete.

So overall, I think it's safe to conclude...

If ever noticing any .sav files in content items, they're likely to mess something up in one or many ways, and as such can be safely removed. *;)

Share this post


Link to post
Share on other sites

I found out that you can drive right through these little garages, out the back side, if there is a road/street right behind it. It effectively operates as one tile of road. No wonder I was getting weird results with it on my route queries. So, for anyone using them, be sure there is no other road as a means out touching it on the other three sides. I also found out that Sims can walk or drive into the back side of a commercial building. Each of these shops is built facing the avenue, but they are driving their cars to work to the back side of the buildings, whether they visually have a parking lot in rear or not.  

Screen shot 2018-07-10 at 12.43.15 PM.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  

Register a New Account

Sign In  

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Thank You for the Continued Support!

Simtropolis relies mainly on member donations to continue operating. Without your support, we just would not be able to be entering our 15th year online!  You've really help make this a great community.

But we still need your support to stay online. If you're able to, please consider a donation to help us stay up and running, so that we can help keep bringing SimCity players together to share our creations.

Make a Donation, Get a Gift!

Expand your city with the best from the Simtropolis Echange.
Make a donation and get one or all three discs today!

stexcollection-header.png

By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

Each donation helps keep Simtropolis online, open and free!

Thank you for reading and enjoy the site!

More About STEX Collections