Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google      Sign In   
  • Create Account
Photo
- - - - -

Failed to create D3D device (portrait mode)

  • Please log in to reply
12 replies to this topic

#1 Moonraker0

Moonraker0
  • LocationFreeland, Michigan, United States
Offline

Posted 14 June 2012 - 09:06 PM

I just bought CXL 2012 on Steam (I had been waiting for another sale), but as I expected, it won't launch (this happened in 2011 as well). I get this error: "Failed to create D3D device: unable to find requested mode (800x600@0)". I have three monitors in portrait mode. I set it to be in landscape mode, and using only one monitor, in the Nvidia control panel. The game then launched successfully. I edited Data\Config\GlobalSettings.cfg to read:


<Application>
<Win32FullScreen>1</Win32FullScreen>
<ScreenWidth>3860</ScreenWidth>
<ScreenHeight>1920</ScreenHeight>
<AssertOnMemoryLeaks>1</AssertOnMemoryLeaks>
</Application>

and it had absolutely no effect on the game. It still gave me that error. Surely the resolution setting isn't hardcoded into the exe! Why is that file even there? I deleted it and the game still launched! I also tried values of 600x800 and 1200x1920 for the resolution. If that's not the config file, then where is it? Isn't there some config file I can edit to change the resolution?

Rhetorical question for the devs: Why is the game attempting to run at 800x600 instead of using my current desktop resolution? Other new games do the latter. If I could get into the game in the first place, I'm sure I could change it to 3860x1920. I tried launching it in landscape mode, but that only lets me choose the landscape mode resolutions in-game, so I can't set it properly for normal operation. I tried choosing windowed mode, but that de-activates as soon as I switch back to portrait mode.

EDIT: I also just looked up another thing that can be done to attempt to fix the problem, which is editing the videomode value in %AppData%\Local\Focus Home Interactive\Cities XL 2012\live\offline\player1.cxl, but I've tried a bunch of values and it didn't work. I mean, I wouldn't expect the standard values to work, but I would expect it to say "Failed to create D3D device: unable to find requested mode (1280x720@60)" instead of 800x600, for example, but it doesn't seem to be affecting the game properly.

Edited by Moonraker0, 14 June 2012 - 09:42 PM.

Check out my SC4 screenshots on Xfire (not-so-current: Trifort region) and Steam or my YouTube channel!

Website of The Monorail Society

hongkongsc4banner.png


#2 scubaaaDam

scubaaaDam
Offline

Posted 16 June 2012 - 07:18 AM

I'm also having this same issue.

I have three portrait monitors with res 3240x1920 and when I start the game I get "Failed to create D3D device: unable to find requested mode (800x600@0)"

I've edited GlobalSettings.cfg but still have the problem. I don't see offline\player1.cxl in my %AppData%\Local\Focus Home Interactive\Cities XL 2012\live\ directory I only have playerprofile and shadercache directories. Maybe that doesn't matter since the OP said it didn't help.

So what to try next?

#3 Verone

Verone
Offline

Posted 16 June 2012 - 10:47 AM

I'm having exactly the same issue as this, and tried editing exactly the same configuration file to no avail.

System spec should be able to handle it fine :

Core i7 980x @ 5.25GHz
Asus ROG Rampage III Extreme Mainboard
24GB Triple Channel Corsair Dominator DDR3
2x Palit 3GB GTX580 (SLI)
3x Dell 2408WFP 24" (Portrait 3600x1920)


Really disappointed tbh, a lot of friends have been talking about how awesome the game is, and I really wanted to play.

Funny enough, if I disable SLI and set my displays up in landscape mode, the game will work fine at 1920x1200@50Hz. I just don't feel like breaking my neck playing it sideways, or re-arranging my desk every time I want to play Dx.

Edit :

I've taken a look at the error log that the game produces on crashing, just a one liner that gives no real help :


[16:36:12] MAINAPPLICATION mgEngineDx.cpp ( 352) Error Failed to create D3D device : Unable to find requested mode (800x600@0)

Edited by Verone, 16 June 2012 - 10:56 AM.


#4 Moonraker0

Moonraker0
  • LocationFreeland, Michigan, United States
Offline

Posted 17 June 2012 - 07:06 PM

Yeah, it's disappointing; I guess they're never going to fix this since they have gone so long without patching it. I would almost be okay with rotating my monitors to play it in landscape mode, but they don't fit on my desk that way. I also tried putting them in landscape orientation with Nvidia Surround disabled, launching the game, then switching back to portrait in the Nvidia control panel with the game running in windowed mode; it doesn't crash, but it does not show the list of portrait mode resolutions in the options after that, still the landscape ones from when it was launched. It seems like, when set to windowed mode, it initializes in fullscreen 800x600 and then switches to the window, or at least tries to. I've just been either playing it on my laptop, or using an HDMI cable to play on the TV nearby, but it's too much of a hassle to disable Surround for this game, since you have to re-configure everything when you turn it back on.
Check out my SC4 screenshots on Xfire (not-so-current: Trifort region) and Steam or my YouTube channel!

Website of The Monorail Society

hongkongsc4banner.png


#5 Moonraker0

Moonraker0
  • LocationFreeland, Michigan, United States
Offline

Posted 19 June 2012 - 03:24 PM

Oh, wow. I actually found a workaround. I honestly never thought I'd see the day...but I've got it all working right now.

The key is for the resolution of 800x600 to be available to the game, as no matter what resolution you set it to, it always starts in 800x600 and then switches to the resolution you set (or so it seems). The workaround I found involves a third-party program called SoftTH (Software TripleHead), which is free. Here are the steps you must take:
  • With Nvidia Surround (or Eyefinity, though I don't use that so I can't confirm if it works) enabled as it normally would be, download SoftTH version 2.08 and extract the archive to the folder in which you installed Cities XL. d3d9.dll should go in the same folder as CitiesXL_2012.exe (if you're using 2012).
  • Download the SoftTH Config Tool (put the .exe wherever you want) and run that.
  • It should show one big display, "Primary Head", with your full screen resolution (all monitors). Change the resolution for "Primary Head" to 800x600 pixels.
  • Click "Save" and save the config.SoftTHConfig file to the Cities XL installation directory (where you put d3d9.dll).
  • Now run the game. It should initialize and start to make its normal sounds/music, but the game won't show up (your desktop is visible). Pres Esc twice, and you should be taken to the main menu.
  • If this has all worked so far, you should be able to go into the options menu and set the resolution of the game to your desired multi-display resolution.
You need to keep SoftTH's d3d9.dll in your game directory, because (as I mentioned earlier) the game initializes at 800x600 every time. It should keep running at your full multi-display resolution after being launched, though. What I noticed is that it never shows the intro videos (just your desktop), so you need to press escape two times to skip them or wait for them to end, then it will show the main menu.

EDIT: Dang, I found out after I posted this that it works fine up through the planet screen, but as soon as the city loads, the video is completely messed up and frozen. I need to experiment more with this.

Edited by Moonraker0, 19 June 2012 - 06:25 PM.

Check out my SC4 screenshots on Xfire (not-so-current: Trifort region) and Steam or my YouTube channel!

Website of The Monorail Society

hongkongsc4banner.png


#6 Bennyboy1988

Bennyboy1988
Offline

Posted 19 June 2012 - 09:43 PM

I had to create an account just to post on this thread; I'm having the same exact issue as you.

Running the game with nvidia surround in portrait mode; followed everything as you say but when I load the game up the screen is black, press esc twice and nothing happens.

I guess it doesn't matter since you can't get games to load anyways; but I wish you the best of luck, I'm seriously not going to rotate my monitors just to play this game.

#7 Moonraker0

Moonraker0
  • LocationFreeland, Michigan, United States
Offline

Posted 20 June 2012 - 07:37 AM

Well, I've pretty much figured out that the problem is that SoftTH expects the game to be running at the resolution it adds (800x600). I can't think of any way around that; old versions of SoftTH allow adding multiple new resolutions, but they have to be configured differently and I think it would mess something up with Nvidia Surround that way. I've posted on the Nvidia forums asking if there's any way to add 800x600 with the Nvidia drivers in portrait mode; it would be a lot simpler to be able to do that instead. Hopefully that gets a helpful reply, because I don't know of any other way around this.

I think the issue with the cities also has something to do with the textures, as the messed up graphics (weird multicolored lines everywhere in all directions) only happens with texture detail on high, and setting it to low just makes it freeze at a full loading bar without doing that. The SoftTH log says "WARNING: emulating managed cube texture with D3DUSAGE_DYNAMIC", but I don't know exactly what that means.
Check out my SC4 screenshots on Xfire (not-so-current: Trifort region) and Steam or my YouTube channel!

Website of The Monorail Society

hongkongsc4banner.png


#8 scubaaaDam

scubaaaDam
Offline

Posted 24 June 2012 - 12:30 PM

When I finally heard back from Focus Home Support they said this was a bug they have no plans to fix. Now I'm trying to get my money back.

#9 B.80486

B.80486
Offline

Posted 17 October 2012 - 12:41 AM

Same thing hear, I'm a little pissed that they don't plan to fix it.
I found out that if you play it in a window you can start the game with the screen in landscape, minimize the game and rotate to portrait. It seams the starting screan needs to run at 800x600 but the rest of the game is fine with anythiong else (just testing it now).

#10 Cyviji

Cyviji
Offline

Posted 26 February 2013 - 05:24 PM

Hey, just wanted to say the SoftTH fix by Moonraker0 actually works on my Radeon 7970 running 3 screens in portrait mode.

I just have to run the game in window mode. Everything else works quite good.

It starts 800x600 and can be dragged on the windowborder to almost fullscreen.



#11 Moonraker0

Moonraker0
  • LocationFreeland, Michigan, United States
Offline

Posted 26 February 2013 - 07:43 PM

It's good to hear that my attempted fix actually amounted to something. :) Thanks for letting us know that it worked, and hopefully it works for other Radeon users, too.


Check out my SC4 screenshots on Xfire (not-so-current: Trifort region) and Steam or my YouTube channel!

Website of The Monorail Society

hongkongsc4banner.png


#12 Mize

Mize
  • Member
  • Freshman

  • 2 posts
  • MizeB3D
Offline

Posted 22 March 2013 - 08:16 AM

Regarding multi-monitor, portrait mode seems hopeless until we find a way to create a custom resolution of 800x600 and this feature is disabled for portrait on nvidia drivers for now.

 

BUT I can run in 3x1920x1200 in landscape mode just fine because the 800x600 mode exists in landscape surround. I don't want to have to rearrange my monitors each time I play, but I can spend some time in this configuration for a while  :)



#13 Beradon

Beradon
  • Beradon
Offline

Posted 11 October 2013 - 09:42 AM

I made an account just to post this.

 

So I know this topic is old, but I wanted to post a fix here for those of you still having trouble and not wanting to install a third party application.  I am posting now because of CitiesXL being available as part of the Humble Bundle so I imagine more people will be playing it.

 

I am running 3 displayes in Portrait NVSurround.  What I figured out from this thread and others is that the key is really that the 800x600 resolution be available.  So what I did is this:

 

I went to the NVIDIA Control Panel to add a custom resolution.  What I found when I got there is that since I am running in NVSurround, the custom resolution button did not let me add anything.  So I temporarily disabled NVSurround, went back in, added the custom resolution of 800x600, then re-enabled my NVSurround.

 

Now I can start this game without any trouble.

 

I imagine this fix will work for ATI / AMD cards with Eyefinity as well.  Just be sure in some way to add the custom resolution of 800x600 and all will be good.

 

EDIT:

 

After switching back to portrait surround I no longer actually SEE the custom resolution that I added, but apparently that doesnt matter because CitiesXL still works.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users