Jump to content

Photo

How to configure SC4 to work with your new hardware

  • Please log in to reply
133 replies to this topic

#1 Mysteryous

Mysteryous

Posted 08 November 2009 - 06:16 PM

By now many of you have brand new computers and are wondering why SC4 won't run worth a hoot on it.  That reason is due to the limitations imposed by the current graphics hardware during the time of the games inception.  This means the graphics rules for the game are fairly static to say the least and won't play nice with mismatched pieces per say.  The good thing is that we can change that to fit our mismatched pieces.  Here's how I was able to work it.

For the sake of consistancy (you may skip if you already did these steps):
First install the game.  (oh well thanks captian obvious..)  Be quiet, were not done here.
Second step is to run the latest update.  (why are you doing this?)  I said be quiet.
Third step is to follow JoeST's instructions on customizing your gameplay experience (you may have to login).

4.)  Now the fun part.  If you are still running Windows XP, then you may skip this.  If you are running Windows Vista or 7, then follow this step please.  Go to your games directory (eg. C:\Program Files\Maxis\Sim City 4 (deluxe)\   you get the idea)  Copy "Graphics Rules.sgr" and "Video Cards.sgr" (without quotes) to your desktop (or an easily accessible directory in which you have full read/write permission)  A pretty picture is provided below.



5.)  Right click anywhere on your desktop and select properties (XP) or Change Resolution (Vista or 7).  Under the screen resolution tab, select advanced.  You will then be met with your adapter information.  Take careful note of that.  Two pretty pictures are provided.  The first one is largely irrelevant except to those who know how to get there.  You may ignore it.




6.)  Once you have done that, open up Graphics Rules.sgr (with notepad) and drill down until you find this:
      partialRule "Fast card" -any
         # We run well on these cards, so up the defaults.
         stringMatch cardIdentity "NVidia*Geforce*"
         stringMatch cardIdentity "NVidia*Quadro*"
         stringMatch cardIdentity "ATI*9700*"
         stringMatch cardIdentity "ATI*8500*"
         stringMatch cardIdentity "Matrox*Parhelia*"
Include your graphics cards string to it so It will look something like this:
      partialRule "Fast card" -any
         # We run well on these cards, so up the defaults.
         stringMatch cardIdentity "NVidia*Geforce*"
         stringMatch cardIdentity "NVidia*Quadro*"
         stringMatch cardIdentity "ATI*9700*"
         stringMatch cardIdentity "ATI*8500*"
         stringMatch cardIdentity "ATI*HD 4800 Series*"
         stringMatch cardIdentity "Matrox*Parhelia*"
(different video cards mean different strings, so take this with a grain of salt)  Now save and exit.

7.)  Now that you have done all that, open up your Video Cards.sgr (with notepad or whatever).  You will be met with a long list of video cards.
Most usually you will be looking for either "vendor "ATI" 0x1002" or "vendor "NVidia" 0x10b4 0x12d2 0x10de"  (without the outermost quotes).  Other brands are in there too.
In the appropriate list add your video card.  Example is as follows:
   card 0x4E69 "Radeon 9800"
   card 0x4148 "Radeon 9800"
   card 0x4168 "Radeon 9800"
   card 0x9442 "Radeon HD 4800 Series"
   card 0x5041 "Rage 128 Pro"
   card 0x5042 "Rage 128 Pro"
   card 0x5043 "Rage 128 Pro"
Now save and exit.

8.)  For vista/7 users, you must navigate back to your game directory and move the edited files there, replacing the unedited ones.  Yes you want to continue when your computer asks you if you want to continue.

That's it your done.  Enjoy playing Sim City 4.  It should run very much faster now.  Many make these modifications without ever editing the Video cards.sgr file, and that works too; but with an unmatched string, the game could potentially become unstable and be prone to crashes a lot more often than not.  A performance deficit has also been observed.



#2 kiros

kiros

Posted 11 November 2009 - 03:28 PM

o man thanks for posting this since i upgrade to win7 i been having issues running fine my sc4 i hope this can solve my issues i have tried before the resolutions and multicore affinity to try help the slow down with out any success im heading for this and im pretty sure this can solve my problems running my sc4 like its mean to be

i just have 1 question in that post you use as a example a ati videocard and i have a nvida to be exact a nvidia geforce gtx 260 and i cant find the the string of that because i cant
see it in my properties windows i have looked in some other places but with out success and like you say im may quote you here
but with an unmatched string, the game could potentially become unstable and be prone to crashes a lot more often than not.
i dont want to ruin my game... im asking if any one can lead me a clue where i can find my correct string for my video card?
as a example this are my 2 pictures reflecting what they show and is not like this 2 pictures above
http://img694.images...8/capture1l.jpg
http://img697.images...6/capture2e.jpg


thanks in advace if any one can help me and also thank you @Mysteryous for posting this it bring more life for my beloved sc4



update

i just do the first , the adding to the list of "Graphics Rules.sgr" my videocard like this without any better performance
noticed
, my only main problem is.. went i run the game under Hardware Mode and i move the screen to any side
its like it jump frames a lot like if my videocard wasn't able to handle the gfx and slow down.. just that all other gfx
are fine and i make this clear i test this under a SC4 DX with NO MODS in it.. and if i change the Render method to
Software well the problem disappear bit then the graphics don't look to well.

btw excuse my English im not a natural English typer but i try my best =\

      partialRule "Fast card" -any
         # We run well on these cards, so up the defaults.
         stringMatch cardIdentity "NVidia*Geforce*"
         stringMatch cardIdentity "NVidia*Quadro*"
         stringMatch cardIdentity "ATI*9700*"
         stringMatch cardIdentity "ATI*8500*"
         stringMatch cardIdentity "NVidia*Geforce GTX 260*"
     stringMatch cardIdentity "Matrox*Parhelia*"


#3 Legosim

Legosim

Posted 11 November 2009 - 05:24 PM

Thanks im going to save this untill i have enough money for a windows 7 pc

#4 Mysteryous

Mysteryous

Posted 12 November 2009 - 06:48 AM

to kiros:

I have noticed a performance difference when doing large scale things (ie bulldozing a whole section of your map); with the string modification things seem to go a little bit smoother, not necessarily faster. As for your video card string, that is quite peculiar. It should generate a HEX string alongside your graphics card string. In your video card properties window, click the Properties button. Then in the properties window, select the "Details" tab (without quotes). There should be a pull-down menu with a befuddling list of selections. Towards the bottom, there should be an option called "Matching device id". The information there should be what your looking for.

My id was pci\ven_1002&dev_9442. Yours should say something similar. The pci\ven_???? describes your vendor. For general purposes, match that with the vendor "nVidia/ati/intel/other" 0x???? and then use that list. The &dev_???? should give you the appropriate string that you insert into the list you matched the vendor to in the first place. Just remember to put 0x before it.

#5 Zentu

Zentu

Posted 14 April 2010 - 06:17 AM

I'm sorry to say this, but this really didn't work out for me. My Rush Hour still has the slowest performance I've ever seen in all the computers I've had for a few years. I'm running Vista 32x and have a nVidia GeForce 9600M GT on a Toshiba Qosmio laptop. This awful performance really frustrates me. What do you want a new computer for if you can't play your favorite game on it?

#6 Crom

Crom
  • Member
  • Freshman

  • 5 posts
  • Crom84

Posted 12 March 2013 - 10:26 PM

Hey.

I know it's an old thread, but I just started playing SC4 again, but all the lag and bad performance was really pissing me off so I spent a couple of hours on google and to my great joy I found this thread.

This absolutely worked for me.

 

I have a pretty decent rig with a GeForce GTX 580, i7 quad core CPU, 6 GB RAM and running Windows 7 but the game was still really sluggish and laggy, even with cities that has a relatively small population, but after following these steps the game runs like I have always wished it did!

 

It feels like a completely new game now that the framerate doesn't drop whenever I move the camera or zoom in/out and the loadtimes are almost non-existing.

It's strange and I'm sorry that this fix didn't work for Zentu but it really did the trick for me so try it out.

 

 

I just added the lines:


stringMatch cardIdentity "GeForce*GTX*580*"

 

To the "Graphics Rules.sgr" file and:

 

card 0x1080 "GeForce GTX 580"

 

To the "Video Cards.sgr" file and BOOM... the game now runs like a dream.

 

 

AND I would never have found the HEX string without Mysteryous's second post, so thanks Mysteryous! You made my day!   :thumb:

 

Edit: This thread sould be stikied imo.!



#7 SuperDeluge

SuperDeluge

Posted 13 March 2013 - 08:46 PM

I wanted to try this but it says the file is read only and won't allow me to save any changes.

 

 

Figured out a way to save the changes.  Thanks, used Crom's lines, hope to see a difference.



#8 Crom

Crom
  • Member
  • Freshman

  • 5 posts
  • Crom84

Posted 14 March 2013 - 06:33 AM

Thanks, used Crom's lines, hope to see a difference.

 

 I don't think that will work unless you have the exact same graphics card because you need the right HEX string for your particular card.



#9 SuperDeluge

SuperDeluge

Posted 14 March 2013 - 05:06 PM

Thanks Crom.  I have the NVIDIA GeForce GTX 580 card.  I think it would have the same string as what you posted.  Don't have much of a city built yet and am having trouble using all of my 24" moniter, but so far graphics are looking great.  Hope the game runs smooth.



#10 Crom

Crom
  • Member
  • Freshman

  • 5 posts
  • Crom84

Posted 14 March 2013 - 06:00 PM

Cool :)

 

The first time I tried this fix I loaded a huge city with the original files at first to get an idea of how laggy and slow it was (with every zoom in/out it had to do that spiral loading of everything for about 5 or 6 seconds and moving the camera was choppy and if I moved it too fast it would become a slideshow), then I quit the game, copied over the tweaked files, launched the game and loaded the same huge city and instantly noticed that the camera ran completely smooth and the spiral loading only took 1-2 seconds depending on the zoom level. SC4 just became my favorite game again.

I can't recommend this tweak/fix enough :]



#11 A Nonny Moose

A Nonny Moose
  • You've got to be kidding!
  • LocationHensall, Ontario, Canada
Awards
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†

Posted 14 March 2013 - 07:59 PM

Thanks Crom.  I have the NVIDIA GeForce GTX 580 card.  I think it would have the same string as what you posted.  Don't have much of a city built yet and am having trouble using all of my 24" moniter, but so far graphics are looking great.  Hope the game runs smooth.

If your monitor is anything like mine (1920 x 1080) you need to set the resolution in the command line that starts the program.  Here is my command line (target).  I am on Linux, so the forward slashes (/) have to be backslashes (\) for windows.

 

"C:/Program Files/Maxis/SimCity 4 Deluxe/Apps/SimCity 4.exe"  -intro:off -CustomResolution:enabled -r1920x1080x32 -d:directx  -f -CPUcount:1

 

Note that this is all on one line and there is a single space before each option that begins with a hyphen (-).


 

 

Beware: Emancipated user.  No Windoze for me.
The teacher opens the door but the student must enter himself. - Ancient Chinese Saying
Music expresses that which cannot be put into words and that which cannot remain silent. -- Victor Hugo
I haven't lost my mind -- it's backed up on tape somewhere.
JohnNewSig.gif
"We have met the enemy, and he is us" - Walt Kelly

Come join us at the Moose Factory


#12 SuperDeluge

SuperDeluge

Posted 15 March 2013 - 07:15 PM

Thanks A Nonny Moose, I didn't have the -d:directx in the command line.  I added that to the command line and the picture seems sharper.  I have a 1920x1200 monitor, but was trying different resolutions to get rid of the blue stripe at the bottom of cities in region view.  The only one that seems to get rid of it for me is 1280x1024, but I think I'll use 1920 and live with the stripe.

 

I would like to show my appreciation for the help I have recieved by sending a donation to Simtropolis.  When my last PC died and I got Windows 7 64 bit I thought that was it for me and Sim City 4.  I got the new Sim City and it really doesn't work for me, but I did get a strong urge to play Sim City again.  I found some of the threads in here and am now running Sim City 4 again.   I am really thankful that 9 years later this site is still here and people on the forums are still helping others out.   Thanks again....off to figure out which patches.....

 

Just sent a donation via pay pal, but the reciept that showed up in my e-mail didn't say I donated to Simtropolis, but that I made a payment to a person.  There was no place to decline a CD, etc.



#13 jinxed1git

jinxed1git
  • LocationThe Southern-most part of Africa

Posted 16 March 2013 - 04:53 AM

I literally JUST registered to thank Mysteryous for both those posts!! 

 

1. I was annoyed because a game that was made back in '03 was lagging like crazy on my dual 660Ti's and i7. 

2. Was even more annoyed because every other forum out there are filled with a bunch of n00bs.

3. Was then EXTREMELY annoyed when my adapter string (0x????) didn't show up next to my card name. 

4. Scrolled down, Mysteryous saved the day twice in one post, and now SC4 is happily being raped my high-end system. Lol.

 

Thank you SOOOO very much! I highly suggest you bump this post or add it to the top of the forum's list or SOMETHING. It's literally the only post anyone with a new system will need.

 

:thumb: +10 simoleons for you!



#14 jinxed1git

jinxed1git
  • LocationThe Southern-most part of Africa

Posted 16 March 2013 - 06:41 AM

Me again. So now I've convinced my friend that SC4 is a cool game. He wants to play. We configure everything like I did.....and nothing.

 

Help? Lol.  :lost:

 

He has an NVidia 9600 GT

 

This is what we added....

 

 

   card 0x0102 "GeForce 256 Ultra"
   card 0x0103 "GeForce 256 Quadro"
   card 0x0622 "GeForce 9600 GT"
   card 0x0110 "GeForce2 MX"
   card 0x0111 "GeForce2 MX DDR"
   card 0x0112 "GeForce2 Go"
 
AND
 
partialRule "Fast card" -any
         # We run well on these cards, so up the defaults.
         stringMatch cardIdentity "NVidia*Geforce*"
         stringMatch cardIdentity "NVidia*Geforce 9600 GT*"
         stringMatch cardIdentity "NVidia*Quadro*"
         stringMatch cardIdentity "ATI*9700*"
         stringMatch cardIdentity "ATI*8500*"
         stringMatch cardIdentity "Matrox*Parhelia*"
 
Game still lags like a beast when scrolling and zooming in...
 
Yes, we've tried with the asterixes (*) in between the words, that didn't work either.
It's really weird because it worked fine with mine.
 
Any and all suggestions would be greatly appreciated  :ohyes:


#15 A Nonny Moose

A Nonny Moose
  • You've got to be kidding!
  • LocationHensall, Ontario, Canada
Awards
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†

Posted 16 March 2013 - 09:08 AM

Are you sure that you have the right hexadecimal code for that card?  See if you can check it with your cold boot set up screen.  Failing that, try System Information (program).


 

 

Beware: Emancipated user.  No Windoze for me.
The teacher opens the door but the student must enter himself. - Ancient Chinese Saying
Music expresses that which cannot be put into words and that which cannot remain silent. -- Victor Hugo
I haven't lost my mind -- it's backed up on tape somewhere.
JohnNewSig.gif
"We have met the enemy, and he is us" - Walt Kelly

Come join us at the Moose Factory


#16 jinxed1git

jinxed1git
  • LocationThe Southern-most part of Africa

Posted 16 March 2013 - 05:16 PM

Are you sure that you have the right hexadecimal code for that card?  See if you can check it with your cold boot set up screen.  Failing that, try System Information (program).

 

System Information doesn't list the hex code. The card's details tab lists this under matching card id:

 

 

pci\ven_10de&dev_0622
 

That hex code comes up a lot, in all the right places too. So I'm assuming that's right. Really stumped.  :lost:

 

Sorry for the late reply, been lanning all night. Lol. He's been able to play for about 5 mins then rage quits. I don't blame him haha



#17 docj101

docj101
  • LocationPennsylvania, USA

Posted 17 March 2013 - 09:49 AM

Me again. So now I've convinced my friend that SC4 is a cool game. He wants to play. We configure everything like I did.....and nothing.

 

Help? Lol.  :lost:

 

He has an NVidia 9600 GT

 

This is what we added....

 

 

   card 0x0102 "GeForce 256 Ultra"
   card 0x0103 "GeForce 256 Quadro"
   card 0x0622 "GeForce 9600 GT"
   card 0x0110 "GeForce2 MX"
   card 0x0111 "GeForce2 MX DDR"
   card 0x0112 "GeForce2 Go"
 
AND
 
partialRule "Fast card" -any
         # We run well on these cards, so up the defaults.
         stringMatch cardIdentity "NVidia*Geforce*"
         stringMatch cardIdentity "NVidia*Geforce 9600 GT*"
         stringMatch cardIdentity "NVidia*Quadro*"
         stringMatch cardIdentity "ATI*9700*"
         stringMatch cardIdentity "ATI*8500*"
         stringMatch cardIdentity "Matrox*Parhelia*"
 
Game still lags like a beast when scrolling and zooming in...
 
Yes, we've tried with the asterixes (*) in between the words, that didn't work either.
It's really weird because it worked fine with mine.
 
Any and all suggestions would be greatly appreciated  :ohyes:

Use this line and see is if works:  stringMatch cardIdentity "GeForce*9600*GT*".  Get rid of that NVidia in the line, add the new line to the bottom of the list.  Take note of GeForce spelling too, cap G and F, might not make a difference but that's exactly how my PC reports it on my PC, GeForce.


banner01_zps7ed66520.jpg banner02_zpse768e3ed.jpg

CLICK THE BANNERS FOR LINKS

 


#18 Aidenn

Aidenn
  • DrAiddenwitz

Posted 17 March 2013 - 10:36 AM

Hi guys!

I'm having the same problem as jinxed1git. I have a 2500k, 8GB RAM, W7 x64 and a GTX 570 (Gainward Phantom), everything up to date.

System Information says that my device ID is 1081 (vendor ID is 10de, like it should be), so I wrote in Video Cards.sgr in the NVidia section at the end:

   card 0x1081 "GeForce GTX 570"

The string is the same one that appears in the adapter string.

in Graphics Rules.sgr I wrote every possible combination (I tried all at once and one at a time as well) in the 'partialRule "Fast card" -any' part:

         stringMatch cardIdentity "GeForce*GTX*570*"
         stringMatch cardIdentity "GeForce GTX 570*"
         stringMatch cardIdentity "NVidia*GeForce*GTX*570*"
         stringMatch cardIdentity "NVidia*GeForce GTX 570*"

Nothing works and the game is still choppy as ever. I tried it with and without XP compatibility and with and without the following command line:

-CPUCount:1 -Intro:off -d:DirectX -w -CustomResolution:enabled -r1600x900x32 -CPUPriority:high -ExceptionHandling:off
 

I tried 0x1086 too (it's the ID from another type of GTX 570 from some manufacturers, mine is 1081 but I wanted to be sure).

 

I even deleted the whole NVidia section from VC and put in something completely else to make sure nothing is overwriting the string and tested it with various variations in GR:

vendor "ALLURBASE" 0x10de
   card 0x1081 "RBELONGTOUS"
end

Still no cigar though and I don't know whether it cross checks with the adapter name in the system as well.

 

Hell, even if I put a "*" in GR (which should tell the game to use that damn fast mode no matter what GPU it is) it still doesn't work.

Any ideas?

 

--edit--

 

http://community.sim...ware-rendering/ <- I tried this thing and it works! Better than software mode I might add. It's still a little jerky here and there, but it's nothing compared to how it was before. I'd like full 60 fps, but I guess I can't have everything.



#19 jinxed1git

jinxed1git
  • LocationThe Southern-most part of Africa

Posted 17 March 2013 - 01:51 PM

Use this line and see is if works:  stringMatch cardIdentity "GeForce*9600*GT*".  Get rid of that NVidia in the line, add the new line to the bottom of the list.  Take note of GeForce spelling too, cap G and F, might not make a difference but that's exactly how my PC reports it on my PC, GeForce.

 

This didn't work either, unfortunately. Somehow I doubt we're gonna fix this one lol. No worries though, I'm happy that it's running smoothly on my PC lol. 

Clearly it doesn't work for everyone.

 

 

 

Hi guys!

I'm having the same problem as jinxed1git. I have a 2500k, 8GB RAM, W7 x64 and a GTX 570 (Gainward Phantom), everything up to date.

System Information says that my device ID is 1081 (vendor ID is 10de, like it should be), so I wrote in Video Cards.sgr in the NVidia section at the end:

   card 0x1081 "GeForce GTX 570"

The string is the same one that appears in the adapter string.

in Graphics Rules.sgr I wrote every possible combination (I tried all at once and one at a time as well) in the 'partialRule "Fast card" -any' part:

         stringMatch cardIdentity "GeForce*GTX*570*"
         stringMatch cardIdentity "GeForce GTX 570*"
         stringMatch cardIdentity "NVidia*GeForce*GTX*570*"
         stringMatch cardIdentity "NVidia*GeForce GTX 570*"

Nothing works and the game is still choppy as ever. I tried it with and without XP compatibility and with and without the following command line:

-CPUCount:1 -Intro:off -d:DirectX -w -CustomResolution:enabled -r1600x900x32 -CPUPriority:high -ExceptionHandling:off
 

I tried 0x1086 too (it's the ID from another type of GTX 570 from some manufacturers, mine is 1081 but I wanted to be sure).

 

I even deleted the whole NVidia section from VC and put in something completely else to make sure nothing is overwriting the string and tested it with various variations in GR:

vendor "ALLURBASE" 0x10de
   card 0x1081 "RBELONGTOUS"
end

Still no cigar though and I don't know whether it cross checks with the adapter name in the system as well.

 

Hell, even if I put a "*" in GR (which should tell the game to use that damn fast mode no matter what GPU it is) it still doesn't work.

Any ideas?

 

--edit--

 

http://community.sim...ware-rendering/ <- I tried this thing and it works! Better than software mode I might add. It's still a little jerky here and there, but it's nothing compared to how it was before. I'd like full 60 fps, but I guess I can't have everything.

 

The fix @ that link works, but not as well as this one. Again, some things work for some people and not for others lol.

 

 

 

~-~-~-~-~-~-~-~EDIT~-~-~-~-~-~-~

 

Use BOTH the fixes listed for gameplay that's smooth as a baby's bottom! Lol no jokes. The game literally runs at a constant 60fps (tested on a city with 2.5Mil population)



#20 A Nonny Moose

A Nonny Moose
  • You've got to be kidding!
  • LocationHensall, Ontario, Canada
Awards
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†

Posted 17 March 2013 - 03:06 PM

Fooling with the .sgr files is all very well, but also remember to set all your GPU controls for the game.  Set them to 'program selected' or words to that effect.

 

Failing that, rename the *.sgr file to *.sgrold and see how the game goes without it.


 

 

Beware: Emancipated user.  No Windoze for me.
The teacher opens the door but the student must enter himself. - Ancient Chinese Saying
Music expresses that which cannot be put into words and that which cannot remain silent. -- Victor Hugo
I haven't lost my mind -- it's backed up on tape somewhere.
JohnNewSig.gif
"We have met the enemy, and he is us" - Walt Kelly

Come join us at the Moose Factory


#21 Aidenn

Aidenn
  • DrAiddenwitz

Posted 17 March 2013 - 08:36 PM

@jinxed1git, what are your final entries in the files? I didn't remove mine (which I believe to be the most likely to work), so my findings above actually count as having "both fixes on" and this gives 100-300 fps, but falls to 25-60 when scrolling depending on zoom level and how big the city is. Still, even 25 fps is infinitely better than 1-3 fps I was experiencing before.

 

I removed the video card lines, but it didn't change anything (the other fix is the one which gives me better performance), so I think the game just ignores them.

 

@A Noony Moose, I always had them set to "Application-controlled" (each one that allows it). I only just now tried to change power management from adaptive to maximum performance because some old games have a problem with "jump starting" the newer video cards. It didn't do jack though and the GPU usage was still in the 15-30% area. Except when I park the camera in a place where there's nothing, then it goes to 80% when fps skyrocket to 800-1000+, but I guess it's normal with unlimited frames. ;)

 

I also tried removing the .sgr files from the directory completely, but it works like it worked before, leading me to believe that the last-used .sgrs are being stored by the game somehow and removing them won't help to diagnose anything.

 

-- edit --

 

Hmm... now I'm stumped. I downloaded a really big city (about 1M+, previously I was checking on the big tutorial one which has a lot less density) and the behaviour is really weird.

First, I tried "usevertexbuffers true". With files in the directory, I get 1-3 fps when scrolling that city (as expected), without the files I get 20-30 fps in the same spot and, finally, with files in the directory and "usevertexbuffers false" I get... 10 fps.

 

I guess I couldn't see it in smaller cities, but the "usevertexbuffering" command isn't that powerful when dealing with 1M+ cities. Also, I believe the reason the game works better without the files is due to lower quality, the GR file has some rules that increase various detail options indepedently from low/medium/high setting of the game and thus the game without the file (even if you set everything on high) has less details present than with the file.

 

-- another edit --

 

If it changes the details, I can't see it and, if it actually changes anything, it has to have something to do only with the amount of sims and automata. I compared the game with and without the files extensively and couldn't find any differences in building density, textures and shadows. Sims and automata can't be easily compared because of their random nature (but they're present in both "modes").

 

Thus, I get the best performance (but still not good enough) after removing the files completely, which is kind of weird. Any more ideas?



#22 jinxed1git

jinxed1git
  • LocationThe Southern-most part of Africa

Posted 18 March 2013 - 09:25 AM

Honestly I've given up on trying to fix Maxis's bad programming.

 

My city (on a 256x256 map) reached just over 4Mil today and the game is still running at 60fps (something to do with my monitor or some crap, whatevz). However when I scroll through densely populated areas, frame rate goes waaaaaaaaay down.

 

Found that the best fix, when running on either software or hardware rendering, is to set the number of vehicles in the options menu to "low". This speeds up the game drastically for me. yes, I know, it ruins the gameplay slightly but if you want smooth scrolling, use that. 

 

Simple yet effective.



#23 Aidenn

Aidenn
  • DrAiddenwitz

Posted 19 March 2013 - 02:42 AM

Yeah, I just want to play. I'm just wondering, why does the game run better without the files and am I missing anything when I get rid of them?



#24 General Lee

General Lee
  • LocationThe Fozen Tundra known as Wisconsin

Posted 19 March 2013 - 11:27 AM

Honestly I've given up on trying to fix Maxis's bad programming.

 

My city (on a 256x256 map) reached just over 4Mil today and the game is still running at 60fps (something to do with my monitor or some crap, whatevz). However when I scroll through densely populated areas, frame rate goes waaaaaaaaay down.

 

Found that the best fix, when running on either software or hardware rendering, is to set the number of vehicles in the options menu to "low". This speeds up the game drastically for me. yes, I know, it ruins the gameplay slightly but if you want smooth scrolling, use that. 

 

Simple yet effective.

I think I know what the problem is. Let me ask you a few questions:

 

1. Is your friends computer a laptop?

2. Does it have an Intel card?

 

If you answered yes, to any of these questions, then this will never work. You see, on a laptop, it has two display cards. An Intel one that doesn't do much, but doesn't use a lot of power, and an NVidia one that does a lot but uses a lot of power. With NVidia's Optimus technology, whenever you are gaming, it will automatically switch over to the NVidia card. And whenever you are not gaming, it will switch over to the Intel card. As with the case of SimCity 4, it will detect the Intel card every time, and will NEVER use the NVidia card. There's no way to force this, and there's no way you can disable the Intel card.

 

The only way to fix this is impossible for you and me, and that would be to unplug the video cable from the motherboard, and plug it into the NVidia card itself. And (the worst part) this can't even be done on some laptop NVidia card models. So even then, it's a hit or miss.

 

Moral of the story, laptop computers are not all they are cracked up to be. Advice to anyone buying a computer, go with the desktop every time. I went with a laptop, and I wish I could rewind time and go with a desktop every day of owning this stupid laptop, utilizing this stupid Optimus technology. 


Edited by CaptCity, 20 March 2013 - 01:41 AM.
Language... See the rules.


#25 dogma555

dogma555
  • Location: ¬† ¬†NYC

Posted 19 March 2013 - 01:06 PM

This is all so frustrating to learn that if I upgrade my rig, SC4 and a slew of classic games probably either won't work correctly, or won't work at all.

 

I may just have to have a seperate setup just for legacy support.. older processor, older video card and drivers, and good ol' win xp 32 bit..


SC 4 + CS 1.6 = :]

#26 Aidenn

Aidenn
  • DrAiddenwitz

Posted 19 March 2013 - 01:56 PM

I think I know what the problem is. Let me ask you a few questions:
 

1. Is your friends computer a laptop?

2. Does it have an Intel card?

 

He has a 9600 GT with a device id of a standard 9600 GT, not a 9600M GT, so it's pretty safe to deduce that his friend does not have a laptop.

 

And neither do I for that matter.



#27 General Lee

General Lee
  • LocationThe Fozen Tundra known as Wisconsin

Posted 19 March 2013 - 07:54 PM

I think I know what the problem is. Let me ask you a few questions:
 

1. Is your friends computer a laptop?

2. Does it have an Intel card?

 

He has a 9600 GT with a device id of a standard 9600 GT, not a 9600M GT, so it's pretty safe to deduce that his friend does not have a laptop.

 

And neither do I for that matter.

I read your post. I will do some more research on this, and get back to you. Hang tight. :lost: 

 

GOT IT! WOOOO! I'm happy now.

 

All right. Let me show you two pictures. One without the files, and one with the files.

 

 

 

2agks52.pngThis is a picture of the game WITHOUT the files. Notice that the textures are of lower quality, and especially note the shadows. They look terrible.

 

 

 

 

34t67og.pngThis time I DID use the files. Now, notice the higher quality textures. And especially notice the shadows. Even the street lights show shadows.

 

So to answer you question, is there a difference between not using the Graphics Rules and using the Graphics Rules? HUGE YES! The quality of the game drops significantly.

 

That explains why the game "seemed" to run better without the files, because the graphics weren't rendering to their full potential. WITH the files AND the modifications, the game should run more smoothly.

 

But alas, I bought a laptop. I can't run this game at it's full potential (as you can see by the FPS in the screenshots). :( 



#28 A Nonny Moose

A Nonny Moose
  • You've got to be kidding!
  • LocationHensall, Ontario, Canada
Awards
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†
 ¬†

Posted 19 March 2013 - 08:32 PM

This is all so frustrating to learn that if I upgrade my rig, SC4 and a slew of classic games probably either won't work correctly, or won't work at all.

 

I may just have to have a seperate setup just for legacy support.. older processor, older video card and drivers, and good ol' win xp 32 bit..

Many users run the game successfully on the most recent hardware/software. 

 

There is no reason to source a separate game machine unless you have run into problems you can't solve by reading the posts in this forum.  In that case, start a new thread giving the details of your machine, your game version number, and if possible a screen shot of what your having trouble with.  If the game crashes, open the last .txt file in your exception reports using notepad and post the first 20 lines of the dump.

 

The trick is, instead of worrying about some possible problems, ask your machine.  It will tell you if you can run or not.  A lot of people don't bother with editing the *.sgr files, including me.  This gets pretty arcane and you have to be good at scripting to get it right.


 

 

Beware: Emancipated user.  No Windoze for me.
The teacher opens the door but the student must enter himself. - Ancient Chinese Saying
Music expresses that which cannot be put into words and that which cannot remain silent. -- Victor Hugo
I haven't lost my mind -- it's backed up on tape somewhere.
JohnNewSig.gif
"We have met the enemy, and he is us" - Walt Kelly

Come join us at the Moose Factory


#29 General Lee

General Lee
  • LocationThe Fozen Tundra known as Wisconsin

Posted 19 March 2013 - 09:13 PM

This is all so frustrating to learn that if I upgrade my rig, SC4 and a slew of classic games probably either won't work correctly, or won't work at all.

 

I may just have to have a seperate setup just for legacy support.. older processor, older video card and drivers, and good ol' win xp 32 bit..

Many users run the game successfully on the most recent hardware/software. 

 

There is no reason to source a separate game machine unless you have run into problems you can't solve by reading the posts in this forum.  In that case, start a new thread giving the details of your machine, your game version number, and if possible a screen shot of what your having trouble with.  If the game crashes, open the last .txt file in your exception reports using notepad and post the first 20 lines of the dump.

 

The trick is, instead of worrying about some possible problems, ask your machine.  It will tell you if you can run or not.  A lot of people don't bother with editing the *.sgr files, including me.  This gets pretty arcane and you have to be good at scripting to get it right.

What about us Laptop users? We have the forced dual integrated graphics cards. SimCity 4 only detects the Intel card. There is no way to force it otherwise. I'd have to disassemble the laptop, and try to plug the video cable into the NVidia card itself (which I'm not going to do). So yes, there may be a need to have a separate game machine, depending on whether or not a person made the mistake of purchasing a gaming laptop (and I regret it every day).



#30 Aidenn

Aidenn
  • DrAiddenwitz

Posted 20 March 2013 - 01:33 AM

@General Lee, thanks! Now I feel stupid, because I made screenshots with and without the files in the same place and alt-tabbing between them showed no difference except for pedestrians and cars being in different places. The shadows were a bit different, but they were still there (because I took a shot of skyscrapers during dawn, and these still drop shadows without the files) and I thought that they looked different because of the difference in in-game time and the shadows have simply moved. That would be weird, because as it turns out, the shadows don't move at all in this game. :D

 

Ok, enough shame, the riddle was solved. Now... why, for example, Crom's rig, which is a bit better than mine, but uses the same generation NVidia card (580 GTX vs my 570 GTX), can take advantage of this configuration fix and I can't? I'd be happy to provide dumps and any information someone more able might need to solve this. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users