Jump to content

Aidenn

Member
  • Content Count

    9
  • Joined

  • Last Visited

  1. Dunno, but on the first page there's a success story with a GTX 580, and he didn't do anything special.
  2. Unfortunately, I always install my games on a second disk (unless they're disk intensive), since my first disk is a SSD with limited space. Thus SimCity 4 was always installed on disk D, where no permissions are ever necessary. I also believe this fix is mostly for crashes and not video performance. No crashes on my SimCity 4, so it's kind of redundant.
  3. Unfortuately, no, 570 GTX is my only card. I also have the standard Sandy Bridge thingamajig, but it's disabled in the BIOS. Furthermore, both have separate video outputs, so if the game somehow used the Intel solution, I would get a blank screen since nothing is connected to the Intel video output. And yes, the vertex buffer "fix" does help me, in the 1M+ city it's the difference between 1 fps and 10 fps when scrolling, so it's quite the improvement. BTW, SC4 can scroll at 1 frame per second on my 2500k with a 570 GTX, while it worked almost perfectly (well, at least a lot better than now) on my old P4 with Radeon 9500 Pro. That's why I'm so hyped about the possibility (further fueled by the success stories in this thread) that it might work just as well or better with my current rig.
  4. @General Lee, thanks! Now I feel stupid, because I made screenshots with and without the files in the same place and alt-tabbing between them showed no difference except for pedestrians and cars being in different places. The shadows were a bit different, but they were still there (because I took a shot of skyscrapers during dawn, and these still drop shadows without the files) and I thought that they looked different because of the difference in in-game time and the shadows have simply moved. That would be weird, because as it turns out, the shadows don't move at all in this game. Ok, enough shame, the riddle was solved. Now... why, for example, Crom's rig, which is a bit better than mine, but uses the same generation NVidia card (580 GTX vs my 570 GTX), can take advantage of this configuration fix and I can't? I'd be happy to provide dumps and any information someone more able might need to solve this.
  5. He has a 9600 GT with a device id of a standard 9600 GT, not a 9600M GT, so it's pretty safe to deduce that his friend does not have a laptop. And neither do I for that matter.
  6. Yeah, I just want to play. I'm just wondering, why does the game run better without the files and am I missing anything when I get rid of them?
  7. @jinxed1git, what are your final entries in the files? I didn't remove mine (which I believe to be the most likely to work), so my findings above actually count as having "both fixes on" and this gives 100-300 fps, but falls to 25-60 when scrolling depending on zoom level and how big the city is. Still, even 25 fps is infinitely better than 1-3 fps I was experiencing before. I removed the video card lines, but it didn't change anything (the other fix is the one which gives me better performance), so I think the game just ignores them. @A Noony Moose, I always had them set to "Application-controlled" (each one that allows it). I only just now tried to change power management from adaptive to maximum performance because some old games have a problem with "jump starting" the newer video cards. It didn't do jack though and the GPU usage was still in the 15-30% area. Except when I park the camera in a place where there's nothing, then it goes to 80% when fps skyrocket to 800-1000+, but I guess it's normal with unlimited frames. I also tried removing the .sgr files from the directory completely, but it works like it worked before, leading me to believe that the last-used .sgrs are being stored by the game somehow and removing them won't help to diagnose anything. -- edit -- Hmm... now I'm stumped. I downloaded a really big city (about 1M+, previously I was checking on the big tutorial one which has a lot less density) and the behaviour is really weird. First, I tried "usevertexbuffers true". With files in the directory, I get 1-3 fps when scrolling that city (as expected), without the files I get 20-30 fps in the same spot and, finally, with files in the directory and "usevertexbuffers false" I get... 10 fps. I guess I couldn't see it in smaller cities, but the "usevertexbuffering" command isn't that powerful when dealing with 1M+ cities. Also, I believe the reason the game works better without the files is due to lower quality, the GR file has some rules that increase various detail options indepedently from low/medium/high setting of the game and thus the game without the file (even if you set everything on high) has less details present than with the file. -- another edit -- If it changes the details, I can't see it and, if it actually changes anything, it has to have something to do only with the amount of sims and automata. I compared the game with and without the files extensively and couldn't find any differences in building density, textures and shadows. Sims and automata can't be easily compared because of their random nature (but they're present in both "modes"). Thus, I get the best performance (but still not good enough) after removing the files completely, which is kind of weird. Any more ideas?
  8. Screen tearing

    I think it doesn't work at any 2560* res. If you really want 1:1 pixels, play in a window.
  9. Hi guys! I'm having the same problem as jinxed1git. I have a 2500k, 8GB RAM, W7 x64 and a GTX 570 (Gainward Phantom), everything up to date. System Information says that my device ID is 1081 (vendor ID is 10de, like it should be), so I wrote in Video Cards.sgr in the NVidia section at the end: card 0x1081 "GeForce GTX 570" The string is the same one that appears in the adapter string. in Graphics Rules.sgr I wrote every possible combination (I tried all at once and one at a time as well) in the 'partialRule "Fast card" -any' part: stringMatch cardIdentity "GeForce*GTX*570*" stringMatch cardIdentity "GeForce GTX 570*" stringMatch cardIdentity "NVidia*GeForce*GTX*570*" stringMatch cardIdentity "NVidia*GeForce GTX 570*" Nothing works and the game is still choppy as ever. I tried it with and without XP compatibility and with and without the following command line: -CPUCount:1 -Intro:off -d:DirectX -w -CustomResolution:enabled -r1600x900x32 -CPUPriority:high -ExceptionHandling:off I tried 0x1086 too (it's the ID from another type of GTX 570 from some manufacturers, mine is 1081 but I wanted to be sure). I even deleted the whole NVidia section from VC and put in something completely else to make sure nothing is overwriting the string and tested it with various variations in GR: vendor "ALLURBASE" 0x10de card 0x1081 "RBELONGTOUS" end Still no cigar though and I don't know whether it cross checks with the adapter name in the system as well. Hell, even if I put a "*" in GR (which should tell the game to use that damn fast mode no matter what GPU it is) it still doesn't work. Any ideas? --edit-- <- I tried this thing and it works! Better than software mode I might add. It's still a little jerky here and there, but it's nothing compared to how it was before. I'd like full 60 fps, but I guess I can't have everything.
×