Jump to content

WillQuixote

Member
  • Content Count

    4
  • Joined

  • Last Visited

  1. Simcity 4 Disk Recognition

    I works! That was a lot more simple than I was expecting.. Thanks buddy
  2. Simcity 4 Disk Recognition

    Unfortunately, the same happens when I launch it that way. Whenever the suspension bridge loading image appears, the 'Please insert correct CD ROM' message appears within a few seconds
  3. Hi, I've got a problem running my Sim City 4 Deluxe. I understand there are a selection of issues surrounding Sim City 4 and running it on Vista, but my issue seems a little bit rediculous, and I'm having trouble finding an answer to it. Anyway, lets explain. I use Vista Ultimate, and it is updated with all 'important' vista updates. I do however have 45 possible optional updates. In terms of Plugins, I've only installed the NEM mod. The problem has become apparent today, after trying to run the game from autorun. The disk went in, the window giving me the option to 'play', 'uninstall' etc appeared and I clicked 'play'. The image of the suspension bridge appeared, I waited for a few seconds, then a message appears telling me to insert the correct CDROM and restart the application. I obviously found this confusing, since the game was working the previous night.. As well as the fact that I would expect a CD ROM error to occur before the autorun window appeared. Any help is hugely appreciated! And I'm sorry if I've missed any relevant topic explaining this, feel free to give me a link to the relevant place and call me a dullard if you so fancy.
  4. Hi, I've got a problem running my Sim City 4 Deluxe. I understand there are a selection of issues surrounding Sim City 4 and running it on Vista, but my issue seems a little bit rediculous, and I'm having trouble finding an answer to it. Anyway, lets explain. I use Vista Ultimate, and it is well updated to my knowlege. However it is possible that I am missing some. The problem has become apparent today, after trying to run the game from autorun. The disk went in, the window giving me the option to 'play', 'uninstall' etc appeared and I clicked 'play'. The image of the suspension bridge appeared, I waited for a few seconds, then a message appears telling me to insert the correct CDROM and restart the application. I obviously found this confusing, since the game was working the previous night.. As well as the fact that I would expect a CD ROM error to occur before the autorun window appeared. Any help is hugely appreciated! And I'm sorry if I've missed any relevant topic explaining this, feel free to give me a link to the relevant place and call me a dullard if you so fancy.
×