• Moose
  • Announcements

    • Dirktator

      Please help us for July   06/30/2017

      This month we're hoping for a little bit of a boost this month or next, in addition to covering the regular bills, we could benefit from some hardware upgrades. STEX Collector's Set gifts can now be sent to you via digital download as well as regular mail if you wish! Every donation dollar goes toward keeping Simtropolis online and humming along. Your contribution counts! Hardware Upgrades As our website community software improves with more and more features, and as we bolt on additional features such as chat, the increased load to handle all these new toys is taking the server a bit to task. You may have noticed that we'd been forced to temporarily disable the chat as we worked out allocating resources for more optimal performance. Following this, we've applied a number of 'soft' changes such as caching options and experimented with server configurations (nginx as proxy, for example), so the hardware aspect is also an area we'd like to focus on. The last time we upgraded hardware was back in 2012, prior to the release of SC13. Your contribution means a lot! Your donation will go toward helping us to 1.) migrate to a newer server or 2.) at least get some ram/cpu/storage updates and any other infrastructure hardware or services. Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
  • How To Switch From Right To Left Hand Drive


    etherian

    There are two major steps.  

    Part one of two

    1. Locate and go to the directory where you have installed SC4, usually it is C:\Program Files\Maxis\SimCity 4 Deluxe

    2. Within this directory, you will see a folder name English, it should contain a file called SimCityLocale, if it does, you are looking at the correct folder.

    3. Now rename this folder from English to UKEnglsh (not a typo!)

    Part two of two

    4. From your START menu, select Run.

    5. Type in regedit into the field and click OK.

    6. On the left hand directory tree, expand HKEY_LOCAL_MACHINE > SOFTWARE > Maxis > SimCity 4 > 1.0

    7. Change the Language value by right clicking it and selecting Modify.

    8. Leave it as Hexadecimal and enter 13 into the Value Data field. Click OK.

    With these two major steps complete, your sims will now start driving on the Left! If you wish to switch from the Left to the Right - rename the folder to English in step 3, and enter 1 into the Value Data field in step 8 instead.




    User Feedback


    bumbro07

    Posted

    For some reason, I cannot find Maxis in my registry... :(

    Share this comment


    Link to comment
    Share on other sites
    Holydaiv

    Posted

    I have 64bit Windows 7 and in that the Maxis folder is under "wow6432Node". So the correct path in this would be HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Maxis > SimCity 4 > 1.0

    Share this comment


    Link to comment
    Share on other sites
    clarelvsroxy

    Posted

    I aint mucking about in the registry must be a better way

    Share this comment


    Link to comment
    Share on other sites
    jakis

    Posted

    OH, YES!!! IT WORKS!!! THANK YOU A MILLION!!!44.gif

    Share this comment


    Link to comment
    Share on other sites
    spuza3

    Posted

    Thank you mate.

    Share this comment


    Link to comment
    Share on other sites
    Ceraton

    Posted

    Will this mess up any of our settings other than the left hand switch? If no, then I will try it as soon as possible. :D

    Share this comment


    Link to comment
    Share on other sites
    nathancola13

    Posted

    i have nothing like that in my files, where do i go? i'm on a windows 7 satellite L755-S5246. What can i do? I really want to get my traffic on the left side, it bothers me that its on the right.

    never mind i got it, my files where all screwed up. thanks for the info!

    Share this comment


    Link to comment
    Share on other sites
    deadmanWNC

    Posted

    Hi, just tried this and yup, the cars moved over, but the traffic query tool only shopws numbers not the type of vehicle now, and the advisor messages are all messed up. Changed back to old settings and the messages are correct but cars are back on the right?

    Any ideas how to cars on the left and the text labels to work?

    thanks

    Share this comment


    Link to comment
    Share on other sites
    XanderMan2460

    Posted

    I have Windows 8 Release Preview 64bit and I get an error saying that I cannot edit the language.

    Share this comment


    Link to comment
    Share on other sites
    XanderMan2460

    Posted

    Never Mind, had to run as administrator.

    Share this comment


    Link to comment
    Share on other sites
    kheldarath

    Posted

    this didnt work for me :( I have the windows 7 32 bit steam version. I changed the registry details but they still drive to the right. Its a pain as i recently got the "UKENGLISH" locale data file. This would be the final step required. I used to be able to use the NAM traffic simulator to do this but the new version doesnt have it?

    Share this comment


    Link to comment
    Share on other sites
    Flat Raver

    Posted

    @kheldarath Remember that the folder needs to be named "UKENGLSH", without the i.

    Share this comment


    Link to comment
    Share on other sites
    Geogeo1

    Posted

    Thanks it works perfectly...off to Padokea :3

    Share this comment


    Link to comment
    Share on other sites
    mojo_rising1985

    Posted

    That worked ..but it messes up all my texts!!! any suggestions?? 

    (renamed the UKENGLSH to ENGLSH and the language value to 1)

     

    Also when i first tried to rename the UKENGLSH folder to ENGLSH  i got the message that "there is another folder using that name"..!?! 

    Share this comment


    Link to comment
    Share on other sites
    ray3501

    Posted

    That worked ..but it messes up all my texts!!! any suggestions?? 

    (renamed the UKENGLSH to ENGLSH and the language value to 1)

     

    Also when i first tried to rename the UKENGLSH folder to ENGLSH  i got the message that "there is another folder using that name"..!?!

    It messes up all your text because you didn't rename the folder properly! If you are to drive on the right side and have the text to speak in English, change UKEnglsh to English (YES! With the "I"!). Missing the "I" in "UKEnglsh" is no typo, but missing the "I" in "English" is a typo.

    Share this comment


    Link to comment
    Share on other sites
    MTYland

    Posted

    what about digital version, i have the instalation folder directly on c drive under a folder called gog games, because my game is the gog version what i need to do?

    Share this comment


    Link to comment
    Share on other sites
    gregchickenguy

    Posted

    I have 64bit Windows 7 and in that the Maxis folder is under "wow6432Node". So the correct path in this would be HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Maxis > SimCity 4 > 1.0

    This is also true for Windows 8

    huzman likes this

    Share this comment


    Link to comment
    Share on other sites
    rsc204

    Posted (edited)

    Digital versions of the game (as well as the others) can be made to use LHD by adding the following switch to the target line of your shortcut:

    -l:"UK English"

    In addition to this, you need to create a duplicate folder in the main SimCity 4 Deluxe folder. So for example there should be an existing folder "English" containing a file "SimCityLocale.DAT". If the folder "UKEnglsh" also exists here (usually disk versions only), check there is a "SimCityLocale.DAT" inside, if so you are good to go. If you don't have the second folder, copy the regular "English" folder and rename that copy "UKEnglsh". Basically the game looks for localised UK text, but you may not have had the UK English versions included with your game. In this case the US English locale (or any other language) can be substituted, but it must reside in a folder named "UKEnglsh".

    There is no drawback to switching, but remember you need to re-install the NAM and check the correct driving side is selected before playing.

    Note: for Steam versions open the Steam Client find Sim City 4, right mouse click and select properties, here you can find an option "Set Launch Options" where you can enter the switch. Note also that the default install location for SC4 is within the Steam Folder in Program Files (x86). Note the orange part is only for users of 64-Bit operating systems.


      Edited by rsc204
    huzman likes this

    Share this comment


    Link to comment
    Share on other sites
    maximusmaximillion

    Posted

    I have 64bit Windows 7 and in that the Maxis folder is under "wow6432Node". So the correct path in this would be HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Maxis > SimCity 4 > 1.0

    thanks a gazillion ... it really does work... hehehehehe :thumb::party:

    Share this comment


    Link to comment
    Share on other sites
    Urban Constanta

    Posted

    Also on windows 7. couldn't find maxis in the reg but after i changed from UKEnglsh to English i entered the game and the traffic was switched from right to left. so it seems that sometimes you don't need to modify the "regs".

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an Account  

    Sign up to join our friendly community. It's easy!  :thumb:


    Register a New Account

    Sign In  

    Already have an account? Sign in here.


    Sign In Now

  • New Articles

  • Recently Browsing   0 members

    No registered users viewing this page.