Jump to content
11241036

MMP Issue: Game skips one step

5 posts in this topic

Recommended Posts

I'm suffering from a weird issue related to placing MMP's: Whenever I'm trying to place a flora item by clicking once, the game always skips one item in the MMP cycle. In other words: If there's a cycle of 6 MMP's, I can only place item 2, 4, and 6 on a city tile. This does only count when I'm clicking once, when dragging, the game only places the first item.

I should note that I'm suffering from this issue since I've bought a new PC, along with an edition of Windows 10 and a digital copy of SimCity Deluxe from Amazon. I can't tell if this issue is related to my new machine, Windows 10, or the digital copy from Amazon.

Share this post


Link to post
Share on other sites

I have the Amazon version of SC4 and do not have a problem like the one you described.  Based on your description, could it be some setting with the mouse software that treats a single click as a double click.  That's the first thing that comes to mind.

Share this post


Link to post
Share on other sites

@SimCoug I've checked all settings related to my mouse and could not find any setting like this. Also, this issue only occurs while playing SC4 and furthermore, only and exclusively while placing MMP's.

Share this post


Link to post
Share on other sites

Another user was recently also having problems with MMPs, although not identical, very similar problems:

At the time I could only conclude that something was probably wrong with the user's setup, given that I'd never heard of the problem elsewhere. Frankly, that's still a possibility, although I know you do know what you are doing technically, I wouldn't want to rule it out.

Of course 2 cases of similar weirdness may be a compatibility issue somewhere, even thought it's hard to understand why that just affects the "Flora Cluster type" functionality. Given that we're looking at two versions of Windows, both versions many people play with without problems, I think we can probably rule out the O/S. Could it be related to graphics drivers?, seems a long shot, since this isn't affecting graphics/rendering, but actual code function.

So it would appear some hardware/software in your machine may be causing an incompatibility with some code/library etc that is preventing the intended behaviour. Without more data regarding the problem, all I can suggest is try the usual suspects.

  • Make sure the game is patched fully (I know, it's a digital version, but check the version number to be sure).
  • Remove your plugins suite and test, maybe with a single, test MMP, ideally with Maxis props only.
  • Try updating your drivers for things like sound/video cards and other devices used by Direct X.
  • Switch the rendering mode to software, it's worth a shot.
  • Disable all security/antivirus tools completely. Best to disconnect from the internet whilst testing.
  • After that, I'd try disabling all background apps on your PC.
    Under Win7 this would be using the MSCONFIG application to disable every program, service and startup application you could, whilst still allowing SC4 to run. Not sure if you get MSCONFIG on Win10, but there should be an equivalent one hopes. That would be your baseline test, if the problem remains, no point continuing. But if somehow it went away, then you'd need to manually enable apps one at a time until you found the culprit.

The problem here is that the behaviour is very odd and it really doesn't make sense:

On 16/06/2017 at 4:44 PM, rsc204 said:

how is it that the game can still read the sequence to switch between the first few items, but then fails for items beyond three? (or in this case can read every second exemplar). We know the code is still switching between IDs, i.e. the expected behaviour. So if that's working why does it stop at a certain point? If the properties inside the MMPs are unmodified, then the links should still be there. If somehow the game couldn't read IDs properly, then your issue would not be limited to MMPs, it would frankly cause huge problems, since everything relies on IDs.

That was one of my conclusions with the last problem I linked to. Not the same as yours, but related to incorrect function of MMP exemplars. Odder with your problem is that the first item never appears. Without that exemplar being read, it would be impossible for the MMP to function in the first place to show the second item. Similarly, the linked IDs are the order of the exemplars being read, which must be happening for it to skip showing a given flora item. The code must be reading the exemplars of those items it doesn't show, or it wouldn't link (jump) to the next one's ID. So it is reading all the data, but simply skipping every other objects display?

16 hours ago, SimCoug said:

Based on your description, could it be some setting with the mouse software that treats a single click as a double click.

You know that resonates totally with the problem you are seeing. We could look at the more complex problems, but I really think SimCoug is on the money, it's simply the most probable explanation here. Perhaps the driver doesn't like archaic versions of DirectX? Perhaps your mouse has super-sensitive buttons?

(Or like one I got recently which double clicks when pressed once, OK that was a cheap nasty second hand mouse I got free with a laptop, but still)...

It just seems that two clicks = every other item shows, that's simply too neat to ignore as the most likely cause.

If that's not it though, things get very tough frankly to diagnose, let alone fix. Such problems are rarely going to be hardware/driver based issues. Of course code is all written in different languages and yes something could break compatibility with the libraries function that enabled that code. But to do so for such a small and specific part of the whole is very odd indeed. You may find it nigh on impossible to track the real cause with any certainty. Especially since we don't know enough about how the game works at a code level to offer targetted advice. What I'm setting myself up to say here is, if you can't get it working easily, you most likely never will. As such, I'd look to try running the game in a VM or some other work-around if you get to that point.

Share this post


Link to post
Share on other sites
Posted (edited)

@rsc204 Thank you for your advice. I've tried all or your suggestions, but none of them worked.

  • My game is fully patched (1.1.641).
  • The problem still persists on an empty Plugins folder.
  • All device drivers are up to date.
  • Switching to Software Rendering Mode didn't help, either, nor disabling antivirus tools, or disabling all background apps.
  • Regarding my mouse: I'm using the same mouse that I've been using on my old machine. I have DirectX 12. I've also checked all mouse settings and couldn't find any setting treating a single click as double-click (besides, that would affect the function of my mouse just anywhere else, and anywhere else, my mouse works fine).

Edit: Fortunately, there's a good temporary workaround: I'll just remove the Flora Clustering ability from selected MMP's, thereby making several single MMP items out of one MMP cycle, if I want more control about which MMP I'll get in particular.


  Edited by 11241036  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:

Register a New Account

Sign In  

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×