• Moose
  • Announcements

    • Dirktator

      Need your donations for May & June!   05/01/2017

      We need your support to help keep Simtropolis online. We also need a little bit more this month to enhance the new chat with some features, such as mobile support! Please consider a donation today if you can help out, it would mean a lot! And we'll send you a little gift in return.  Help us reach our May goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
    • Dirktator

      About our affiliation with GOG.com   05/23/2017

      Simtropolis is now an affiliate of GOG.com! When you use one of our affiliate links to GOG.com, all it means is that Simtropolis has a chance to earn a small commission from any purchases you might make. So if you see something that tickles your fancy, please use our affiliate links and by doing so, you'll help support Simtropolis! Thanks!
AmiPolizeiFunk

The Asset Editor got some improvements!

11 posts in this topic

I'm really happy that the Asset Editor got some improvements. Most importantly, it seems to be much more stable now! I can do things now without crashing that would have crashed me 100% of the time previously. I can even use the Asset Editor without unsubbing to my 1000+ assets and 30+ mods. Previously, this was unthinkable. It's still sluggish, but it's actually use-able. In -noWorkshop mode, I can do "New Asset" after importing an asset without crashing, which I could never do previously.

 

We also have some new options in the building stats window, particularly a dropdown list of monument templates (and one called "always unlocked" that doesn't have silly requirements) instead of the binary "use monument template" button that we had previously.

 

And ofc now we can mod citizens. I'm really looking forward to some new folk to populate my world. Is anybody working on any new cims yet?

 

Are there more changes that I haven't noticed?

Avanya likes this

Share this post


Link to post
Share on other sites

They fixed the bug when model is not shown in Asset Importer Window. Well they say so, haven't tried myself yet.

Share this post


Link to post
Share on other sites

Bulldozer has a switch for underdground. Once you click it, you switch to underground view. 

It's awesome. 

Share this post


Link to post
Share on other sites

I was so happy when I noticed these improvements yesterday! Shoud make the end part of the asset creation process so much more comfortable! Also citizen modding sounds interesting, but I won't look into it just yet.

Share this post


Link to post
Share on other sites

Yay! Very happy to hear this and can't wait to try it out myself. :) Lately I've had crashes with 3 mods and 5 buildings on, which made it a pain to do anything! :P I still have a bunch more wishes for the asset creator (which I should prob write down), but more stability is always great :D

Share this post


Link to post
Share on other sites

Quite opposite as many of you wrote, my Asset Editor never crashed at all with -noWorkshop. Even though I use some mods in my local folder (like Daylight Classic, Modtools, FPS Camera, etc.)

Share this post


Link to post
Share on other sites

Old Asset Editor Syndrome 

Medically proven neuro-motor illness. 

Causes: 

Caused by the old asset editor which crashes to desktop because of pre-installed mods and excessive number of assets. Modder has to click "Quit to desktop" in order re-use the Asset Editor. 

Symptoms: 

Modder clicks "Quit to desktop", unintentionally, due to the bad neuron receptors between motor muscles and neurons.

Lost_Gecko, Ryno917 and Alexgru88 like this

Share this post


Link to post
Share on other sites

Yeah I know right? I'm trying to remember to change my attitude from:

"This will never work, just QTD to be safe and restart"

to:

"Hey thie MIGHT work, maybe I should just try it?"

R3V0 likes this

Share this post


Link to post
Share on other sites

I also noticed the improvements and stability. But now I'm getting a problem where the road to show how your building is oriented isn't showing up. It might be because my model footprint is too big, but I'm not certain. Anyone else experiencing this?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By alborzka
      This thread will focus on improving and revamping the Transport Lines Manager mod, as well as potentially adding features from IPT and/or unique new features if possible.
      Transport Lines Manager Reborn 6.0.1 now in the workshop.
      Bugs as of 6.0.1:
      Renamed depots are not working in the TLM listing and in depot details windows. Bus stations and terminals are wrongly listed as depots. Not show cable car stations on linear map as near transport. Ticket price changes not being implemented. Sort lines by colour not working. OP is below:
      The creator of IPT hasn't been online in over 5 months, and the creator of TLM hasn't been online in nearly 1 month. Mass Transit DLC is coming out in a few weeks, and I don't know how either of these mods will fare with changes being brought to the transit system.
      Is anyone in touch with either of these authors? I would especially hate to see TLM go to the dustbin of modding history considering how many options and useful configurations it provides (plus the aesthetics!) such as changing frequency depending on time of day (such a no-brainer), and IPT has excellent debunching. Now that these two mods are nearly incompatible, and with the DLC coming out soon potentially rendering both useless, something must be done. They're far too valuable to go to waste.
      If we can't get the authors to update their mods or publish their code for others to carry it forward, can we all maybe pitch in and create an entirely new mod from scratch? Is someone working on this already? Even with the improvements being brought with the free upgrade/DLC, I feel TLM/IPT features will still be vital to many player's C:S experience. What do y'all think?
    • By Armesto
      So, with the addition of blimps to the new expansion, I made a real scale Graf Zeppelin. It's my first time with a vehicle and weird stuff is happening.
      First, vanilla motors seem to be in the model and I don't know how to remove them (also the lateral screens, but they are hide inside the model, so is not a problem). 

      Second, my motors don't spin as they should, only two of the four rotate, and they do it in the direction of wheels...

      Any idea on how to solve this?
    • By AmiPolizeiFunk
      As expected, my save failed to load. What's the protocol here? Should I disable all mods and try to add them back one-by-one?
       
      Let's help each other out by listing out mods that have been broken and should definitely be disabled. Who will go first?
    • By skallben
      To the North to be specific. We have mass transit and culture. We have old buildings, and we have alot of rails.
      This city journal will focus on function, infrastructure, public spaces and mass transit. Not the DLC, but real functional mass transit, Scandinavian/Northern european style. I will guide you through the larger urban area after the jet lag has let off. Welcome.

      A bit before landing, in the background you see Morstad, where we will spend most of our first tours.


      Older part of the urban area, Gamla Stan (Old Town).


      Can you spot the rail station? Hint: Walk down the road.
    • By vitusweb
      Hi everybody,
      I am just experimenting with my first Blender asset. I have no textures at the moment.
      At first I could import it successfully in the game, but it had some flipped normals and missing faces, which I had to fix.
      After correcting those issues and removing doubles, I tried to import it again. I can now see my asset in the Asset Editor and it looks correct (including size and orientation). I can appearently save it, but it won't show up in game. Even if I try to load the saved asset again in the Asset Editor, it won't work (it just does nothing). Still I can see it in the content manager. I can even find it with the Find It mod in game, but I get an error as soon as I try to plop it (I think "Object reference not set to an instance of an object").
      I am using the "Cinema" template when importing it in the Asset Editor. I am using the --disableMods and --noWorkshop options when working with the Asset Editor.
      I don't think it is a model problem, otherwise it wouldn't show up even in the Asset Editor... Does anyone have an idea? Thanks!
      EDIT: I had this issue originally with a quite complex model, but it happens even with the simple model which I attach as fbx.
       
       
       
       
      testtorre4.fbx
  • Recently Browsing   0 members

    No registered users viewing this page.