• Moose
  • Announcements

    • Dirktator

      Need your donations for May & June!   05/01/2017

      We need your support to help keep Simtropolis online. We also need a little bit more this month to enhance the new chat with some features, such as mobile support! Please consider a donation today if you can help out, it would mean a lot! And we'll send you a little gift in return.  Help us reach our May goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
    • Dirktator

      About our affiliation with GOG.com   05/23/2017

      Simtropolis is now an affiliate of GOG.com! When you use one of our affiliate links to GOG.com, all it means is that Simtropolis has a chance to earn a small commission from any purchases you might make. So if you see something that tickles your fancy, please use our affiliate links and by doing so, you'll help support Simtropolis! Thanks!
AmiPolizeiFunk

Let's keep a list of which mods break with MT

53 posts in this topic

14 minutes ago, Mr_Maison said:

If you disable a mod such as Metro Overhaul, You must also disable all assets related to it or you will continue to get errors since the trains, depot, etc. will be orphaned.

the building assets at least don't actually break the game. they will just receive a "network prefab missing" error and not load in game. I think the vehicles might cause trouble though

Share this post


Link to post
Share on other sites
5 minutes ago, AmiPolizeiFunk said:

My MOM seems to be working (which is pretty incredible, since I don't think they have updated it yet.)

MOM didn't actually break, i think the person above just disabled it in case (which caused it's own problems)

Avanya likes this

Share this post


Link to post
Share on other sites

Finally after 2 days i got the game running with MT. The game crashed while saving, exiting etc. Had to get rid of 25 tiles, unlock all areas, "transportation unlock" and a few assets. Working like a charm with the updated 81 tiles :)

Share this post


Link to post
Share on other sites

Mod panel is working.

Also I have no issues with One-way train tracks. Whats not working properly when the mod is installed is the vanilla one way track.

Share this post


Link to post
Share on other sites
1 hour ago, rovapasi1 said:

Mod panel is working.

Also I have no issues with One-way train tracks. Whats not working properly when the mod is installed is the vanilla one way track.

try removing the mod though because the Vanilla definitely works in the vanilla game

Share this post


Link to post
Share on other sites
20 hours ago, Judazzz said:

Very interesting. My map went completely ape after I started a ferry line as well (textures, props, trees, decals flickering, blue roads, buildings disappearing), so I'll definitely give disabling Network Skins a try. Thanks for the heads up!

Too bad Boformer is hardly active these days, so I'm not really hopeful it will be fixed any time soon :cry:

Looks like you can maybe find some of that hopefulness again. From Network Skins comment section:

Quote

BloodyPenguin: Guys, I'm starting to look into the issue. Once I fix it, I'll ask boformer to upload my updated version. Stay tuned!

 

gfvsims likes this

Share this post


Link to post
Share on other sites

I'm currently facing an issue with Advanced Buildings Editor. Train station assets that have been saved with the mod enabled won't load again in the asset editor, and also fail to load in-game. I discovered this after I had already updated an old station of mine with a (apparently) broken version... and since it was my first asset I don't have the old .crp file backed up (I do have the original .fbx files of course - but I can't "rebuild" the asset without ABE).

I'm fairly certain it's this mod, because the only other mods I have enabled are Prefab Hook, ModTools and More Network Stuff (which is necessary to place the train tracks needed in this station). I'm already bugging BloodyPenguin about it but I just wanted to warn other asset creators about this - properly check if you're updated assets are working before uploading them!

Share this post


Link to post
Share on other sites

 

16 minutes ago, Lee Towers said:

I'm currently facing an issue with Advanced Buildings Editor. Train station assets that have been saved with the mod enabled won't load again in the asset editor, and also fail to load in-game. I discovered this after I had already updated an old station of mine with a (apparently) broken version... and since it was my first asset I don't have the old .crp file backed up (I do have the original .fbx files of course - but I can't "rebuild" the asset without ABE).

I'm fairly certain it's this mod, because the only other mods I have enabled are Prefab Hook, ModTools and More Network Stuff (which is necessary to place the train tracks needed in this station). I'm already bugging BloodyPenguin about it but I just wanted to warn other asset creators about this - properly check if you're updated assets are working before uploading them!

Do you mean your 3 track dutch station?

 

EDIT: Yeah, you mean this one. Sh**

Share this post


Link to post
Share on other sites

Yep I mean that one. But @BloodyPenguin already fixed it supposedly, he's so amazingly quick! The station will (hopefully) be back in business within a few hours.

Share this post


Link to post
Share on other sites

Does anyone have the "Dutch_3track_station.crp" older than 20.05.2017 18:21 ??

 

If so, pls. upload to steam!!!

 

EDIT: Sorry, saw the second part of your comment to late. Maybe someone has a copy, would make fixing faster than rebuild the whole asset.

Share this post


Link to post
Share on other sites

@rovapasi1  Thank Russian pirates: http://uploadfiles.eu/du9rccc54yie/782539245_Dutch_3-track_station.zip.html

I just fixed the issue with Advanced Buildings Enabler (and uploaded the update).

Before that, I forgot to update the part that saved paths for 1.7 code :( Because of that all assets that have networks in the, that were saved with this mod enabled after 1.7 was released are impossible to load now :(

The new version of ABE saves assets just fine (UPDATE 4), but only way to fix the assets that were broken by this mod is to load previous versions of them in asset editor (or rebuild from sources) and save them again.

I'm really sorry guys :(

Share this post


Link to post
Share on other sites

Wow, Thanks. My map looked realy stupid without.

 

Now I can play and wait for the fixed one

Share this post


Link to post
Share on other sites

Modders (@BloodyPenguin & @Boformer & @SamsamTS in particular) -- thanks for you hard work! *:thumb:

 

just a reminder, Network Skins still has the bug where asymmetric light effects on props don't get rotated properly on pedestrian paths:

wJt0C59.jpg

Share this post


Link to post
Share on other sites

'First-Person Camera' was updated to 1.7 on May 20th. I can't confirm if it's working or not yet.

Any update on exactly which mod 'Control Building Level-Up' is conflicting with?

Share this post


Link to post
Share on other sites

Any news on an update for Dynamic Resolution? Does it still conflict with MT? 

 

Not having better anti-aliasing whilst taking screenshots is bumming me out!

Share this post


Link to post
Share on other sites
5 minutes ago, AmiPolizeiFunk said:

Any news on an update for Dynamic Resolution? Does it still conflict with MT? 

 

Not having better anti-aliasing whilst taking screenshots is bumming me out!

That's why you use Shift + F12 to take a 4x resolution screenshot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By Mr_Maison
      Hello everyone. This will be my custom content showcase and workshop thread. In all the years I been a member here, I never uploaded any content but enjoying great work by other members. I take this opportunity to say Thank You to all content makers for making our city building experience so enjoyable. I feel that making content is overdue for me and I want to give back to the community. I have some buildings and trees that I will be showing in upcoming updates to this thread. I will also be asking for advice and help.
      5/25/2017 Release: Wooden Box Planter Link http://steamcommunity.com/sharedfiles/filedetails/?id=932855630

       
      And with Tulips

       
      More info on last pages of this thread.
       
       
      Note: This post was edited 5/29/2015 to reserve this first post for all current updates.
       
       
    • By Ronyx69
      So I was recently looking at some Japan driving videos and got inspired to make some highway pillars.
      I'm planning to make an entire set of various types of pillars in this style, even a 6cell over-canal pillar. (if it goes okay)
      Tell me what you think about my first attempt, I need to nail the style and the details before I start making other variations.
      Constructive criticism welcome, also any ideas.
      By the way, do pillars have LODs like regular buildings? I should just make it just the pillar, without the small details - pipe, wires, supports.
      Not sure when they're going to be done and available.

       


       
    • By alborzka
      This thread will focus on improving and revamping the Transport Lines Manager mod, as well as potentially adding features from IPT and/or unique new features if possible.
      Transport Lines Manager Reborn 6.0.1 now in the workshop.
      Bugs as of 6.0.1:
      Renamed depots are not working in the TLM listing and in depot details windows. Bus stations and terminals are wrongly listed as depots. Not show cable car stations on linear map as near transport. Ticket price changes not being implemented. Sort lines by colour not working. OP is below:
      The creator of IPT hasn't been online in over 5 months, and the creator of TLM hasn't been online in nearly 1 month. Mass Transit DLC is coming out in a few weeks, and I don't know how either of these mods will fare with changes being brought to the transit system.
      Is anyone in touch with either of these authors? I would especially hate to see TLM go to the dustbin of modding history considering how many options and useful configurations it provides (plus the aesthetics!) such as changing frequency depending on time of day (such a no-brainer), and IPT has excellent debunching. Now that these two mods are nearly incompatible, and with the DLC coming out soon potentially rendering both useless, something must be done. They're far too valuable to go to waste.
      If we can't get the authors to update their mods or publish their code for others to carry it forward, can we all maybe pitch in and create an entirely new mod from scratch? Is someone working on this already? Even with the improvements being brought with the free upgrade/DLC, I feel TLM/IPT features will still be vital to many player's C:S experience. What do y'all think?
    • By Armesto
      So, with the addition of blimps to the new expansion, I made a real scale Graf Zeppelin. It's my first time with a vehicle and weird stuff is happening.
      First, vanilla motors seem to be in the model and I don't know how to remove them (also the lateral screens, but they are hide inside the model, so is not a problem). 

      Second, my motors don't spin as they should, only two of the four rotate, and they do it in the direction of wheels...

      Any idea on how to solve this?
    • By AmiPolizeiFunk
      I'm really happy that the Asset Editor got some improvements. Most importantly, it seems to be much more stable now! I can do things now without crashing that would have crashed me 100% of the time previously. I can even use the Asset Editor without unsubbing to my 1000+ assets and 30+ mods. Previously, this was unthinkable. It's still sluggish, but it's actually use-able. In -noWorkshop mode, I can do "New Asset" after importing an asset without crashing, which I could never do previously.
       
      We also have some new options in the building stats window, particularly a dropdown list of monument templates (and one called "always unlocked" that doesn't have silly requirements) instead of the binary "use monument template" button that we had previously.
       
      And ofc now we can mod citizens. I'm really looking forward to some new folk to populate my world. Is anybody working on any new cims yet?
       
      Are there more changes that I haven't noticed?
  • Recently Browsing   0 members

    No registered users viewing this page.