• Moose
  • Announcements

    • Dirktator

      Need your donations for May & June!   05/01/2017

      We need your support to help keep Simtropolis online. We also need a little bit more this month to enhance the new chat with some features, such as mobile support! Please consider a donation today if you can help out, it would mean a lot! And we'll send you a little gift in return.  Help us reach our May goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
    • Dirktator

      About our affiliation with GOG.com   05/23/2017

      Simtropolis is now an affiliate of GOG.com! When you use one of our affiliate links to GOG.com, all it means is that Simtropolis has a chance to earn a small commission from any purchases you might make. So if you see something that tickles your fancy, please use our affiliate links and by doing so, you'll help support Simtropolis! Thanks!
AmiPolizeiFunk

Let's keep a list of which mods break with MT

52 posts in this topic

As expected, my save failed to load. What's the protocol here? Should I disable all mods and try to add them back one-by-one?

 

Let's help each other out by listing out mods that have been broken and should definitely be disabled. Who will go first?

Share this post


Link to post
Share on other sites

Not working: 

Advanced Building Editor - Assets get broken when they are saved while ABE is active

Loading Screen - Doesn't load any workshop assets 

Quay Anarchy - Gives errors 

Transport Line Render Fix - Gives errors 

Some might say that Network Extensions 2 is not working but I think they don't care enough to test mods individually, for my case, NExt 2 is working just fine. 

Share this post


Link to post
Share on other sites

I'd advise posting on reddit if you have updates.  The turnaround on r/CitiesSkylines is very quick.

R3V0 likes this

Share this post


Link to post
Share on other sites
17 minutes ago, Tim The Terrible said:

Why does it say One Way Tracks is broken? Works fine for me...

One Way Tracks work, but I noticed that joining your tracked with the new vanilla one ways made the junction a bunch of dirt.  That was a quick casual observation a couple hours ago though.  

There's only three major mods that are down that would draw errors for anybody still:

1. Improved Public Transport  (Replaced by IPT 2 though)

2. Transport Line Manager  

3. Dynamic Resolution

Besides those three, one should not be pulling errors when loading in.

Share this post


Link to post
Share on other sites
Just now, Roadman20 said:

One Way Tracks work, but I noticed that joining your tracked with the new vanilla one ways made the junction a bunch of dirt.  That was a quick casual observation a couple hours ago though.  

That's because the modded tracks are based on tram track and were never designed to intersect with the vanilla ones. The whole mod needs to be reworked and freshly based on the new tracks instead of the tram tracks. Right now it's the same as intersecting rail with roads - does not work.

Share this post


Link to post
Share on other sites
Just now, Tim The Terrible said:

That's because the modded tracks are based on tram track and were never designed to intersect with the vanilla ones. The whole mod needs to be reworked and freshly based on the new tracks instead of the tram tracks. Right now it's the same as intersecting rail with roads - does not work.

That's probably what people are complaining about then, the mod still works as originally intended before this latest release.

Share this post


Link to post
Share on other sites
1 minute ago, Roadman20 said:

That's probably what people are complaining about then, the mod still works as originally intended before this latest release.

On Reddit someone said it threw an error. I tried while running only ModTools, Catenary Replacer, One Way Tracks and Extra Station Tracks, but error or not, everything worked as usual. So either it's an incompatibility (which I doubt) or someone's got it wrong.

Not all errors are harmful 

Roadman20 likes this

Share this post


Link to post
Share on other sites

Network Skins is broken for me AFTER i start placing new public transport types (like ferries). Removed it and it works properly. nets and props no longer disappear

Judazzz and Avanya like this

Share this post


Link to post
Share on other sites

I hope Dynamic Resolution gets an update soon. I'm so accustomed to looking at the game at a minimum of 150% supersampling that the aliasing I'm seeing now is driving me a bit nuts!

Share this post


Link to post
Share on other sites

I'm shattered to know that Samsam won't uodate his Advanced Vehicle Options tool. 

*cries* 

We can count it broken as well, since it doesn't have features that monocars need, along with ferries and cable cars 

Yellowfin likes this

Share this post


Link to post
Share on other sites
2 hours ago, R3V0 said:

I'm shattered to know that Samsam won't uodate his Advanced Vehicle Options tool. 

Is it sure he will not fix?

I just had a look at the code on git. Even I have never worked with C# it looks pretty foreward and should not be impossible to expand the used routines to cover monorails, ferries and blimps.

EDIT:

Its working for all "old" transport types. F.e. trains still have the "replace last car" option

 

Share this post


Link to post
Share on other sites
3 minutes ago, rovapasi1 said:

Is it sure he will not fix?

I just had a look at the code on git. Even I have never worked with C# it looks pretty foreward and should not be impossible to expand the used routines to cover monorails, ferries and blimps.

EDIT:

Its working for all "old" transport types. F.e. trains still have the "replace last car" option

 

Someone said on my INNOVIA Asset page, that's not gonna happen, I checked Samsan's page, and it seems he added a note that he will not work on updating the asset. I also checked it, it can be done but I have zero knowledge about prefab names of moo, cable cars etc. Those values has to be added and extra lines with replace car with engine function for monorails should do the trick

 

Share this post


Link to post
Share on other sites
2 minutes ago, R3V0 said:

Someone said on my INNOVIA Asset page, that's not gonna happen, I checked Samsan's page, and it seems he added a note that he will not work on updating the asset. I also checked it, it can be done but I have zero knowledge about prefab names of moo, cable cars etc. Those values has to be added and extra lines with replace car with engine function for monorails should do the trick

That was my findings as well.

But he states on his page as well, he will try to keep the mod working.

Btw. Those values should be visible in the asset editor or in mod tools.

Avanya likes this

Share this post


Link to post
Share on other sites
Just now, rovapasi1 said:

That was my findings as well.

But he states on his page as well, he will try to keep the mod working.

Btw. Those values should be visible in the asset editor or in mod tools.

Hmm...

Then... 

Set the phasers to fun 

*launches Cities Skylines*

Avanya likes this

Share this post


Link to post
Share on other sites
7 minutes ago, R3V0 said:

Hmm...

Then... 

Set the phasers to fun 

*launches Cities Skylines*

yeah they're all in modtools under the expansion 4 tab

Avanya likes this

Share this post


Link to post
Share on other sites

Hi,

 

i just startet to build a metro on my new city - and it asked me for a Metro Depot ? I assume IPT is causing this ... because vanilla CS has no Metro depot .. anybody same problem ?

Share this post


Link to post
Share on other sites

By "metro" do you mean with MOM (Metro Overhaul Mod)? MOM needs a depot, the vanilla metro does not.

Share this post


Link to post
Share on other sites

yeah .. thats why i am wondering - i have no MOM - i disabled all assets and have just Mod´s on that are from the OK list (findit/moveit kind of mods) - i build the metro line (Metro tab hasnt a depot - just the 3 icons for station/tunnel/line) and when checking 10 min later i was wondering why no metro was driving ... so i opend the tab and saw that IPT showed "no Metro Depot" - thats why i think it has to do with IPT

 

UPDATE: After reloading Metro was fine -

Share this post


Link to post
Share on other sites
13 hours ago, Bad Peanut said:

Network Skins is broken for me AFTER i start placing new public transport types (like ferries). Removed it and it works properly. nets and props no longer disappear

Very interesting. My map went completely ape after I started a ferry line as well (textures, props, trees, decals flickering, blue roads, buildings disappearing), so I'll definitely give disabling Network Skins a try. Thanks for the heads up!

Too bad Boformer is hardly active these days, so I'm not really hopeful it will be fixed any time soon :cry:

Share this post


Link to post
Share on other sites

The metro depot issue should not be a real issue. You should be able to choose the first station of your metro line as depot. Same as for train lines in IPT

Share this post


Link to post
Share on other sites
10 hours ago, R3V0 said:

We can count it broken as well, since it doesn't have features that monocars need, along with ferries and cable cars 

That's not what broken means... Broken is when it doesn't work anymore, at all. The word you are looking for is 'outdated'.

gfvsims and Avanya like this

Share this post


Link to post
Share on other sites
4 minutes ago, Tim The Terrible said:

That's not what broken means... Broken is when it doesn't work anymore, at all. The word you are looking for is 'outdated'.

My usual philosophy is "if it aint broken, don't fix it", so I don't care if a mod or an asset gives error messages but continues to do what it's supposed to. Although, some people might not like it the same way, if an error message pops up, they complain. Thus, I said "it's broken". Anyway it's updated now, most of the stuff is updated I think, only camera mods? 

 

 

Share this post


Link to post
Share on other sites
4 hours ago, Miccrosshill said:

yeah .. thats why i am wondering - i have no MOM - i disabled all assets and have just Mod´s on that are from the OK list (findit/moveit kind of mods) - i build the metro line (Metro tab hasnt a depot - just the 3 icons for station/tunnel/line) and when checking 10 min later i was wondering why no metro was driving ... so i opend the tab and saw that IPT showed "no Metro Depot" - thats why i think it has to do with IPT

 

UPDATE: After reloading Metro was fine -

sometimes if you disable a mod it doesn't stop it from causing problems. the only sure safe way of completely stopping a mod from interfering is to unsub from it.

4 hours ago, Judazzz said:

Very interesting. My map went completely ape after I started a ferry line as well (textures, props, trees, decals flickering, blue roads, buildings disappearing), so I'll definitely give disabling Network Skins a try. Thanks for the heads up!

Too bad Boformer is hardly active these days, so I'm not really hopeful it will be fixed any time soon :cry:

Yeah I've had other people have the same problem now. and funnily enough I said other transport networks in general but it was only the ferry line that i had placed when i noticed it.

2 hours ago, rovapasi1 said:

The metro depot issue should not be a real issue. You should be able to choose the first station of your metro line as depot. Same as for train lines in IPT

MOM has it built in to not be able to select a metro station. It must have a depot. MOM would have had to be unsubbed for this to not take affect.

Avanya likes this

Share this post


Link to post
Share on other sites

If you disable a mod such as Metro Overhaul, You must also disable all assets related to it or you will continue to get errors since the trains, depot, etc. will be orphaned.

gfvsims likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By Mr_Maison
      Hello everyone. This will be my custom content showcase and workshop thread. In all the years I been a member here, I never uploaded any content but enjoying great work by other members. I take this opportunity to say Thank You to all content makers for making our city building experience so enjoyable. I feel that making content is overdue for me and I want to give back to the community. I have some buildings and trees that I will be showing in upcoming updates to this thread. I will also be asking for advice and help.
      5/25/2017 Release: Wooden Box Planter Link http://steamcommunity.com/sharedfiles/filedetails/?id=932855630

       
      And with Tulips

       
      More info on last pages of this thread.
       
       
      Note: This post was edited 5/29/2015 to reserve this first post for all current updates.
       
       
    • By Ronyx69
      So I was recently looking at some Japan driving videos and got inspired to make some highway pillars.
      I'm planning to make an entire set of various types of pillars in this style, even a 6cell over-canal pillar. (if it goes okay)
      Tell me what you think about my first attempt, I need to nail the style and the details before I start making other variations.
      Constructive criticism welcome, also any ideas.
      By the way, do pillars have LODs like regular buildings? I should just make it just the pillar, without the small details - pipe, wires, supports.
      Not sure when they're going to be done and available.

       


       
    • By alborzka
      This thread will focus on improving and revamping the Transport Lines Manager mod, as well as potentially adding features from IPT and/or unique new features if possible.
      Transport Lines Manager Reborn 6.0.1 now in the workshop.
      Bugs as of 6.0.1:
      Renamed depots are not working in the TLM listing and in depot details windows. Bus stations and terminals are wrongly listed as depots. Not show cable car stations on linear map as near transport. Ticket price changes not being implemented. Sort lines by colour not working. OP is below:
      The creator of IPT hasn't been online in over 5 months, and the creator of TLM hasn't been online in nearly 1 month. Mass Transit DLC is coming out in a few weeks, and I don't know how either of these mods will fare with changes being brought to the transit system.
      Is anyone in touch with either of these authors? I would especially hate to see TLM go to the dustbin of modding history considering how many options and useful configurations it provides (plus the aesthetics!) such as changing frequency depending on time of day (such a no-brainer), and IPT has excellent debunching. Now that these two mods are nearly incompatible, and with the DLC coming out soon potentially rendering both useless, something must be done. They're far too valuable to go to waste.
      If we can't get the authors to update their mods or publish their code for others to carry it forward, can we all maybe pitch in and create an entirely new mod from scratch? Is someone working on this already? Even with the improvements being brought with the free upgrade/DLC, I feel TLM/IPT features will still be vital to many player's C:S experience. What do y'all think?
    • By Armesto
      So, with the addition of blimps to the new expansion, I made a real scale Graf Zeppelin. It's my first time with a vehicle and weird stuff is happening.
      First, vanilla motors seem to be in the model and I don't know how to remove them (also the lateral screens, but they are hide inside the model, so is not a problem). 

      Second, my motors don't spin as they should, only two of the four rotate, and they do it in the direction of wheels...

      Any idea on how to solve this?
    • By AmiPolizeiFunk
      I'm really happy that the Asset Editor got some improvements. Most importantly, it seems to be much more stable now! I can do things now without crashing that would have crashed me 100% of the time previously. I can even use the Asset Editor without unsubbing to my 1000+ assets and 30+ mods. Previously, this was unthinkable. It's still sluggish, but it's actually use-able. In -noWorkshop mode, I can do "New Asset" after importing an asset without crashing, which I could never do previously.
       
      We also have some new options in the building stats window, particularly a dropdown list of monument templates (and one called "always unlocked" that doesn't have silly requirements) instead of the binary "use monument template" button that we had previously.
       
      And ofc now we can mod citizens. I'm really looking forward to some new folk to populate my world. Is anybody working on any new cims yet?
       
      Are there more changes that I haven't noticed?
  • Recently Browsing   0 members

    No registered users viewing this page.