• Moose
  • Announcements

    • Dirktator

      Need your donations for May & June!   05/01/2017

      We need your support to help keep Simtropolis online. We also need a little bit more this month to enhance the new chat with some features, such as mobile support! Please consider a donation today if you can help out, it would mean a lot! And we'll send you a little gift in return.  Help us reach our May goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
    • Dirktator

      About our affiliation with GOG.com   05/23/2017

      Simtropolis is now an affiliate of GOG.com! When you use one of our affiliate links to GOG.com, all it means is that Simtropolis has a chance to earn a small commission from any purchases you might make. So if you see something that tickles your fancy, please use our affiliate links and by doing so, you'll help support Simtropolis! Thanks!
R3V0

REV0's - INNOVIA 200 (Las Vegas Monorail) WIP

392 posts in this topic

20 minutes ago, alborzka said:

Nice work! I'm assuming the modular train station project will replace the Grand Central Station?

It will. I'm planning to use its extensions at some point but not the main building. 

Using the same post in order to give final output regarding to the office building. It's finished and ready to release at this point. 

l0Bh2im.png

GkxCNyo.jpg

ElUf96b.jpg

Z5ogoAl.jpg

[sketchfab]4ccfa524ad294710a70b9e52b3212d0e[/sketchfab]
ULTRAHUB - Office Extension, Variant 1 by R3V0_76 on Sketchfab

 

Share this post


Link to post
Share on other sites

Final shots before the release of train extension modules: 

1. I need to fix some pathway issues with closed roof variant.

2. Assets are bending through the terrain, since I have to use fence shader, i'll count it as a glitch. 

3. Wave roof concrete stairs has some issues that I couldn't fix on the Blender, texture is fine, so I count it as a game issue. 

I intentionaly left roofs as clean as possible, so the end-user can add decorate it with whatever he wants, same goes for modules. I am planning to release a prop/logo pack with important train transport companies following the release. 

I created 2 combinations for shots: 1. Closed roofs only, 2. Open, wave combined. 

BbswBvT.png

cfjDWZR.png

cOgEANy.png

KWJiJ0b.png

qyHeMpe.png

SolP6OL.png

D4d9pa8.png

mJOVQWF.png

Share this post


Link to post
Share on other sites

Question to those who are interested with the project: 

I'm not sure how but, would you prefer to have all modules under train section (i'll try to use asset category changer mod for it) or should they be in their specific places (metro module to metro, tram to tram etc.)

I'd kill for a specific tab only for ultrahub on the game buildings menu (or ability to put all modular stations on workshop into one single tab) would be nice. 

Also, is it possible to shade underground AND disable building to conform according to train ? 

I'm using fence shader to texture underground and the thing is, building is bending to the ground... 

Share this post


Link to post
Share on other sites
57 minutes ago, R3V0 said:

Also, is it possible to shade underground AND disable building to conform according to train ? 

I'm using fence shader to texture underground and the thing is, building is bending to the ground... 

 

R3V0 likes this

Share this post


Link to post
Share on other sites

It looks so awesome! I'm not sure about the tabs... It would feel weird to have a tram module in a train secton but on the other hand it probably wouldn't really be used on its own, which means having to switch tabs 100% of the time... A possibility is to put "MTT" or something in all the descriptions so that everything would show up with Find it!, but that's counting on a mod... I'm not playing the game enough to have a relevant opinion about it though...

Dezelles and R3V0 like this

Share this post


Link to post
Share on other sites

I would let all the stuff in the train tab as it is one station. I did the same thing when I created MoM stations for other modular stations available in the workshop.

The reason I choose this approach is that I did not want to switch tabs while building the station.

But if you are creating unique icons for the whole set of assets that makes it very easy to identify the moduls in their respective tabs - thats also a possible way to go.

 

At the end of the day its just a question of "taste".

 

Share this post


Link to post
Share on other sites
10 hours ago, Ronyx69 said:

 

That worked, mostly: 

While it worked fine on one asset, it causes glitches with the texture on this asset: 

veILsp0.png

Share this post


Link to post
Share on other sites
3 minutes ago, R3V0 said:

That worked, mostly: 

While it worked fine on one asset, it causes glitches with the texture on this asset: 

Not sure what's the glitch.

Probably something to do with having stuff at 0. It still generates some kind of weird semi-base mesh stuff if faces end right at 0 so move stuff a bit up or down from 0.

Share this post


Link to post
Share on other sites
2 hours ago, Ronyx69 said:

Not sure what's the glitch.

Probably something to do with having stuff at 0. It still generates some kind of weird semi-base mesh stuff if faces end right at 0 so move stuff a bit up or down from 0.

It was the different texture on the tunnel entrance. Anyhow, I fixed it by remodeling the edge, as you suggested. 

In other news as Ronyx helped, once more: 

9b3DoBQ.png

Totaly possible. Trick is to plot tunnels with -14m deep + 2 units of ramp from -14 to -10 and usual tram track. 

Now I'm thinking to make it properly, but not sure how to release it. 

a) Release an empty platform, so the end user add tram, bus roads and through-train track (no station stops) 

OR

b) Make one platform for tram and release as "ready to plop" asset, same for bus (bus idea just came out, i was planning to model a bus terminal before) 

Share this post


Link to post
Share on other sites
33 minutes ago, R3V0 said:

a) Release an empty platform, so the end user add tram, bus roads and through-train track (no station stops) 

OR

b) Make one platform for tram and release as "ready to plop" asset, same for bus (bus idea just came out, i was planning to model a bus terminal before) 

I vote for A

R3V0 likes this

Share this post


Link to post
Share on other sites
5 hours ago, Ronyx69 said:

Not sure what's the glitch.

Probably something to do with having stuff at 0. It still generates some kind of weird semi-base mesh stuff if faces end right at 0 so move stuff a bit up or down from 0.

yeah it's this. had the same thing happen with sotunder

R3V0 likes this

Share this post


Link to post
Share on other sites
3 hours ago, R3V0 said:

It was the different texture on the tunnel entrance. Anyhow, I fixed it by remodeling the edge, as you suggested. 

In other news as Ronyx helped, once more: 

-img snip-

Totaly possible. Trick is to plot tunnels with -14m deep + 2 units of ramp from -14 to -10 and usual tram track. 

Now I'm thinking to make it properly, but not sure how to release it. 

a) Release an empty platform, so the end user add tram, bus roads and through-train track (no station stops) 

OR

b) Make one platform for tram and release as "ready to plop" asset, same for bus (bus idea just came out, i was planning to model a bus terminal before) 

I'd prefer a version with a tram track pre-installed. Perhaps you could use the tram station track from the tram station track mod? And perhaps somebody could create a sunken tram station track, although that might be very specific and quite far out.

R3V0 likes this

Share this post


Link to post
Share on other sites

Update: I hit another snag, this time pathfinding. 

I want peds use the platforms above the tracks. In order to do that I need to plot ped connections. While it works above train track and peds are following it almost without problems, putting a tram or bus stops distrupts nearby ped paths. The problem is, the ped path of the, let's say train tracks, snaps directly to the tram or bus road, causing erratic behaviour for peds. 

Is there any way to fix ped paths where they are ? I need them not to bend or snap to anything 

 

Share this post


Link to post
Share on other sites

Make sure that the path network nodes are far away from the tram tracks. I experienced similar problems when I made my sunken train station.

R3V0 likes this

Share this post


Link to post
Share on other sites
50 minutes ago, boformer said:

Make sure that the path network nodes are far away from the tram tracks. I experienced similar problems when I made my sunken train station.

Tried it now, still doesnt work, ped paths I created on the bridge still snapping to the tram track, despite the fact that nodes are 90units away. The height difference is 9m doesnt change a thing. I found the solution by turning tram and bus modules into 4 unit wide, that way 1 unit from each side remains free, no bending. 

What I now have is this: 

Some peds are "jumping from the first floor" to reach the ground floor. I don't know it this can be fixed too, because some peds are following the stairs and turning back while others, well they suicide from 10 meters. 

8qayEwe.png

Share this post


Link to post
Share on other sites

Check to make sure that you don't have duplicate ped paths, and also make sure that snapping is OFF when you place the ped paths. :P Sometimes if you have ped paths too close together it causes problems.

R3V0 likes this

Share this post


Link to post
Share on other sites
3 hours ago, R3V0 said:

Some peds are "jumping from the first floor" to reach the ground floor. I don't know it this can be fixed too, because some peds are following the stairs and turning back while others, well they suicide from 10 meters. 

That's fine.

Share this post


Link to post
Share on other sites

Update: Wasted 2 days and still ped paths are not working properly. 

I tried many different combinations but still, it doesn't work. I just can't connect to modules next to each other and let peds use bridges. 

Ped connection of an individual module is working. 

When they are stacked, no one uses bridge. All peds are preferring connections on either side of the platform. The issue is not a choice, central bridge, for whatever the reason is not working when modules are stacked. 

Since I made another modular station before and it was working just fine, I suspect the problem is related to the game; modular sunken/underground is just impossible to make.

This is the ped path on one of the modules. When it's plopped single, these paths are operational. When they are stacked, the one except the one snapped to the roads, none of them receiving any passenger. Same is also valid for the main building, which doesnt have paths so tight, building-module access is not working either.

All ped paths are surface on the module below, I tried different combinations like connection for the center piece and surface for others, or without the center one etc. none of them so far is making it working.

I'm out of ideas.  

4LH7p3h.png

Share this post


Link to post
Share on other sites
6 hours ago, TransitAuthority said:

Check to make sure that you don't have duplicate ped paths, and also make sure that snapping is OFF when you place the ped paths. :P Sometimes if you have ped paths too close together it causes problems.

regardless of snapping on or off all embedded ped paths snap to any other ped paths (either road path, or train platforms etc)

Share this post


Link to post
Share on other sites

@BadPeanut Oh, I didn't know that. Well, then I would try maybe deleting one ped path on each side of the bridge (ex. 2 escalators on one side, delete the ped path on one of them).

Share this post


Link to post
Share on other sites

I'm not totally sure how you're achieving your modularity (haven't kept up on your thread) but it doesn't look like you're using the same method as me - which i think i can get working as a modular undergound station. i think maybe with a bit more trial and error you may still get there with your way. it often is just a fluke if you can get the ped paths to stay exactly where you want them so keep that in mind.

Share this post


Link to post
Share on other sites
Just now, Bad Peanut said:

I'm not totally sure how you're achieving your modularity (haven't kept up on your thread) but it doesn't look like you're using the same method as me - which i think i can get working as a modular undergound station. i think maybe with a bit more trial and error you may still get there with your way. it often is just a fluke if you can get the ped paths to stay exactly where you want them so keep that in mind.

I'm using a gravel road on the right end side of the modules, so they can be snapped. I used only surface, then connection on edges etc. on different variants but it's not working. Inside is a no go, since peds are invisible. 

I did a further test but this time with default shader (so no nobase thing), nothing changes; when alone the module is working but when it's stacked peds don't use modules which are not connected to the road. That leaves only clipping terrain as a variable. I didnt clip terrain when I made Grand central and it's module and it was working. So a modular train station which ped paths are going underground is not gonna work. 

Are you using anything different than adding extra piece to connect them, some modtools code change ? 

Share this post


Link to post
Share on other sites
38 minutes ago, R3V0 said:

I'm using a gravel road on the right end side of the modules, so they can be snapped. I used only surface, then connection on edges etc. on different variants but it's not working. Inside is a no go, since peds are invisible. 

I did a further test but this time with default shader (so no nobase thing), nothing changes; when alone the module is working but when it's stacked peds don't use modules which are not connected to the road. That leaves only clipping terrain as a variable. I didnt clip terrain when I made Grand central and it's module and it was working. So a modular train station which ped paths are going underground is not gonna work. 

Are you using anything different than adding extra piece to connect them, some modtools code change ? 

no i don't change any code at all and anything visual (like shaders and clipping ground) doesn't affect your ped paths, only other networks and the height settings do

Share this post


Link to post
Share on other sites
1 hour ago, Bad Peanut said:

no i don't change any code at all and anything visual (like shaders and clipping ground) doesn't affect your ped paths, only other networks and the height settings do

Are you changing any values of the default station ? Aside mainetance etc. 

So far: 

* Clipping is not an issue, I ''unclipped the bridge part, only works for 2 modules, 3rd one doesn't work. 

* Didn't play with the lenghts of ped paths so I didn't use Move it tool that time, it didn't work either. 

* I extended pads from 2 tiles of width (pads are reaching 4 units of width), that one didn't solve it either. 

* Different ped types don't work either, or at least after 2 modules, passenger can't reach beyond. (Not that they don't want to use, they can't reach)

At this point I'm gonna say it's impossible to make modular underground station because whatever I applied to make a modular station above ground level, doesn't work here. 

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, R3V0 said:

Are you changing any values of the default station ? Aside mainetance etc. 

So far: 

* Clipping is not an issue, I ''unclipped the bridge part, only works for 2 modules, 3rd one doesn't work. 

* Didn't play with the lenghts of ped paths so I didn't use Move it tool that time, it didn't work either. 

* I extended pads from 2 tiles of width (pads are reaching 4 units of width), that one didn't solve it either. 

* Different ped types don't work either, or at least after 2 modules, passenger can't reach beyond. (Not that they don't want to use, they can't reach)

At this point I'm gonna say it's impossible to make modular underground station because whatever I applied to make a modular station above ground level, doesn't work here. 

 

 

 

I don't think changing those values will do anything, obviously i have custom maintenance and costs and if you have any buildings that when you remove the road don't have road access you'll want fire risk at 0, garbage at 0 and all workers set to 0 to avoid any "too many problems" pop ups
sounds like you've given it a good go anyway! good luck with the rest of modules!

R3V0 likes this

Share this post


Link to post
Share on other sites

Proposal: create the bridge in sub-building. It could maybe function as a ground building.

Share this post


Link to post
Share on other sites

Update: 

After numerous combinations I tried this morning, I confirm that it's impossible to achieve modularity with surface to underground access through sub buildings.

I did manage to get modules working modules but it will require remodeling of main building and platforms. I am not sure how to get tram working since it's always bending the ped connection, i'll try to figure something out. 

s8yQwNt.png

 

Share this post


Link to post
Share on other sites

What solution did you figure out for trains. More space between the path over the tracks and the stairs downwards?

Share this post


Link to post
Share on other sites
7 minutes ago, rovapasi1 said:

What solution did you figure out for trains. More space between the path over the tracks and the stairs downwards?

Under tracks. 

I'm not a "modder" but after doing like hundred tests 3 days straight, I came to conclusion that the game doesn't recognize a starting point for ped paths not connected to the ground. The start point has to set to 0, otherwise peds will not take the initial path. After that, in order to make it work (at least under the ground), as module must have "open" paths on edges so passengers can jump into them. Modular station on ground is different than underground, I found it the hardway. 

Share this post


Link to post
Share on other sites

I was playing around with a ground station. There the ped paths connected from one plattform to another even they was above 0. But as you stated before this seems to be the case for your station as well, as long as there was only two modules.

EDIT: As far as I remember I never tried three. :-(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By Mr_Maison
      Hello everyone. This will be my custom content showcase and workshop thread. In all the years I been a member here, I never uploaded any content but enjoying great work by other members. I take this opportunity to say Thank You to all content makers for making our city building experience so enjoyable. I feel that making content is overdue for me and I want to give back to the community. I have some buildings and trees that I will be showing in upcoming updates to this thread. I will also be asking for advice and help.
      5/25/2017 Release: Wooden Box Planter Link http://steamcommunity.com/sharedfiles/filedetails/?id=932855630

       
      And with Tulips

       
      More info on last pages of this thread.
       
       
      Note: This post was edited 5/29/2015 to reserve this first post for all current updates.
       
       
    • By Sparks44
      How do we import models to be used as citizens. I see the template but none of my models work.
      I imagine this could have a lot of potential, maybe we could have cities full of aliens, or very fast zombies. Or maybe lots of bloody penguins, roaming the streets. Although you have to have a mod that lets you select what citizens you want. Otherwise the penguins would be amongst normal citizens. I've already made a zombie prop. I like to know how to put him in my city?
      Also does anyone know if we have access to the vanilla main citizen models and not just the lods, so I can dump them?
    • By Lee Towers
      Hey all! I've been following this forum for a while now and all your amazing creations inspired me to start building assets myself. The first building is almost finished - a 3 track train station, as seen below (props for the person to recognise the station it's based on). I still have a few problems with it though, so bear with me:
      1. The game is creating floors inside the building on its own. There's not even a vertex with the same z-coordinate where it's creating an xy plane inside the building. Is this something that's generated on purpose by the game? The floors are assigned the same textures as the roof of the building. They can be seen through the windows and are positioned about halfway behind the windows.
      2. My sims are not using the third platform. I'm using the single station track with a platform on the left side of the track (relative to the direction it was laid). I thought it had to do with the pedestrian connections that I've laid down, but they are using the second platform which is accessed by the same pedestrian connection.
      3. Speaking of pedestrian connections... I'd much prefer a rendered underground tunnel to the half-assed building I have there now but the game isn't letting me (it pushes the whole model upwards). How do I go about doing that? I know Joak uses them in his train stations, how did he do that?
      Any help regarding one of these questions would me much appreciated! Feedback on the model is also welcome by the way... it's my first time using blender and gimp. The textures aren't final either (mainly the roof and supports need work) but I've yet to learn how to use bump maps.

    • By Skibitth
      Hey guys!
      I come back with another custom build! This time is an old wooden train bridge
      Hope you will enjoy it!
       
      Cheers!
    • By Babyhead Gaming
      Cities Skylines British Themed  with Babyhead Gaming and we are back with a NEW season of British City with the new DLC that has been released with Cities Skylines . Here in EP1 we start out with a very humble start unlock a few starter Milestones. I know I am new here I only just found this website ( I know I must been living under a rock or something ) . Scroll down for more screenshots and videos , uploaded daily . 
       
       
      [/media]
       
       

  • Recently Browsing   0 members

    No registered users viewing this page.