• Moose
  • Announcements

    • Dirktator

      Help us with our donation goal for a new Chat upgrade!   04/17/2017

      Your donations not only help keep the site up and running, but also allows us to expand some functionality and upgrade other features of the site periodically to stay current! We're looking for some community support to help us get a new Chat system (as you know our old Chat is no longer supported by IP.Board). A new system promises to give us many more options and all for fairly little cost, relatively speaking. Please help us reach our April goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
Cyclone Boom

bugs
Simtropolis 8.1.x - Bugs & Issues Report Thread

382 posts in this topic

The "Table" function is broken too.  You can't edit existing tables and the link in the edit window to creating a new one is gone.

A Nonny Moose, my issue has nothing to do with mosaics.

 

David

Share this post


Link to post
Share on other sites

Well, I tried.  Seems the editor is under continuous revision.  I note the preview button has disappeared as well as the image button.  Are we sure this game (upgrade) was worth the candle?

Compdude787 and _Michael like this

Share this post


Link to post
Share on other sites
On 12/14/2015 at 8:31 AM, A Nonny Moose said:

Well, I tried.  Seems the editor is under continuous revision.  I note the preview button has disappeared as well as the image button.  Are we sure this game (upgrade) was worth the candle?

I agree. I don't see the point of this whole upgrade. I mean, the old site (ST7) looked fine. Heck, it still looked pretty modern IMO. There was NOTHING wrong with it and this "new" version doesn't work as well. And also, the old chat was better too! Sorry to rant, but I really hate it when websites upgrade their interface for no apparent reason.

Share this post


Link to post
Share on other sites

A short question: Do you still fiddle around with the image handling of the site, or is it safe for me to start fixing all those images that now have wrong aspect ratios (only the width is shrunk by the page, not the height) as a result of the update?

Share this post


Link to post
Share on other sites
15 hours ago, Turjan said:

A short question: Do you still fiddle around with the image handling of the site, or is it safe for me to start fixing all those images that now have wrong aspect ratios (only the width is shrunk by the page, not the height) as a result of the update?

Hmm, so posted images are out of proportion? Could you please give an example of where this has occurred?
 

6 hours ago, raynev1 said:

Though not a bug or bad issue , I do miss the back to top button on the bottom of the pages . Best wishes .

Yes, this functionality can be added back. For now, something like this browser addon might be useful as an alternative.

------------

Dirk's been a little busy the past week, so hopefully the issues can be sorted very soon. Again, thanks all for hanging in there! ;)

raynev1 and _Michael like this

Share this post


Link to post
Share on other sites
4 hours ago, Cyclone Boom said:

Hmm, so posted images are out of proportion? Could you please give an example of where this has occurred?

One example is in this CJ post. Several of the images are out of proportion, but look okay when you click on them. I first noticed it in my own CJ, in this post . I went already ahead and reinserted the first and the last image, but there are still two examples in the spoiler tag, although you cannot click on the images in the spoiler tag.

I hope the links work, because in the CJ, only the first link in the first post works.

Share this post


Link to post
Share on other sites

Another example of out of proportion images is my last entry in the desktop image thread over in General Off Topic.

Share this post


Link to post
Share on other sites

Thanks, confirmed.

After checking the HTML source, it seems these images are defining a height value. When images resize based on the available page width, they maintain the height, but are scaled accordingly.

For example:

<img alt="image.jpg" style="height:720px;" src="http://s17.postimg.org/ahk28j2pr/image.jpg"></span>

Compared to another image:

<img alt="image.jpg" src="http://s17.postimg.org/x3ks7ir27/image.jpg"></span>


It's interesting how this affects some images and not all (including ones in the desktop thread). At first glance, it seems like larger images have this in common. Unaffected images don't have this set height value, so can resize in proportion to the page.

Share this post


Link to post
Share on other sites
Quote

Missing editor functions:  Insert image, YouTube, post preview, tables.

These are simtropolis specific customization and will be restored soon, we had to work out a few other issues first.

 

Quote

Homepage Features slider is frozen, only showing the latest submission.

This is now fixed! You may need to force-refresh your browser or clear your cache.
 

Quote

News articles block not shown on the Homepage (articles still are still there in the news index).

News articles are temporarily on the home page sidebar. We need to update some templates to have them show on the home page like they did before (I just haven't found time yet but I'll get to it!)

Quote

Missing numerical rating values on STEX uploads and Gallery images.

Will add this back in shortly.
 

Quote

Staff directory page does not open.

Seems to be a bug, still working on it.
 

Quote

Missing "go to top" arrow.

This has been Fixed! Again, a force refresh may be necessary. (CTRL-F5 usually)
 

Quote

Not all theme colours are shown:
E.g. Unread forum icons have reverted to the default colour (light blue). Also on some areas like the Account Settings page.

Theme restoration is in progress!

Quote

In the search menu, "Submissions" is listed twice (possibly a cosmetic issue only).

These are "news submissions" and "feature submission" but they should be better identified!
 

Quote

 

Likely to need further testing:

  • Possible issue with CJ entries occasionally not shown in the correct order.
  • Possible issue with streams and content listing order.

 

Working with my admins through these, we'll get it straightened out!

Cyclone Boom, SimCoug and _Michael like this

Share this post


Link to post
Share on other sites
8 hours ago, Cyclone Boom said:

It's interesting how this affects some images and not all (including ones in the desktop thread). At first glance, it seems like larger images have this in common. Unaffected images don't have this set height value, so can resize in proportion to the page.

Thanks for looking into this. These differences are probably not coming from the source though. All my images were 1080p (except the intro banner), come directly from the Steam screenshot function (no editing), and all of them have been individually uploaded to imgur, one after the other. Nevertheless, they behave differently.

One other observation though: None of my newest CJ entries has the problem. This may have been a one-time issue that was introduced during the first update. That's basically the reason why I asked whether it's safe to fix those now.

Cyclone Boom likes this

Share this post


Link to post
Share on other sites

A quick note.  When I post my image for the desktop thread I accept the image default, so how the height gets set I have no idea.

Yet again allow me to complement Dirk and the team for doing yeoman work under the need to keep a 24/7 site alive and well.SmilieCanada.gif

Cyclone Boom likes this

Share this post


Link to post
Share on other sites
On ‎12‎/‎19‎/‎2015 at 9:43 AM, Cyclone Boom said:

It's interesting how this affects some images and not all (including ones in the desktop thread). At first glance, it seems like larger images have this in common. Unaffected images don't have this set height value, so can resize in proportion to the page.

I somehow managed to get a mix of such resized images in this old post in the "Did You Know" thread.  Images 1, 2, and 3 cannot resize proportionately, while the images 4 and 5 can.  Images 2 and 3 were originally oversize from their sources and I had manually set their widths in the previous incarnation of the Insert Image dialogue box.  Images 4 and 5 were originally at 800px wide, once upon a time our max standard, and I had left them as is.  Image 1 was undersize, but I may have peeked at or tinkered with the width and height settings while composing as a guide for setting images 2 and 3.  I may be wrong, but I seem to vaguely remember that the previous Insert Image dialogue box would not necessarily auto-fill both fields for width and height until the preview had fully loaded and then you actually clicked into one of the fields, such as when manually entering a custom width.

In the "Show Us You Desktop" thread, in this older post I used images originally sized and uploaded at 800px wide, which did not require additional width or height customization, and are not affected by the inability to be proportionally resized.  However, this later post, composed entirely the same way with the same type and size of images uploaded to the same source, does have this bug.  In this even later post, I had started using larger images after realizing others were commonly displaying in-page images with a width of 1024px, and the images in that post are now affected by this resizing bug.  Also, they no longer display in-page with widths of 1024px, but at a max of 1004px with additional link framing.

Amusingly, this post by A Nonny Moose also in the "Show Us Your Desktop" thread is affected by the non-proportional resize issue, and, in a follow-up quoted reply by matias93, the miniaturized quotation of that image is affected as well.

Technology works in mysterious ways!

 

Cyclone Boom likes this

Share this post


Link to post
Share on other sites

^ Uh-uh!  Computers don't argue.  They do what they are told and if they find they are sick they usually just halt.  Some bug is pooping in these images.  This kind of thing is usually caused by some "programmer" who means well but doesn't understand what he is doing.

One of the biggest problems we have these days is we have conveniently decided to use languages that generate code instead of slugging through the basic stuff.  In this case we are at the mercy of whoever wrote the generator and failed to document it well.  Imagine having to write a site like this in XML or even HTML.  It would take years, and then you still have to debug it. 

In the bad old days, everyone wrote in machine code and two other people desk checked it, but programs were much smaller and far less complex.  This was before assembler programs existed.  Before this, you got to wire the program into a plug panel, then along came John von Neuman.  We should consider ourselves very lucky that we are not still wiring panels.  (These panels are where the original term "bug in a program" came from.  Everyone should know the story.)

Cyclone Boom likes this

Share this post


Link to post
Share on other sites

Quick update:

The staff directory page has now been fixed, and other layout/design areas are being worked on.

Please continue to inform us of anything not as it should be.

Thanks all!

Share this post


Link to post
Share on other sites

I just encountered this weird behavior that I mentioned on last page again, and this time I have a screenshot.

hIvrxp1.jpg

Basically, after I fiddle around in the quote box, like deleting part of the quote, typing the answer yields text with letters in reverse order (or differently put, the input field doesn't move). Not a big deal, as you can just go out of the answer box and back in again, and it doesn't always happen, but I wanted to at least show that I wasn't hallucinating.

Share this post


Link to post
Share on other sites

6 null

6 null Relating to the text editor:

  1. There is no change font option. As of now I have to copy/paste every time I wish to post, and sometimes for every paragraph. May be temporarily disabled, but I would like to know if it will come back soon.
  2. Typing in the text editor produces weird results. Every once in awhile Quite often, "6 null 6 null" will appear at the beginning of a sentence or post and insert itself at random times. (6 null 6 null Every instance of the phrase I mentioned 6 null 6 null appeared automatically with the exception of the link). It seems to happen more often when I edit inside of a sentence, like I did above.
  3. Similarly, many times after pressing a certain letter (haven't quite nailed down which one yet), google gives me a pop up telling me to choose a region.
  4. Occasionally when I press the letter 'T' while typing a word, a new tab will open promoting me to 6 null share the link on Twitter, which I do not use at all.

 

I do not know if other users have had these issues, but for me, the text editor is quite broken.

Share this post


Link to post
Share on other sites

Insufficient information.  What browser are you using?  Sounds like a beta of Chrome.  Try Firefox.

Share this post


Link to post
Share on other sites

I've restored a few missing formatting options.

Still waiting on tech support to assist with the deeper issues. Again apologies this is taking longer than anticipated.
 

@nos.17

That's strange, has anyone else noticed that?

Browser and version would be useful, and I'll try a local test.

Dirktator and Turjan like this

Share this post


Link to post
Share on other sites
21 hours ago, Cyclone Boom said:

That's strange, has anyone else noticed that?

Browser and version would be useful, and I'll try a local test.

Sorry about that... using Chrome  47.0.2526.106 m , all up to date. I know (almost for sure)  that the Twitter problem was the result of an out-of-date/malfunctioning chrome extension; the others probably are related too. I disabled and reinstalled it and everything seems to be in order (for now). 

 

Thank you, by the way, for re-enabling the rest of the text formatting features. :)  I really do appreciate how difficult it can be to work with websites...especially one as large and complex as this.

Cyclone Boom likes this

Share this post


Link to post
Share on other sites
On 12/31/2015 at 11:52 PM, Cyclone Boom said:

I've restored a few missing formatting options.

Thanks. The spoiler tags had been gone during a few days, and they are back now.

Cyclone Boom likes this

Share this post


Link to post
Share on other sites

The advertising one liner after the first topic is now good an obsolete.  If Origin is still paying for this, the dates should be changed.  If they are not paying, it should be either sold to somebody else, or taken down.

Share this post


Link to post
Share on other sites
20 hours ago, Sabretooth78 said:

Not a bug, per se, but the banner image still reads 2015.

It usually takes me about two or three weeks before I finally acknowledge that a new year has passed too...

Share this post


Link to post
Share on other sites

Was just searching some content images in the gallery and a few pages in the STEX and was getting some intermittent Error 524: Host Errors on connection. Not sure if this is just a connection thing resetting, since refreshing the page worked out after the failed attempted. Just wanted to leave a note on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By TekindusT
      I was just taking a look to the Milestone thread and realized I have no idea what those stars under our usernames and ranks in the forums mean. Sure they have a logic behind but it's a bit difficult to see for me, except that the users with most posts have their first star inside a shield or inside a banner...? But why some users with less posts have 5 stars and others have only 1 but the first one is shielded... ? Are they tied to our post count? You get it. Any Simtropolite ready to shed some light on this matter for me?
    • By manueld832
      So I started building RHW(new to RHW btw) to reduce regional traffic then I notice that the trucks are constantly changing lanes or doing a zigzag movement........please help!!! 
      Here's a photo https://www.dropbox.com/s/6gij4k6il26idqj/20170329_232144.jpg?dl=0
    • By mike_154
      i want to donate money to you guys,for your great work here at simtropolis, but i can not because paypal is not responding.Why dont you guys make an open pay system for credit cards,then we do not need this hassle. 
    • By Cyclone Boom

      Our friends at GOG.com had a special City-Builder discount sale!  (Closed as of February 13, 2PM GMT) 

      As part of this, Simtropolis has been given a bunch of free keys to selected games to give away!
      Winners announced here!

      If you want one of these games, simply reply to this thread by answering ONE of the questions below:
      What's your favourite city-building game, and why will you always be fond of it? Write a creative and entertaining review (good or bad) of any city-building game. The ways in which custom content has transformed the city-building game you play. Tell us about your most memorable city-building experience, funny, tragic or otherwise.
      There is no minimum or maximum, but aim to write at least 50 words.
       
      FAQ

      Q: How are prize winners selected?
      A: The Admins will pick their favourite replies below, so don't delay, post away!
      Q: How many times can I reply?
      A: Just one reply per person please.
      Q: Can I add images or video to my post?
      A: Sure! Feel free to be creative to make your post stand out.
      Q: Does it have to be written in a certain style?
      A: No, not at all. Just aim to make it creative and entertaining, whether fact or fiction...
      Q: How long does this run for?
      A: The closing date to enter is Monday 13th February at 23:59 (EST).
       
      Prizes

      Winners will be able to select ONE of the following City-Building classics, to add to their personal collection:
       
      Caesar
      1993

      SimCity 2000 Special Edition
      1995

      Caesar II
      1995

      Pharaoh + Cleopatra
      1999

      SimCity 3000 Unlimited
      2000

      Emperor: Rise of the Middle Kingdom
      2002

      Banished
      2014

      Tropico 5
      2014

      Lethis - Path of Progress
      2015

      Urban Empire
      2017

       
      Whatever your experience with a City-Builder, we'd love to hear it.
       
    • By Cyclone Boom
      Got some ideas?
      Here's a place where you can recommend any improvements to Simtropolis. 
      It's about time we had one of these. Even though the site continues to develop, we'd love to hear your thoughts on how it can be further refined and made better for everyone. Whether it be a simple layout/design tweak, or a completely brand new feature, post away in this thread!
      While we can't promise everything will be possible or implemented, each idea will be read and considered. I'm sure you'll appreciate there are limitations, both technically and financially.
      To report any issues with an existing site feature, or something not working as intended, please instead use the Bugs Thread.
       
      Guidelines
      For clarity, please keep one idea per post. Double posts are acceptable if you've more than one idea at once.
      Note: To prevent successive replies from auto-merging, you may need to wait 5 minutes.
        Give a subheading, describing briefly what the idea is.
        Explain the idea -- it helps to give as much detail as possible. Pictures or diagrams are acceptable, but not required.
        Why would this be of benefit to the community?
        If you value anyone's idea, please Like it to show your support. This helps to give a rough indication of how well an idea is received.
        If commenting on an idea, please quote/copy the subheading so it's clear what is being discussed.  
      Progress Status
      Once processed, ideas will be tagged with one of the following:
       
      NOT PLANNED -    The idea is appreciated, but at this stage, is not feasible to implement.
        INTERNAL REVIEW -    We like the idea, and will pursue whether it's currently feasible to implement.
        PLANNED -    We have decided to implement the idea, and are finding the best ways to go about it.
        IMPLEMENTED -    The idea has been added as a new site feature!
      This will change depending on ongoing progress with implementation.
       
      Thanks all!
      -The Admins
  • Recently Browsing   0 members

    No registered users viewing this page.