• Moose
  • Announcements

    • Dirktator

      Help us with our donation goal for a new Chat upgrade!   04/17/2017

      Your donations not only help keep the site up and running, but also allows us to expand some functionality and upgrade other features of the site periodically to stay current! We're looking for some community support to help us get a new Chat system (as you know our old Chat is no longer supported by IP.Board). A new system promises to give us many more options and all for fairly little cost, relatively speaking. Please help us reach our April goal so we can keep bringing you site improvements as well!  Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
Cyclone Boom

bugs
Simtropolis 8.1.x - Bugs & Issues Report Thread

382 posts in this topic

I have occasionally had this problem with Firefox as well, but it seems to be transient and having to do with maintenance on this editor.  If the worst comes to the worst, you can just insert the text of the URL in the post and this is recognized as a link.

Share this post


Link to post
Share on other sites

Also noticing this intermittently on Firefox. If you refresh the page you're on, I've found it usually works on the reload (with post data auto-restored).

Hopefully it will be fixed in the next board version, as it will improve the editor's performance:
 

Editor updates

  • Uses div-mode which is much faster and more reliable. Clicking into the editor is now pretty much instant.
  • Auto-linking and member mentions to use new APIs for better reliability
  • Quotes, code boxes, and spoilers can be dragged and moved and there is no more "red line"
  • When cmd/ctrl right-clicking: options to remove or break-out of quotes, edit links and edit image properties
  • Pasting asks if you want to convert to plain text
  • Totally new code plugin with syntax highlighting as you type
  • Option to make enter behave as a new line rather than with spacing
  • Editor is responsive, and ability to have small editor show in areas with less space
  • Member @mentions in posts can now be selected by tab key

 

Share this post


Link to post
Share on other sites

I've had that happen occasionally.  The work around is to just drop the URL into the post.

Share this post


Link to post
Share on other sites

After a recent mention on the forums, I looked on the STEX Mods & Tools at the SC4DataNode v0.94 by rivit.  Clicking on the pink "Download this file" button brought the familiar multiple download popup, but this time with something unusual:

lPGRpqu.jpg

There is a second mysterious file being offered for download in the *.ipb form.  I do not know what an IPB file is and I've never seen it before on the STEX...Google suggests IPB is a Perl script for the Apple iPhone and iOS apps.  Gobbledygook names on mysterious script files in our downloads raises red flags.  Alarmingly, a Google search for "ipb perl" brings up as top returns illicit guides for injecting IPB trojan exploits to hack into forums, particularly mentioning those using IP.Board forum software such as Simtropolis.

After trying other downloads in the STEX, I again spotted in the Mods & Tools another spooky IPB file piggybacking on the download popup for the DAMN Manager 1.3.1 by yild:

z5Vop49.jpg

Coincidently, these are not only in the same Mods & Tools section with the SC4DataNode tool, but they are also sequentially linked such that you can browse directly from one to the other in the STEX using the "Previous" and "Next File" buttons within each page.

These are older files that have been on the STEX through several upgrades and several attacks on Simtropolis...could they be something that was missed in the cleanup, or are they something new?  I suppose it could be something on my own system, and so I'll do all the usual scans, but I won't dare to actually download the files to see what they may be.  I see them both on Chrome and IE, when either logged in or logged out of Simtropolis, and even on my Android smartphone.  Does anyone else see these mystery downloads or recognize what they may be?

Hmmm, they've copied the filesizes of the ZIP downloads, and the one in the DAMN Manager ever borrowed parts of its name...am I being overly paranoid, and are these simply just alternative versions of the tools for, uh, Apple iPhone users?

 


  Edited by Odainsaker

Share this post


Link to post
Share on other sites

Damned good question.  I am at a loss as to why a PC gaming site should support anything related to phones other than browsing. What say the STEX moderators?

Share this post


Link to post
Share on other sites

I'm not sure if this is a bug or not, but one of my downloads for the Rural GLR is showing in the STEX as having only 1 star. When you open the page it's listed with a rating of 4.71 stars. This is quite irritating, as this mod had one negative review from someone who clearly didn't read the readme. Is there any chance someone could fix this for me please?

Share this post


Link to post
Share on other sites

@Odainsaker

Thanks for the report.

I've taken a look at the files you mentioned.

After checking (in a sandbox environment), I'm fairly certain these IBP files refer to a previous version of the upload.

When editing their files, authors have the option to upload a new version of the archive (e.g. zip, rar). On the editing page, there's also a checkbox which can preserve the previous versions. If so, these are able to be selected and downloaded separately, at the bottom of the description -- the dropdown named "See changelog". If you're familiar with Firefox, it works a bit like the versioning of addons on Mozilla's exchange.

The reason why they I believe they're a previous version is because of the file size.
For example:

With the SC4DataNode, the v0.93 file:  SC4DataNode v0.93 Installer.zip  (1,085kb)

This has a matching size to the IPB file named:  3c9ca70d42f66f43cff4b4a4f1a4957d-.ipb  (1,085kb)

Then after changing the *.ipb file extension to *.zip, the file opened normally, and confirmed the two are identical.


I suspect they're named IPB because IP.Board is our community suite. The software must store them in this format, so it knows it's a previous version. Not sure why it's still showing with this extension... maybe it wasn't migrated properly since the site update earlier in the year.

As for the strange file name, I'd say this is just a random hash to make it unique.

Rest assured, there's nothing harmful about this format -- the extension is really superficial. It just seems a minor inconvenience for these older versions of files. ;)

-----------------
 

@rsc204

Thanks, think I've fixed that (check page 3).

Looks like the actual rating wasn't being linked to the stars. Please let me know if you notice any others.


  Edited by Cyclone Boom
Odainsaker likes this

Share this post


Link to post
Share on other sites

Don't know if you already note it, but the buttons in the post composer have their images changed: link has a cogwhell, cite a centered paragraph, code a smiley, emoticon a link chain and so.

Share this post


Link to post
Share on other sites

Hi @matias93

The editor has been modified with changes in the update, mostly to improve performance.

First of all, have you tried clearing your browser's cache? I suspect there might be something clashing with the old format.

There's also a couple of missing buttons to restore (e.g. insert images, YouTube).

matias93 likes this

Share this post


Link to post
Share on other sites

When I look at my profile activity, it seems I gave 1/5 rating to Porkie Props trees and a map from 2004... It's quite weird because I didn't do that.

It also seems that a bot posted reviews on the same files at the same time as a Guest.

I also took a look to other accounts and they also seem to post reviews on old stuff for no apparent reason.

 

Share this post


Link to post
Share on other sites

Hmm, that's interesting.

It's also the same on my profile, where STEX reviews are listed as posted "20+ hours ago".


After checking, here's my initial thoughts:

In one of the previous site upgrade (a few months ago), ratings on STEX files were converted into reviews.

As you'll know in the past, ratings were set without the need for a comment -- like how it works now in Gallery albums. This was the case for thousands of ratings, which accumulated over time. The thing is, old ratings mustn't have been stored with a timestamp. So when converted into reviews, only the rating showed with an 'unknown date'.

Since this latest update, it seems these old ratings (now reviews) have been reindexed. This means the system has gone through and assigned them all a date, which was previously missing. For example, if you check the NAM, or a file with a large sample, most reviews show as being posted yesterday.

Think this might explain what's happened.

Share this post


Link to post
Share on other sites

Ok, it explains this then.

But I still don't understand why I gave 1/5 to two files. So maybe I did it a long time ago, but it seems quite stupid with hindsight.

Share this post


Link to post
Share on other sites

I can't access the Status Update page at the moment.  When I use the bookmark I have, it results in a Page Not Found error. The button to create a new statuses is still available in the "Create" menu up top. Is this a issue, or have status updates been removed?

Share this post


Link to post
Share on other sites

Clearing the cache definitely fixes a problem I was having.  I like the improved look.  Pink was definitely not my colour.  Also, has anyone noticed besides me that we now have automatic hyphenation?  Neat.

Share this post


Link to post
Share on other sites

You cannot upload image links (I use ImageShack) in the Cities: Skylines CJ section.  There is no longer an "image" icon in the taskbar.  If that is a feature of the last upgrade, it's game over for my CJ and likely the rest of the forum-based ones as well.  If it's a problem, could we have some more information, please.  I logged out of ST and logged back in to see if there was something at my end, but no luck.

Please, Obi-Wan (whoever the designated staffperson is to deal with this stuff), you're our only hope.

 

David

Share this post


Link to post
Share on other sites
2 hours ago, dedgren said:

You cannot upload image links (I use ImageShack) in the Cities: Skylines CJ section.  There is no longer an "image" icon in the taskbar.  If that is a feature of the last upgrade, it's game over for my CJ and likely the rest of the forum-based ones as well.  If it's a problem, could we have some more informatrion, please.  I logged out of ST and logged back in to see if there was something at my end, but no luck.

Please, Obi-Wan (whoever the designated staffperson is to deal with this stuff), you're our only hope.

 

David

Check the button 'Insert other media'. It has an option to add images via URL. I understand the image button would eventually return, but meanwhile, there's an option.

Random SC4 image for testing:

CiudaddelLago-17Oct29751420169342_zps969

Yes, it works

Share this post


Link to post
Share on other sites

SmilieCanada.gifWell, well.  The image box does seem to be absent at the moment.  But I was able to insert this smilie from my private site, so the "Insert other media" box works.

Share this post


Link to post
Share on other sites

I couldn't answer to topics at all some hours ago, so this works again.

One other thing: After I quote something and then start typing after getting the cursor out of the quote box, the text input is backwards. I can go out of the browser window and back in again, and then it works normally.

Share this post


Link to post
Share on other sites

We'll get onto restoring the insert image button, and also the one for YouTube videos.

I think these are both custom buttons which aren't in the default setup.

There's still a few other things to fix around the site. Please let us know if there's anything else missing / not working.

Share this post


Link to post
Share on other sites
7 hours ago, matias93 said:

Check the button 'Insert other media'. It has an option to add images via URL. I understand the image button would eventually return, but meanwhile, there's an option.

Random SC4 image for testing:

CiudaddelLago-17Oct29751420169342_zps969

Yes, it works

Hi Matias- Nope.  Doesn't work for me.  I either get a) a non functional full link in text; b) a non-functional truncated text link; c) a little tiny box that has 0x0 dimensions and cannot be edited; d) a repeat of my first image; or e) nothing.  I'm stymied.

 

David

Share this post


Link to post
Share on other sites

I'd like to suggest that the hyphenation algorithm is too tight.  I don't think you should hyphenate vicariously after only two letters.  This is some kind of European convention and it doesn't work well with English which really needs syllabification:  that is, the hyphenation occurs only at complete syllables.

Share this post


Link to post
Share on other sites

OK folks, it's time to step up.  The Cities: Skylines CJ section and, as best I know, the rest of the forums, have been broken for uploading more than one image for almost a week now.  Part of that time was maintenance, I know, and that's understandable.  But, as a result of that maintenance, the upload image" icon is now gone from the edit toolbar.  Using the "Insert other media" button will sometimes allow you to upload one image, as below, but subsequent images are either ignored when uploaded, or upload as 0x0 boxes that cannot be edited (see below), or as a non-functional truncated link.  Something is broken.  You know that.

lZxcgi.png

gRdPhm.png

a5CVqA.png

I just took a screenie of the above which I was able to post through [ Ctrl ] [ C ].  Go figure.

 

UPDATE- Nope.  The screenie, which was above this line, disappeared when I posted.  I will put it into ImageShack and post it in just a moment.  -de

Doing that as a workaround won't work, though, because it uses ST's bandwidth.  All my images have been on paid ImageShack for years, so all one of my posts here needs to do is process links.  That's not happening.

The Cities: Skylines CJ forum, if not on Death's door, was at least in the intensive care ward before this started.  90%+ of the CJs there are dead, most abandoned by the authors without explanation.  Often the only entries in those CJs were made by the author- commenting is down hugely from a decade ago, and that's on CJs done in the biggest thing that has come along since SC4.  How much longer do you think it will be before the remaining active authors, unable to post new content, simply call it a day and walk?

I've been involved in website administration long enough to know that some problems aren't solved with a snap of the fingers.  A couple of days, a couple of weeks even, might be needed to address something complicated.  That's not unreasonable.  What is unreasonable, though, is the complete absence of substantive communication from staff/management, if not out in the open at least by DM to those who are impacted, explaining in appropriate detail what is going on.  It's time to address that situation.  Please.

 

David


  Edited by dedgren

Wordsmithing/Update

Share this post


Link to post
Share on other sites

KK%20Dragon.jpg

JohnNewSig.gif

moose.gif

This little experiment shows that you cannot insert more than one separate image on a given line.  If the need is for a "mosaic" I guess it will have to be composed externally and inserted as a single image.

Share this post


Link to post
Share on other sites

One thing I've just found out is that the features slider does not move automatically and cannot be moved by the user. It is stuck on the first one feature. Also, of some weird reason, my latest CJ entry does not show up on the City Journals main list, but appears in the side bar.

Note here how the first three in the main page go back to BTT,  but mine is missing, however it appears in the sidebar.

566dcb12285ae_ScreenShot2015-12-13at19.4

dedgren likes this

Share this post


Link to post
Share on other sites

The CJ section has a similar problem to. I hope the admin and mod guys are working on this. Otherwise the CJ section and forums are going to be a bit dead.

_Michael and dedgren like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Similar Content

    • By TekindusT
      I was just taking a look to the Milestone thread and realized I have no idea what those stars under our usernames and ranks in the forums mean. Sure they have a logic behind but it's a bit difficult to see for me, except that the users with most posts have their first star inside a shield or inside a banner...? But why some users with less posts have 5 stars and others have only 1 but the first one is shielded... ? Are they tied to our post count? You get it. Any Simtropolite ready to shed some light on this matter for me?
    • By manueld832
      So I started building RHW(new to RHW btw) to reduce regional traffic then I notice that the trucks are constantly changing lanes or doing a zigzag movement........please help!!! 
      Here's a photo https://www.dropbox.com/s/6gij4k6il26idqj/20170329_232144.jpg?dl=0
    • By mike_154
      i want to donate money to you guys,for your great work here at simtropolis, but i can not because paypal is not responding.Why dont you guys make an open pay system for credit cards,then we do not need this hassle. 
    • By Cyclone Boom

      Our friends at GOG.com had a special City-Builder discount sale!  (Closed as of February 13, 2PM GMT) 

      As part of this, Simtropolis has been given a bunch of free keys to selected games to give away!
      Winners announced here!

      If you want one of these games, simply reply to this thread by answering ONE of the questions below:
      What's your favourite city-building game, and why will you always be fond of it? Write a creative and entertaining review (good or bad) of any city-building game. The ways in which custom content has transformed the city-building game you play. Tell us about your most memorable city-building experience, funny, tragic or otherwise.
      There is no minimum or maximum, but aim to write at least 50 words.
       
      FAQ

      Q: How are prize winners selected?
      A: The Admins will pick their favourite replies below, so don't delay, post away!
      Q: How many times can I reply?
      A: Just one reply per person please.
      Q: Can I add images or video to my post?
      A: Sure! Feel free to be creative to make your post stand out.
      Q: Does it have to be written in a certain style?
      A: No, not at all. Just aim to make it creative and entertaining, whether fact or fiction...
      Q: How long does this run for?
      A: The closing date to enter is Monday 13th February at 23:59 (EST).
       
      Prizes

      Winners will be able to select ONE of the following City-Building classics, to add to their personal collection:
       
      Caesar
      1993

      SimCity 2000 Special Edition
      1995

      Caesar II
      1995

      Pharaoh + Cleopatra
      1999

      SimCity 3000 Unlimited
      2000

      Emperor: Rise of the Middle Kingdom
      2002

      Banished
      2014

      Tropico 5
      2014

      Lethis - Path of Progress
      2015

      Urban Empire
      2017

       
      Whatever your experience with a City-Builder, we'd love to hear it.
       
    • By Cyclone Boom
      Got some ideas?
      Here's a place where you can recommend any improvements to Simtropolis. 
      It's about time we had one of these. Even though the site continues to develop, we'd love to hear your thoughts on how it can be further refined and made better for everyone. Whether it be a simple layout/design tweak, or a completely brand new feature, post away in this thread!
      While we can't promise everything will be possible or implemented, each idea will be read and considered. I'm sure you'll appreciate there are limitations, both technically and financially.
      To report any issues with an existing site feature, or something not working as intended, please instead use the Bugs Thread.
       
      Guidelines
      For clarity, please keep one idea per post. Double posts are acceptable if you've more than one idea at once.
      Note: To prevent successive replies from auto-merging, you may need to wait 5 minutes.
        Give a subheading, describing briefly what the idea is.
        Explain the idea -- it helps to give as much detail as possible. Pictures or diagrams are acceptable, but not required.
        Why would this be of benefit to the community?
        If you value anyone's idea, please Like it to show your support. This helps to give a rough indication of how well an idea is received.
        If commenting on an idea, please quote/copy the subheading so it's clear what is being discussed.  
      Progress Status
      Once processed, ideas will be tagged with one of the following:
       
      NOT PLANNED -    The idea is appreciated, but at this stage, is not feasible to implement.
        INTERNAL REVIEW -    We like the idea, and will pursue whether it's currently feasible to implement.
        PLANNED -    We have decided to implement the idea, and are finding the best ways to go about it.
        IMPLEMENTED -    The idea has been added as a new site feature!
      This will change depending on ongoing progress with implementation.
       
      Thanks all!
      -The Admins
  • Recently Browsing   0 members

    No registered users viewing this page.