Jump to content
Sign in to follow this  
simulous

sim city stops/crashes (No error displayed)

Recommended Posts

can someone help me please find the log file for simcity 4 deluxe. Been having an issue were the game just randomly stops and i loose all my progress. Im using windows 7 ult x64 Which is also a completely new installation. I was having the same issue before the software rebuild and im still getting it. What i have done so far is apply the most recent game patches, run simcity4.exe as an administrator (even though my account is a member of the administrators group, and also disabled desktop composition, which did actually make a difference but its just happened again so i think i need to check out the log file and see what's happening. Also, ive disabled my AV to no avail. Any help would be greatly appreciated. 

 

Also tried different display drivers (just a bog standard intel Q43 display adaptor) 

Share this post


Link to post
Share on other sites

There is no log, and the dump in documents/SimCity 4/Exception reports is what you get.  However, if you will post the first 20 lines of the most recent one (use the .txt file), we can find out some things about your version of the game that might be enlightening.

 

For Windows 7, the option -CPUcount:1 should be added to the target line of the starting short cut.  You should do an internal save (CRTL+s) every time you'd like to have a clean point (only saves the last one).

 

You might want to look over all the possible options.  Here they are.  A modern machine with a 16:9 screen will need some extra stuff.\

 

FYI, here is my command line:

 

"C:/Program Files (x86)/Maxis/SimCity 4 Deluxe/Apps/SimCity 4.exe"  -intro:off -CustomResolution:enabled -r1920x1080x32 -d:directx  -f -CPUcount:1

 

I am on Linux, so you need to change the slashes in this to backslashes (\) for NTFS.

 

Also remember that this program hasn't been touched by the developers since 2003.  All the custom content has been created without altering the text of the program, and we have agreed to not do that, and to refrain from reverse engineering it.

Share this post


Link to post
Share on other sites

Also, try running the program on a single core. Open SC4, then open task manager. Right the process in task manager, then hit set affinity. Deselect all CPUs except for one.

 

SC4 was written ten years ago, and is designed to run on mostly single core PCs. It doesn't "know" how to handle multi-core processors properly, and this can result in random crashes to the desktop.

 

You'll have to do this everytime you open SC4, though. I don't know of any way to permanently set a program's affinity.

Share this post


Link to post
Share on other sites

I don't know of any way to permanently set a program's affinity.

 

> Right click on the SC4 icon

> Select 'Properties'

> In the target box (where it says "C:\Program.....SimCity 4 Deluxe") add the text: -CPUcount:1

> Make sure there is a space between the original text and the text you've just added

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:

Register a New Account

Sign In  

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×