• Moose
  • Announcements

    • Dirktator

      Please help us for July   06/30/2017

      This month we're hoping for a little bit of a boost this month or next, in addition to covering the regular bills, we could benefit from some hardware upgrades. STEX Collector's Set gifts can now be sent to you via digital download as well as regular mail if you wish! Every donation dollar goes toward keeping Simtropolis online and humming along. Your contribution counts! Hardware Upgrades As our website community software improves with more and more features, and as we bolt on additional features such as chat, the increased load to handle all these new toys is taking the server a bit to task. You may have noticed that we'd been forced to temporarily disable the chat as we worked out allocating resources for more optimal performance. Following this, we've applied a number of 'soft' changes such as caching options and experimented with server configurations (nginx as proxy, for example), so the hardware aspect is also an area we'd like to focus on. The last time we upgraded hardware was back in 2012, prior to the release of SC13. Your contribution means a lot! Your donation will go toward helping us to 1.) migrate to a newer server or 2.) at least get some ram/cpu/storage updates and any other infrastructure hardware or services. Donate and Get a Gift or Donate Any Amount Thanks so much! - Dirktator & The Admins
oppie

SimCityPak - Modding Tool

622 posts in this topic

@reReticulated Spline: Yeah I watched that while trying to load the Instance names etc, did a fresh install, tried to build the project myself in vs2010 and still no joy. Seems my pc falls under the category of some of the other users on here and it just wont work. Its not through people's lack of trying, even oppie couldn't figure out some of these strange errors. I'll keep my fingers crossed I can use it in the future and just keep track of new SimCityPak releases to try.

Share this post


Link to post

Please help me! What am I doing wrong? Or mirror UV-maps will inevitably cause a glitch for the lights on meshes with normal maps? Example on images below:

qp18ci.jpg

 

 

 

 

 

 

 

 

 

 

 

ADDED 03 june 2014:

If you try to export model ID 0xc7c12969 (or any other railway path) to wavefront.OBJ format, SimCityPak crashes with an error "CLR20r3" (53809df7; System.Core; 4.0.30319.33440; 5200436c; 43e; 4d; System.InvalidOperationException; OS Version 6.3.9600.2.0.0.256.48; Language code: 1049).

First of all, it's looks like your Normal Map is incorrect. You should invert the "Y".

Share this post


Link to post

FYI we are waiting on oppie to free up some time to work on some bugs and improvements to SCP.  He's been extremely busy and hopefully will have time in the next week or so.  I know he told me 2 weeks 3 weeks ago but his schedule is so all over the place its hard for him to cut out time for the SCP while he is working on multiple things

 

Hopefully we will be able to look forward to a 4.1 and more soon

Share this post


Link to post

I'm extremely uncomfortable, have absolutely no confidence to the point of paranoia when it comes to modding in ANY game which is why I never tried. I can work around almost all of the games weaknesses(poor AI and behind the scene math) but if the only change I wanted to make was to double the amount of goods each lvl and density of  commercial buildings produced, what would I have to do? What would I use and what file would contain such info. Obviously someone called Nikolai has managed to do it but a few people have apparently tried speaking to him to alter some of his mods and he's either ignored them or outright refused. Whatever floats his boat is all I can say. If It's something as simple as opening the mod tool, opening the file containing the basic info and altering a few numbers, (like you'd do in some mods like the ones used in CIv4 where you simply open the file in wordpad or some such, edit the values, save the file, close it the either import it or replace the original file with the altered one) I can do that. Certainly helped get rid of that annoying Global warming crap in CIV 4 lol. Anything more complicated and fuggetaboudit!

Share this post


Link to post

Man... I either get half english half dutch or I get a bunch of numbers and letters

Share this post


Link to post

I downloaded this and got stuck on the very first step of figuring out which directory was needed for what in the configuration, and I never saw anything on YouTube about how to populate that information.

I'll wait until it's a bit more advanced and ties all those bits together for us during installation.  ILivesReader for SimCity 4 was a heck of a lot easier for me to figure out.

Share this post


Link to post

Hi,

 

I have read the tutorial for SimCityPak. I have open the "Simcity_Game.package", selected the "Property file" and after opening the "Pedestrian Path", i have an error "Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information". Can you me help to solve the problem? Thanks in advance.

Share this post


Link to post

Hi guys!

 

Could anyone tell me how to edit 0x622b9cd7 "The Global file" (using version 4.0.0) without it causing the Game to crash? seems the compression is lost after edit. But so is it for all other .package files you edit, is it not?

Share this post


Link to post

OS X (Mac) support. I would like to contribute to making this tool cross platform. How can I do this? I know .NET open sourced their stuff so it will compile on MAC/Linux. 

 

Thanks

Share this post


Link to post

Hi

 

Having spent some time looking for info regarding industry freight adjusting (existing mods did not felt quite right), only to find it's quite scarce, I return to post my findings here, to whom it may still concern (don't know if there are still people playing this or they all moved to cities skylines).

 

Industry buildings are found in ...\Origin Games\SimCity\SimCityUserData\EcoGame\SimCity-Scripts_287520926.package, and required instances are:

 

low tech industry: 0x0846121c, 0x483fbb03, 0x4841fa6a

medium tech industry: 0x608c65c3, 0x20944fdc (however it is found as "btn_pause_scale_activeHighlight"), 0x20921175

high tech industry: 0x9fc315e2, 0xdfc5b88d, 0x9fc792d4

 

After opening these instances, the required properties are: 0x0C0F20DB - after how many in-game minutes the factory produces another batch of freight, and 0x0C0F20DC - the quantity of freight produced.

for example, low density industry produces by default 3 freight at every 72 minutes, meaning 1440 minutes in a day / 72 = 20 batches of 3 freight, ie. 60 freight per day.

medium density industry produces by default 4 freight at every 48 in-game minutes, and high density industry produces 6 freight at every 36 in-game minutes.

 

So, to increase production, either increase quantity of freight for each batch or decrease the time it takes to produce it.

 

After creating the required packages (please be sure to follow the SimCityPak's creator instructions regarding tool usage so you do not break your game), place them in SimCityData folder, copy

SimCity-Scripts_287520926.package in SimCityUserData\Packages folder and:

- if you start a new game: play for a few moments, save, quit, reload - that will load the new production values. however, for the total freight production to appear in "population detail" info panel you must also buldoze the established industry.

- if you load a saved game: only buldozing industry is necessary.

 

That's about it. If someone has any questions, feel free to pm me, I'm not very knowledgeable at moding but I will answer to the best of my findings.

Cheers.

Share this post


Link to post

Great stuff. Quick question, do you know if those modifications are compatible with online play? 

Share this post


Link to post

@ Athorium i had the same problem when changing computer i found this worked for me! Think it was mayor magnus on simcitypak help post Well, I finally figured out why I could not run SimCityPak without getting the aforementioned error.  Someone posted at CodePlex that you need to have http://www.microsoft...s.aspx?id=20914 installed.  Apparently the XNA DLL that comes with the program is not the final solution.  Now I can finally view property files. all credit goes to him for looking it up on codeplex.

Thanks Little Harty, it works for me!

Share this post


Link to post
On 12/10/2014 at 0:03 AM, tornero57 said:

Hi,

 

I have read the tutorial for SimCityPak. I have open the "Simcity_Game.package", selected the "Property file" and after opening the "Pedestrian Path", i have an error "Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information". Can you me help to solve the problem? Thanks in advance.

See old post: get this installed: https://mxa.codeplex.com/wikipage?title=How install XNA 4.0 on Visual Studio 2012

 

Share this post


Link to post

Greetings people

I am currently investigating the RCI ploppable feature in the akar mod in which you can just plop any RCI building construction site(which will be be built of course) and I wanted to make a personal mod out of it  in which I need to pay some amount of cash to place the ploppable ( instead of it being free ). I have struggled all day using SCP trying add the property scUnitConstructionCost and fix some value to a random item but it doesn't seem to work. When load my game, that plop is still free.

Would you know how to do this?

Regards

I know that the author of the bench park mod could create a bench and set a fee of $100.. and it works every time I modify that value

Here is a pic

000103.png

Share this post


Link to post

I'm getting the following error when trying to load the locale file:

An error occurred when trying to load instance names from your locale file: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

 

Any help please?

error.PNG

Share this post


Link to post

As this was working perfectly fine before, I simply did a fresh install of SimCity and the PAK and it works... who know's what was wrong but I got there.

Share this post


Link to post

Hiya. Pardon my intrusion here, but one thing I noticed:

On 8/27/2016 at 8:18 AM, mehere said:

Goes to a page which is shutting down completely on December 15, 2017. Here's a screenshot of that page for reference once it's no longer available:

5965417bc416c_MXAShutdown.jpg.a36ef8e8f8826fb3d48ee75247dae5b9.jpg

The specifics are stated in Brian Harry's blog. So, if any of this is still relevant, y'all might need to re-find the stuff on GitHub and post linkys. *;)

 

Snowy0230 likes this

Share this post


Link to post

you are quite right, I installed this this morning before the fresh install after reading the modding guide but didn't realize that was my fix. You are a star @CorinaMarie Thank You!!

CorinaMarie likes this

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now

  •  
  • Recently Browsing   0 members

    No registered users viewing this page.