Simtropolis Help Squad

How To Install STEX BATs, Lots and Maps

89 posts in this topic

I think there should be a warning that rendering a map will reset tutorials. So you should back up those cities! (lost my huge Rush Hour Tutorial this way)

Share this post


Link to post
Share on other sites

I tryed how to upload the ST EXchange but it still will not work.:???: Can you help me?:???:

Perhaps try at a different time. If still doesn't work, you might post the specific issue here.

Share this post


Link to post
Share on other sites

Ok i'm new to the site and installed a bunch of lots that have in their description "no dependency" and have extracted them into my plugings folder, yet I cannot find them under any of my ingame menus am i missing something, is bat editor and lot editor required for the use of custom plugings?

Share this post


Link to post
Share on other sites

Welcome to Simtropolis...

No, you don't need the BAT or Lot Editor to use custom content. A couple things to check...

First, when you say "extract", you mean that you "unzipped" the downloads before placing them in the Plugins folder. Zip files won't be read by the game.

Second, what specific items are you trying? You may have downloaded what are known as "growables". These types won't appear in the menus.

Share this post


Link to post
Share on other sites

The map part i don't really understand,I need pictures to see what to do.

Share this post


Link to post
Share on other sites

WHERE I HAVE TO DOWNLOAD LOT FILES IN SIMCITY 4. i have downloaded few of them from this site but i don't know where to paste these files in simcity 4 can some one help me

Share this post


Link to post
Share on other sites

Welcome to Simtropolis...

WHERE I HAVE TO DOWNLOAD LOT FILES IN SIMCITY 4. i have downloaded few of them from this site but i don't know where to paste these files in simcity 4 can some one help me

Other than maps, files downloaded from the exchanges need to be unzipped and place in the My Documents/SimCity 4/Plugins folder. You might check for specifics.

Share this post


Link to post
Share on other sites

  • I'm trying to render one of the maps i downloaded and used the ctrl alt shift r method, selected the JPG file and it still will not load. It still stays a plain.
  • Thank you.

Share this post


Link to post
Share on other sites

Does the cursor change to an hour glass? Also, there are different map formats. Are you sure it is the types that requires in-game rendering? Which map is it (link or exact name)? There could be an issue with the upload. It's rare, but does happen occasionally.

Share this post


Link to post
Share on other sites

Windows XP and up can open compressed folders and have them act like regular folders by default. You would just select the files you want to copy into the plugins folder, and do so regularly (right click menu or dragging).

You can also use a decompressor program, like {7 Zip}.

Share this post


Link to post
Share on other sites

Hi, I am new to the site and need some help. I go to the ST/ Exchange and download a file from the BAT section. After that, I get taken to WinRAR. When I go to extract the files an error message appears saying access is denied. Where am I going wrong? Thanks for the help.

Edit: Problem Solved.


  Edited by cwong

Share this post


Link to post
Share on other sites

Then you need to do the following:

  • Go to city, use query tool and find the name of the Bat/Lot that is giving you a brown box
  • Search up the file on the exchange (stex, lex, plex...)
  • Make sure you have ALL listed dependencies
  • install any missing dependencies

When you get back to the city after doing this, the box should be gone, if not: repeat all steps listed above

(sure I made those steps as a list, ST bug going on?)


  Edited by yarahi

Share this post


Link to post
Share on other sites

i can't seem to get any of the custom regions to work. once i have downloaded it and added into C:\Program Files\Maxis\SimCity 4 Deluxe\Regions everything goes fine. but when i start the game and look in the list of regions, the name/folder doesn't appear at all

Share this post


Link to post
Share on other sites

This might sound like a really daft question but, do I have to leave the image files in the plugin folder or can i remove them the same as the text files and just leave the other data files in place?

Thanks :???:

Share this post


Link to post
Share on other sites

I still do not get it completely regarding BAT, LOT and Props.

BAT = just the graphic without any dependencies included?

LOT = Graphic + functional + (most) dependencies?

Props = Small graphics used by BAT & LOT (i.e. dependencies)?

And I tried to render a region, Capenewham AK is the name I believe. It has a ~700 kB jpg, how longish does it take to "render" (CTRL+ALT+SHIFT+R) in SC4? It was busy 2 hours yesterday untill I lost my patience....CPU is an AMD 5600+ X2 (2.8GHz) and 4GB Ram .

Share this post


Link to post
Share on other sites

I have a problem and i don't know if it's becaouse my windows 7 isnt in english but whenever i want to render a map i pres ctrl+alt+shift+r the window pops up but it doesnt allow me to go into documents and settings in order to get to the bmp file, can someone haelp me ?

Share this post


Link to post
Share on other sites

This might sound like a really daft question but, do I have to leave the image files in the plugin folder or can i remove them the same as the text files and just leave the other data files in place?

Thanks :???:

Image and text files can be removed from the Plugins folders and stored at another location. The game reads all files in the Plugins, but only uses certain ones, so if there were a large number of these 'extra' files, the game could take a little longer to load. The only files required to be in the Plugins are those with prefixes ending in lot, desc, model, or dat.

Share this post


Link to post
Share on other sites

I have two bad links to report in the OP at the top of this thread...

The links in : How to Fix Missing Props and Buildings and in I see all the props on a downloaded lot from the STEX, but the building, why is this happening? are broken because Apple MobileMe is now closed.

Share this post


Link to post
Share on other sites

I read, understand, and utilize the sorting of folders explained here, and I appreciate taking the time to give that information. However, I have a question about the possibility of even further organization of the DLC.

My question is this; Is it possible, either by folder organization or file modification, to have the addons more organized IN GAME? For instance, I would like to have, in the IN GAME menu, all the restaurants grouped together, all the gas stations grouped together, all the parks grouped together and so on. So all the restaurants would be, say, at the top of the sub menu for landmarks. Under that, the next group of landmarks would be the gas stations etc.

Is this possible?

Share this post


Link to post
Share on other sites

It is based on the type of the map

If the map is a SC4Region file then simply extract them to the region file in the documents.

If the map is a grayscale map, then you must render the bmp. file first before you could use it.

However, some maps will need SC4Mapper to work.

If you need more information, read this article.

Share this post


Link to post
Share on other sites

Im new to this and not sure how to install the depencies.....at the moment im using the non dependencie lots which are great, but there is some cool ones i want to get my hands on.........help!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  :thumb:


Register a New Account

Sign In  

Already have an account? Sign in here.


Sign In Now


  •  
  • Recently Browsing   0 members

    No registered users viewing this page.