Jump to content
Sign in to follow this  
DamienM23

Game crashing when moving from region to city view

2 posts in this topic Last Reply

Recommended Posts

Okay, so my game, SC4 Deluxe, keeps crashing EVERY time I go from Region view to City view. I am running Windows 7 and have all relevent updates. I have never had this problem before, but it started after I did three things:

1. I installed several mods from trusted sites

2. I deleted my terrain, which was Cycledog's Italia terrain mod.

3. I installed PEG's MTP terrain

The game worked fine before that, so I isolated the variables. I removed all plugins on and after the date I first noticed the bug. Went in-game, same problem. Deleted ALL terrain mods in my plugins folder, which I expected to leave me with the default Maxis terrain. However, I still encountered the same problem. Finally, I uninstalled the game, and re-installed it. I still have the problem. It occurs on established cities, New Cities, and on unrendered cities saved in Terraformer. I have exhausted my knowledge and need help. I thank you for your time

Share this post


Link to post
Share on other sites

Cities crashing in such a manner as yours could be caused by a couple different things - incorrectly installed/uninstalled seaports, airports, or terrain/tree mods. Also, removing plugins still in use by the game, could cause crashes when opening cities that used them. Since you mentioned you completely re-installed the game and the problem continues, did you keep the cities you had used before, or did you try never-before used cities without any plugins in use?

If you are trying the same cities after a fresh install, I would probably focus on the terrain mods you had removed/changed. Did you use any special tree mods with Cycledogg's terrain mod? If so, did you remove any trees from the cities that were planted while the mod was in use? That can be a cause for crashing. Did you try putting your original plugins back in and see if the citiy opens?

Of course, if the crashing is occurring on brand new cities with no plugins, then perhaps it is software/hardware issue. In that case, posting your computer specifications might help get specific assistance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an Account  

Sign up to join our friendly community. It's easy!  

Register a New Account

Sign In  

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

volume5_md.pngPlease help us reach our September Goal!

Your contribution helps keep Simtropolis up and running!

Please consider a donation today.

We need to continue to raise enough money each month to pay for expenses which includes hardware, bandwidth, software licenses, support licenses and other necessary 3rd party costs.

By way of a "Thank You" gift, we'd like to send you our STEX Collector's DVD. It's some of the best buildings, lots, maps and mods collected for you over the years. Check out the STEX Collections for more info.

Each donation goes to help us keep the site running free.

Enjoy the site!

OK - See STEX Collections